Clicky

Jump to content
Portal do Host
  • Sign Up

Sign in to follow this  
rodrigo286

Cagefs

Recommended Posts

Pessoal, comecei a usar o CageFS, e logo de cara já tive um problema, ele não roda o Wordpress, pensei que seria apenas alterar alguma config, procurei e não achei nada e para ajudar o problema que no menu do WHM só tem a opção de ligar o CageFS e adicionar e remover contas, nada sobre alterar as configurações do plugin.

Obrigado.

Share this post


Link to post
Share on other sites
5 horas atrás, rodrigo286 disse:

Pessoal, comecei a usar o CageFS, e logo de cara já tive um problema, ele não roda o Wordpress, pensei que seria apenas alterar alguma config, procurei e não achei nada e para ajudar o problema que no menu do WHM só tem a opção de ligar o CageFS e adicionar e remover contas, nada sobre alterar as configurações do plugin.

Obrigado.

Amigo, ele roda o Wordpress tranquilamente! O CageFS apenas isola cada usuário dos demais permitindo que você tenha total controle individualmente.

Dá uma olhadinha bacana nesse link:

Gerencio um cliente que usa CageFS em mais de 100 sites Wordpress.
Obs: Recomendo que você também instale o LVE Manager

Referente ao wordpress, qual está sendo o problema em si?

  • Like 1

OwnServer | Soluções Corporativas & Gerenciamento de Servidores | www.ownserver.com.br

Share this post


Link to post
Share on other sites

Então pessoal, aqui ao ligar o CageFS, o wordpress retorna o erro: Failed to exec

Se eu retirar o usuário do CageFS, volta ao normal, isso ocorre com qualquer Wordpress, seja com instalação nova ou já instalada.

Já procurei mas não encontrei nada, alguém tem ideia do que pode estar ocorrendo.

Abraço.

Share this post


Link to post
Share on other sites
1 hora atrás, rodrigo286 disse:

Então pessoal, aqui ao ligar o CageFS, o wordpress retorna o erro: Failed to exec

Se eu retirar o usuário do CageFS, volta ao normal, isso ocorre com qualquer Wordpress, seja com instalação nova ou já instalada.

Já procurei mas não encontrei nada, alguém tem ideia do que pode estar ocorrendo.

Abraço.

Estranhíssimo, o que você pode fazer é entrar no helpdesk.cloudlinux.com e abrir um ticket com os caras.
Eles respondem relativamente rápido e lhe passarão as instruções para resolver e/ou solicitarão acesso para verificar e resolver para você.

 

  • Like 1

OwnServer | Soluções Corporativas & Gerenciamento de Servidores | www.ownserver.com.br

Share this post


Link to post
Share on other sites
49 minutos atrás, owsbr disse:

Estranhíssimo, o que você pode fazer é entrar no helpdesk.cloudlinux.com e abrir um ticket com os caras.
Eles respondem relativamente rápido e lhe passarão as instruções para resolver e/ou solicitarão acesso para verificar e resolver para você.

 

Claro que depois disso você posta aqui a resolução do problema para todos acompanharem, certo @rodrigo286! ;-)


"- Isto fica feliz em ser útil!" ;)     ->  Ajudei? Dê um "Curtir" aí no post!

Share this post


Link to post
Share on other sites

A sim, sempre que tenho uma resposta eu coloco aqui.

No caso eu refiz minha build do Easy Apache 4 para a seguinte, que me foi indicada em outra duvida que tive aqui no forum:

Citar

Apache 2.4

config

config-runtime

mod_asis

mod_bwlimited

mod_cache

mod_cache_disk

mod_cgi

mod_deflate

mod_env

mod_expires

mod_file_cache

mod_headers

mod_hostinglimits

mod_lsapi

mod_mpm_prefork

mod_proxy

mod_proxy_fcgi

mod_proxy_http

mod_remoteip

mod_security2

mod_socache_memcache

mod_speling

mod_ssl

mod_suexec

mod_suphp

mod_unique_id

mod_version

tools

PHP 5.4

libc-client

pear

php-bcmath

php-bz2

php-calendar

php-cli

php-common

php-curl

php-devel

php-fileinfo

php-ftp

php-gd

php-gettext

php-iconv

php-imap

php-intl

php-ioncube

php-litespeed

php-mbstring

php-mcrypt

php-mysqlnd

php-pdo

php-pgsql

php-posix

php-soap

php-sockets

php-sourceguardian

php-tidy

php-xml

php-xmlrpc

php-zendguard

php-zip

runtime

Others

apr

apr-util

cpanel-tools

documentroot

libcurl

libmcrypt

libtidy

modsec-sdbm-util

php-cli

profiles-cpanel

 

E tenho os plugins CageFS, Comodo WAF, CSF, ClamAV, Easy CP Backup 3.6, Engintron e Pyxsoft Anti Malware.

Depois de refazer a build do Easy Apache 4 o erro mudou para 500, agora aparece Error 500.

Vou mandar um ticket mas ainda vou tentar resolver sozinho.

Abraço.

Share this post


Link to post
Share on other sites
2 horas atrás, rodrigo286 disse:

A sim, sempre que tenho uma resposta eu coloco aqui.

No caso eu refiz minha build do Easy Apache 4 para a seguinte, que me foi indicada em outra duvida que tive aqui no forum:

E tenho os plugins CageFS, Comodo WAF, CSF, ClamAV, Easy CP Backup 3.6, Engintron e Pyxsoft Anti Malware.

Depois de refazer a build do Easy Apache 4 o erro mudou para 500, agora aparece Error 500.

Vou mandar um ticket mas ainda vou tentar resolver sozinho.

Abraço.

Veja o ERROR-LOG do wordpress para entender melhor o erro 500, pode se falta de memoria para o mesmo.


Ajude o fórum! Antes de postar, leiam as regras de postagem aqui.

Share this post


Link to post
Share on other sites

Então, o suporte do cloud linux fez funcionar, só que 5 minutos depois aconteceu novamente sem eu ter editado nada.

Então respondi o ticket e ela disse que rodou o seguinte comando:

Citar

cagefsctl --force-update

Esse comando eu já tinha tentado, por isso não sei por que funcionou, mas de qualquer forma o erro voltou logo depois e ela então diz ter ativado o suporte nível 2 e pediu para aguardar 30 minutos.

No caso @Anger, obrigado vou dar uma olhada no LOG, mas acho estranho por que só ocorre com o CageFS ligado na conta e pelo que olhei no Cloud Linux está configurado como 1GB de ram para cada conta.

Abraço.

#EDIT

O wordpress nem gera log de erros, realmente é muito estranho, vamos ver o que o pessoal do Cloud Linux fala.

Abraço.

Share this post


Link to post
Share on other sites

Resolvido pessoal...

A conta que estava com problema era a conta "mariano", inclusive a minha duvida é se essa correção que eles fizeram é para todas as contas, pelo que entendi sim, se eu estiver errado, por favor me corrigir.

Mandei outra mensagem cobrando e responderam da seguinte forma:

Citar

 

Hello,

You had this issue due to incorrect "fs.symlinkown_gid" option:
[root@phoenix ~]# sysctl -a | grep link
fs.symlinkown_gid = 1006

[mariano@phoenix root]$ /usr/local/bin/php -v
Default PHP version 54 not installed, exiting
ea-php-cli Copyright 2016 cPanel, Inc.
php_cli unable to execute php :-1: (2) :No such file or directory:
when attempting to run ()

To solve a problem I have changed it to "99"
[root@phoenix ~]# sysctl -w fs.symlinkown_gid=99
fs.symlinkown_gid = 99

[root@phoenix ~]# su -s /bin/bash mariano
[mariano@phoenix root]$ php -v
ea-php-cli Copyright 2016 cPanel, Inc.
PHP 5.4.45 (cli) (built: Apr 28 2017 14:38:13)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2014 Zend Technologies
    with the ionCube PHP Loader v4.7.5, Copyright (c) 2002-2014, by ionCube Ltd., and
    with Zend Guard Loader v3.3, Copyright (c) 1998-2013, by Zend Technologies

After this your site works fine. Please check it.

Best regards,

 

Uma outra duvida que não entendi é o erro que aparece na hora que ele vai arrumar que o PHP não está instalado, isso ocorreu por que o symlink estava incorreto, certo?

Bom, o importante que resolveu pessoal, espero que esses comandos sejam uteis se isso ocorrer com alguém, grande abraço.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×
×
  • Create New...