Jump to content
Limestone de cara nova! ×
Portal do Host

Acesso ftp sendo bloqueado


RevendaHost
 Share

Recommended Posts

Pessoal alguém já presenciou algo assim?

Um cliente não consegue acessar por FTP a conta dele no servidor. Esse servidor é dele, eu apenas gerencio.

Se ele tenta acessar pelo Filezilla retorna conexão expirada, se tenta acessar pelo browser ftp.dominio.com ele é redirecionado para a página padrão do cPanel. Aqui pra mim o acesso pe normal, tanto por Filezilla, quanto pelo browser. Testei em duas operadoras e mais a minha conexão da Claro, tudo ok.

Agora o curioso é se eu desabilitar o CSF o cliente consegue acessar pelo Filezilla, ou seja, o firewall tá bloqueando ele. Só que o IP dele não está bloqueado no servidor, inclusive ele consegue acessar normalmente o WHM e Cpanel, então logicamente não existe bloqueio.  Em resumo o CSF bloqueia o acesso dele somente por FTP!

Alguém teria ideia do que possa ser?

Link to comment
Share on other sites


  • Replies 7
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

1 hora atrás, RevendaHost disse:

Pessoal alguém já presenciou algo assim?

Um cliente não consegue acessar por FTP a conta dele no servidor. Esse servidor é dele, eu apenas gerencio.

Se ele tenta acessar pelo Filezilla retorna conexão expirada, se tenta acessar pelo browser ftp.dominio.com ele é redirecionado para a página padrão do cPanel. Aqui pra mim o acesso pe normal, tanto por Filezilla, quanto pelo browser. Testei em duas operadoras e mais a minha conexão da Claro, tudo ok.

Agora o curioso é se eu desabilitar o CSF o cliente consegue acessar pelo Filezilla, ou seja, o firewall tá bloqueando ele. Só que o IP dele não está bloqueado no servidor, inclusive ele consegue acessar normalmente o WHM e Cpanel, então logicamente não existe bloqueio.  Em resumo o CSF bloqueia o acesso dele somente por FTP!

Alguém teria ideia do que possa ser?

Já tentou conectar via FTP simples http://prntscr.com/ez5ti7

Link to comment
Share on other sites

1 hora atrás, RevendaHost disse:

Pessoal alguém já presenciou algo assim?

Um cliente não consegue acessar por FTP a conta dele no servidor. Esse servidor é dele, eu apenas gerencio.

Se ele tenta acessar pelo Filezilla retorna conexão expirada, se tenta acessar pelo browser ftp.dominio.com ele é redirecionado para a página padrão do cPanel. Aqui pra mim o acesso pe normal, tanto por Filezilla, quanto pelo browser. Testei em duas operadoras e mais a minha conexão da Claro, tudo ok.

Agora o curioso é se eu desabilitar o CSF o cliente consegue acessar pelo Filezilla, ou seja, o firewall tá bloqueando ele. Só que o IP dele não está bloqueado no servidor, inclusive ele consegue acessar normalmente o WHM e Cpanel, então logicamente não existe bloqueio.  Em resumo o CSF bloqueia o acesso dele somente por FTP!

Alguém teria ideia do que possa ser?

Aqui eu estava com o mesmo problema, escolhi essa opção como Disabled ( http://prntscr.com/ez61v9 ) e depois disso não tive mais esse problema.

Link to comment
Share on other sites

@MarksEliel e @edvan isso que vocês citaram estão relacionados, se fizer a configuração para desabilitar o TLS não precisa fazer o que o @edvan falou.

Porém isso aí já virou um clássico  rsrs   de cara o cliente tentou acessar da forma mais antiga, usando aquele atalho quem tem no Filezilla, ai para resolver tem que fazer essa configuração no gerenciado de servidores no Filezilla, só que mesmo assim não resolve. Continuar apresentando "erro ao lista as pastas" ou conexão "expirada depois de 20seg" e, como falei nem mesmo pelo browser é possível acessar. @MarksEliel também já fiz isso que você falou e não muda nada.

Só é possível acessar se parar o CSF habilitou bloqueou. Mas agora pela manhã esse problema que aconteceu com o cliente aconteceu comigo também! Ontem não aconteceu, ai descobri que o CSF só me deixa acessar o FTP se colocar meu IP na lista de permitidos, caso contrário só mesmo desativando.  Então o problema não é só com o cliente, o problema aparentemente é o CSF.

Já desinstalei e instalei o CSF novamente e dá na mesma. Testei um outro servidor meu mesmo, que configurei semana passada e esse problema não acontece. Funciona normalmente como sempre funcionou. Eu estou começando a achar que é algum problema ou incompatibilidade entre o S.O e o CSF. O servidor do cliente roda Centos 7.3 + EA4 + WHM64 build 15, esse meu que falei roda Centos 6.9 + EA4 + WHM64 build 15. Quem tem contato com essas duas versões do Centos vai reparar que o CSF no momento que dá enabled ou restart os logs são diferentes e tem um erro referente ao LFD, e em TODOS os servidores que tive acesso com Centos7 tem algum tipo de erro no log do CSF. No Centos 6 isso não acontece.

Link to comment
Share on other sites

2 minutos atrás, RevendaHost disse:

@MarksEliel e @edvan isso que vocês citaram estão relacionados, se fizer a configuração para desabilitar o TLS não precisa fazer o que o @edvan falou.

Porém isso aí já virou um clássico  rsrs   de cara o cliente tentou acessar da forma mais antiga, usando aquele atalho quem tem no Filezilla, ai para resolver tem que fazer essa configuração no gerenciado de servidores no Filezilla, só que mesmo assim não resolve. Continuar apresentando "erro ao lista as pastas" ou conexão "expirada depois de 20seg" e, como falei nem mesmo pelo browser é possível acessar. @MarksEliel também já fiz isso que você falou e não muda nada.

Só é possível acessar se parar o CSF habilitou bloqueou. Mas agora pela manhã esse problema que aconteceu com o cliente aconteceu comigo também! Ontem não aconteceu, ai descobri que o CSF só me deixa acessar o FTP se colocar meu IP na lista de permitidos, caso contrário só mesmo desativando.  Então o problema não é só com o cliente, o problema aparentemente é o CSF.

Já desinstalei e instalei o CSF novamente e dá na mesma. Testei um outro servidor meu mesmo, que configurei semana passada e esse problema não acontece. Funciona normalmente como sempre funcionou. Eu estou começando a achar que é algum problema ou incompatibilidade entre o S.O e o CSF. O servidor do cliente roda Centos 7.3 + EA4 + WHM64 build 15, esse meu que falei roda Centos 6.9 + EA4 + WHM64 build 15. Quem tem contato com essas duas versões do Centos vai reparar que o CSF no momento que dá enabled ou restart os logs são diferentes e tem um erro referente ao LFD, e em TODOS os servidores que tive acesso com Centos7 tem algum tipo de erro no log do CSF. No Centos 6 isso não acontece.

O meu aqui é Centos 6.8 Minimal + CloudLinux + cPanel 64 build 15

Havia notado isso também, só acessa o FTP se o IP for liberado, não sei se foi alguma coincidência, mais quando desabilitei o TLS a conexão deu certo...

Vamos aguardar os outros usuários do fórum para ver se alguém tem uma solução diferente da nossa.

Link to comment
Share on other sites

Em 28/02/2016 em 15:12, Claudio disse:

[RESOLVIDO - SOLUÇÃO]

Olá senhores. Obrigado por comentarem. Cheguei a uma solução com incentivo e auxílio de vocês que serviram de grande ajuda. Abaixo, segue um tutorial básico e funcional.

#Não me responsabilizo por qualquer dano que possa causar ao servidor, este é apenas um tutorial de Configuração de FTP passivo.  Posteriormente, se ainda não existir esse tutorial no PDH, o moderador pode estar movendo para categoria de tutoriais.

Para resolver este problema você precisa abrir um conjunto (range) de 5.000 portas para liberar as conexões passivas entre o cliente de FTP e o respectivo servidor.

Neste tutorial vamos utilizar o range compreendido entre 35000:40000. Para você executar os passos abaixo, você deve estar logado ao servidor como root via SSH.

 

1 – Primeiro vamos abrir as portas no CSF (firewall), para isso basta editar o arquivo csf.conf com o seguinte comando: 


nano /etc/csf/csf.conf

Procure pela linha que começa com TCP_IN e adicione após a última porta, e antes da aspas dupla, o range de portas 35000:40000. Lembre-se de incluir uma vírgula antes de inserir o range de portas. Como exemplo, em um servidor com cPanel com a configuração básica a linha ficará assim:


TCP_IN = "20,21,25,53,80,110,143,220,443,465,587,993,995,2077,2078,2082,2083,2086,2087,2095,2096,35000:40000”

Saia do editor teclando CONTROL+X, depois Y e ENTER.

Agora digite os seguintes comandos para reiniciar o CSF e o LFD para ativar as alterações:


service lfd restart
service csf restart

Depois das configurações feitas no firewall devemos configurar o servidor de FTP para utilizar as portas que liberamos. O servidor padrão que o cPanel utiliza é o Pure-FTP. Para configurá-lo você deve editar o arquivo pure-ftpd.conf com o seguinte comando:


nano /etc/pure-ftpd.conf

Procure pela linha:


# PassivePortRange          30000 50000

Retire o comentário (#) e altere as portas para as que você liberou no CSF. A linha deverá ficar assim:


PassivePortRange          35000 40000

Saia do editor teclando CONTROL+X, depois Y e ENTER.

Agora digite o seguinte comando para reiniciar o Pure-FTP e ativar as alterações:


service pure-ftpd restart

Após reiniciar o Pure-FTP as configurações já estão ativas e você poderá utilizar normalmente o sua conexão através do FTP.

 

 

Obrigado.

 

 

Fonte: vivaolinux, blogdohost, turbolab.it

 

O tópico

 

Link to comment
Share on other sites

18 minutos atrás, Claudio disse:

 

O tópico

 

Sua dica aparentemente ajudou a resolver o problema. Obrigado!

Eu já tinha visto essa sua postagem no ano passado, mas nunca havia se quer testado pois nunca tive esse problema.

Seguindo isso que você indicou, eu abri o arquivo pure-ftpd.conf e nele não tem a linha PassivePortRange 30000 50000 comentada, ela estava habilitada e a range de portas era 49152 65534. Abri elas no CSF e consegui conectar.  Agora vou verificar em outros servidores com Centos7 se estão assim ou se isso foi alguma cagada do próprio cPanel 64.

Obrigado pela ajuda.

@edvan , @MarksEliel parece que resolve o problema.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.



×
×
  • Create New...

Important Information