Clicky

Ir para conteúdo

Claudio

Site fazendo download após instalação cpanel + easy apache 4

Posts Recomendados

Olá senhores

Em um servidor de teste, instalei o novo cPanel e foi um problema grande me acostumar com o Easy Apache 4, mas 24h depois me adaptei bem. Só que surgiu um problema.

Migrei 100 sites do servidor em produção para o servidor que está em teste (não apontei DNS) e 40% dos sites estão fazendo download automático quando acessa a URL temporária, sendo que no servidor em produção esse problema não acontece.
O servidor em teste tem o PHP 7 instalado, mas por padrão estou usando o PHP 5.5/6 nos 100 sites hospedados.

Alguém tem uma sugestão pra mim?

Obrigado.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Isso geralmente acontece quando o PHP não está habilitado... tenta instalar qualquer um dos perfis com PHP já pré-instalados pela cPanel e ver se funciona.

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Claudio Isso aconteceu aqui, tive que migrar várias contas para um novo servidor com a versão atual do cPanel&WHM e alguns sites(não todos) acontecia isso...
O que notei foi que no servidor antigo eu usava o NTPHPSelector e ele adicionar um arquivo .htaccess no diretório public_html da hospedagem, nesta linha tem algo mais ou menos assim: AddHandler application/x-httpd-php54  .php54 .php  no meu caso bastava apagar essa linha que o problema era solucionado...

Espero ter ajudado...

Compartilhar este post


Link para o post
Compartilhar em outros sites
45 minutos atrás, Tasso disse:

Isso geralmente acontece quando o PHP não está habilitado... tenta instalar qualquer um dos perfis com PHP já pré-instalados pela cPanel e ver se funciona.

Perdão, não entendi muito bem. Como eu poderia fazer isso usando a nova versão do cPanel e o Easy Apache 4?

42 minutos atrás, MarksEliel disse:

@Claudio Isso aconteceu aqui, tive que migrar várias contas para um novo servidor com a versão atual do cPanel&WHM e alguns sites(não todos) acontecia isso...
O que notei foi que no servidor antigo eu usava o NTPHPSelector e ele adicionar um arquivo .htaccess no diretório public_html da hospedagem, nesta linha tem algo mais ou menos assim: AddHandler application/x-httpd-php54  .php54 .php  no meu caso bastava apagar essa linha que o problema era solucionado...

Espero ter ajudado...

As contas que estão com esse problema não usavam o NTPhpSelector, não há nem mesmo arquivo .htaccess Mas obrigado..

Compartilhar este post


Link para o post
Compartilhar em outros sites

Isso é "normal", acontece sempre que se migra uma conta para outro servidor, e neste servidor roda uma versão diferente do PHP daquela que geralmente está sendo carregada através de um arquivo htaccess ou php.ini no site.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Cada um ta resolvendo o mesmo problema de um jeito diferente. 
Eu só consegui resolver o meu depois de fazer downgrade para o Easy Apache 3, e depois refiz o upgrade para o Easy Apache 4 e só assim resolveu. Detalhe: O Easy Apache 4 foi instalado automaticamente pelo cPanel quando instalei o mesmo. Não sei explicar exatamente como resolveu, mas basicamente foi assim. Que trabalheira! Ainda bem que é teste.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora

  • Quem Está Navegando   0 membros estão online

    Nenhum usuário registrado visualizando esta página.



O Portal do Host

Dicas para sua empresa de hospedagem. Artigos, notícias, tutoriais e os aspectos da indústria de hospedagem.

Limestone Networks

A LSN tem sido parceira e patrocinadora do PDH, fornecendo uma plataforma segura e confiável.

Cloud - Servidores decicados - Co-location
×