Clicky

Ir para conteúdo

pablosbs

Bug pesquisa domínios WHMCS v6.1.1

Posts Recomendados

Pessoal...

Há um grave bug nos códigos de integração com o WHMCS 6 , caso estejam utilizando os códigos de integração para checagem de domínios fiquem atentos pois os clientes conseguem comprar até o domínio google.com e pagar por ele se quiserem...

O bug só acontece na seguinte situação:

No admin em Setup > General settings > Domains > Standard whois > Configure 

Se você tiver selecionado mais de uma extensão nessa parte e utiliza o código de integração para o domainchecker em alguma parte do seu site os clientes irão conseguir comprar domínios que não estão disponíveis da seguinte forma :

Coloque no campo de pesquisa google.net e deixe selecionado o domínio .com na busca.... conforme minha printscreen1.

Nas sugestões de domínio irá aparecer todos os domínios liberados para registro... olhem as prints. Vou ter que anexar as outras prints em outro post pois excedeu o limite...

 

 

print1pdh.png

Segue os demais prints.

printpdh2.png

printpdh3.png

Soluções que encontrei até agora :

1 - Tentei validar os campos para evitar que o cliente procure por "google.net" , ou seja, evitar o ponto no meio que causa o bug permitindo somente letras e números nesse campo... mas a validação em HTML5 que encontrei funciona somente no Chrome e Firefox... Não funcionou no meu Ipad no safari por exemplo.

2 - Desativar temporariamente a opção de sugestão de outras TLDs...

Criei ticket na WHMCS para ver o que eles falam...

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Vixe

Já avisou o whmcs sobre o bug?

Tinha uma epoca ai que eles estavam pagando por bugs (derrepente já ajudava naquele preju que tu levou por causa desse bug)

Mas testei em um código de integração de um dos meus sites e não identifiquei o problema...


oGigante.com • Revenda de Hospedagem + Construtor de Site
█ CloudLinux • DNS Próprio • Softaculous PREMIUM • PHP 5.2 ao 5.7 • Proteção Adicional e +

Compartilhar este post


Link para o post
Compartilhar em outros sites

Vixe

Já avisou o WHMCS sobre o bug?

Tinha uma epoca ai que eles estavam pagando por bugs (derrepente já ajudava naquele preju que tu levou por causa desse bug)

Mas testei em um código de integração de um dos meus sites e não identifiquei o problema...

Então, consegui replicar o bug até no demo deles, provavelmente você não tem a opção de sugestão de domínios ativada.

Eu avisei sim mas ultimamente o suporte do whmcs demora dias pra responder... :S

O ideal é uma validação do lado do servidor... no próprio WHMCS mesmo.

Vixe

Já avisou o WHMCS sobre o bug?

Tinha uma epoca ai que eles estavam pagando por bugs (derrepente já ajudava naquele preju que tu levou por causa desse bug)

Mas testei em um código de integração de um dos meus sites e não identifiquei o problema...

Consegui replicar em seu site também... segue o print.

bug.png

Editado por pablosbs

Compartilhar este post


Link para o post
Compartilhar em outros sites

Testei aqui no meu .. realmente ele diz que está disponível mais quando clico em comprar , dá a mensagem....

Domínio Indisponível
Infelizmente, o domínio que você selecionou não está disponível. Isso às vezes pode ocorrer se o domínio foi registrado recentemente. Por favor, volte e escolha um outro domínio.

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Testei aqui no meu .. realmente ele diz que está disponível mais quando clico em comprar , dá a mensagem....

Domínio Indisponível
Infelizmente, o domínio que você selecionou não está disponível. Isso às vezes pode ocorrer se o domínio foi registrado recentemente. Por favor, volte e escolha um outro domínio.

 

Qual é seu site?

complicado, um cliente conseguiu registrar cs.com.br com esse bug e está falando que vai processar.... haha...

Compartilhar este post


Link para o post
Compartilhar em outros sites

Vixe

Já avisou o WHMCS sobre o bug?

Tinha uma epoca ai que eles estavam pagando por bugs (derrepente já ajudava naquele preju que tu levou por causa desse bug)

Mas testei em um código de integração de um dos meus sites e não identifiquei o problema...

Continuam pagando https://bugcrowd.com/whmcs

Compartilhar este post


Link para o post
Compartilhar em outros sites

Eu tive sorte que ainda nao atualizei o meu para essas versões mais recentes, estou na 6 mais ainda não fui para estas demais complementos, vou esperar ela madurar um pouco

 

Qual é seu site?

complicado, um cliente conseguiu registrar cs.com.br com esse bug e está falando que vai processar.... haha...

tenso em... rsrs

Compartilhar este post


Link para o post
Compartilhar em outros sites

Participe da conversa

Você pode postar agora e se cadastrar mais tarde. Se você tem uma conta, faça o login para postar com sua conta.

Visitante
Responder

×   Você colou conteúdo com formatação.   Remover formatação

  Apenas 75 emojis são permitidos.

×   Seu link foi automaticamente incorporado.   Mostrar como link

×   Seu conteúdo anterior foi restaurado.   Limpar o editor

×   Não é possível colar imagens diretamente. Carregar ou inserir imagens do URL.


  • Quem Está Navegando   0 membros estão online

    Nenhum usuário registrado visualizando esta página.



×
×
  • Criar Novo...