Jump to content
Sign in to follow this  
Fabi Silva

Erro Ioncube + WHMCS

Recommended Posts

Oiii gente tudo bem ???? Gente olha eu aqui novamente, estou tendo um problemãooooo com esse Ioncube, que negócio chato sô rsrs. Vamos ao fatos.

Ioncube eu recompilei junto ao Easy Apache, depois desinstalei e reinstalei por comando (/scripts/phpextensionmgr install ioncubeloader) ao digitar php -v aparece a mensagem que esta instalado, conforme podem ver http://prntscr.com/8munj7. Mas ao tentar instalar o WHMCS (link do PDH) aparece a bendita mensagem (index.php requires the ionCube PHP Loader ioncube_loader_lin_5.4.so to be installed by the website operator. If you are the website operator please use theionCube Loader Wizard to assist with installation.)

Já não sei mais o que fazer, ja pesquisei muito pelo tio Google mas nada, ja ativei em Tweak Settings, já desinstalei, reinstalei, recompilei, adicionei a linha (zend_extension="/usr/local/IonCube/ioncube_loader_lin_5.4.so") em /usr/local/lib/php.ini que originalmente é instalado automaticamente no meio do arquivo, depois coloquei no começo do php.ini e NECASSSSS até agora.

 ME Socorremmmmm pleaseee ??? Obrigada meninos vcs são muito lindos e sempre me ajudam muito 

Ahhhh e criei um arquivo info.php e não aparece o Ioncube instalado, não sei se deve aparecer igual à isso error.thumb.png.f38f8eb698deda2a85fbc4e7

Ou se essa imagem esta obsoleta, peguei ela nesse site http://tecadmin.net/install-ioncube-loaders-in-cpanel-server/ 

Share this post


Link to post
Share on other sites

Eu acho que há um arquivo php.ini dentro do site e isso está causando o problema.

Obrigada @Jaime realmente tem um php.ini eu criei ele, apaguei ele e nada dava certo, alem dele tem um na pasta home/usuario, eu só consegui resolver instalando manualmente, com aquele instalador que tu instala via navegador, esta funcionando, mas é ruim, se cada cliente precisar ter que fazer esse trabalho braçal né ??

Indiretamente consegui, mas seria bacana se não precisasse fazer essa obra braçal né ?? É um trem muito chato rsrs, mas mesmo assim OBRIGADAAAA @Jaime

Share this post


Link to post
Share on other sites

Olá, bom dia!

Basta entra em seu termina SSH com o root e executar o seguinte comando abaixo:

Aviso: Nunca delete nada em seu PHP.INI

/scripts/phpextensionmgr install ioncubeloader

Espero tê-la ajudado.

Grande abraço.

@DELTA SERVERS moço tu sempre me socorrendo, tu é um lindo, moço eu ja usei esse mesmo script e necas, tive que usar aquele instalador do Ioncube, aquele Wizard, ai entrei no public_html e instalei la, deu certo, mas agora tentando instalar o WHMCS (link do PDH) esta pedindo o pdo e pdo_mysql e vi que ja esta compilado la no Apache, credo gente, que complicação esses trem rsrs

Share this post


Link to post
Share on other sites

Boa tarde @Fabi Silva

 

Tivemos esse problema no update do whcms + CWP.

 

O procedimento para instalar o ioncube é o mesmo em outros paineis, inclusive no cpanel e funciona perfeito.

 

Aqui está o procedimento: http://goo.gl/EuF8mF

 

Caso você tenha problemas para instalar os painéis para você, contrate uma consultoria que faça isso para você, existe muitos aqui no fórum.

 

Abraços


Consultoria em TI - Soluções Hospedadas  - Licenças Plesk (Partner) - Assistência Técnica  - Site: tecsecret.com.br

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.





×
×
  • Create New...