Jump to content

Adicionar mais uma versão de PHP no VPS


webmasterinetbr

Recommended Posts

Olá Pessoal, eu tenho um VPS que coloco algumas aplicações antigas e tem o PHP 5.4.41, mas preciso de uma versão mais antiga, a 5.2, mas sem tirar a versão 5.4.

Tentei instalar o ntPHPselector que seria a solução para os problemas, mas depois de instalado, aparece a opção na seção de "software" no Cpanel, mas quando clica abre uma página com Erro HTTP 404. Pesquisei neste fórum e vi que muitos enfrentam esse problema do erro do ntPHPselector.

Alguém tem alguma dica?

Agradeço toda a ajuda.

 

7 minutos atrás, webmasterinetbr disse:

Olá Pessoal, eu tenho um VPS que coloco algumas aplicações antigas e tem o PHP 5.4.41, mas preciso de uma versão mais antiga, a 5.2, mas sem tirar a versão 5.4.

Tentei instalar o ntPHPselector que seria a solução para os problemas, mas depois de instalado, aparece a opção na seção de "software" no Cpanel, mas quando clica abre uma página com Erro HTTP 404. Pesquisei neste fórum e vi que muitos enfrentam esse problema do erro do ntPHPselector.

Alguém tem alguma dica?

Agradeço toda a ajuda.

 

Dados do VPS
--

CENTOS 6.10 - v76.0.22
Server version: Apache/2.4.12 (Unix)
Cpanel::Easy::Apache v3.30.1 rev9999
---
Versão do cPanel 76.0 (build 22)
Versão do Apache 2.4.12
Versão do PHP 5.4.41
Versão do MySQL 5.5.61-cll
 

Link to comment
Share on other sites

2 horas atrás, pluginscpanelwhm disse:

ntPHPselector

Já vi pelos posts aqui que eles não ajudam em nada e quanto aos hacker eles tentam tentam tentam e nada conseguem. SSH desativado, Segurança de senha dupla, todas as proteções de apache e htacess, acho meio difícil, mas não impossível. O máximo que podem fazer é derrubar a VPS, mas uso ela só para testes então que derrubem kkkkk.

Link to comment
Share on other sites

9 horas atrás, webmasterinetbr disse:

Adam, se eu colocar o Eapache4 não roda mais nada, é tudo site velho

Olá,
mas se você usa o easyapache 3 é facil você compilar o php 5.2 em uma pasta tipo na /opt/php
e usar o htaccess para chamar essa versão do php em qualquer site que você quiser utilizar.
o bom seria você atualizar seus sites pra pelo menos php 5.6 por que vai ser sempre tenso manter sites assim.
mas se você aceitar me envie mensagem MP que conversamos sobre outra solução.
 

Link to comment
Share on other sites

4 horas atrás, pluginscpanelwhm disse:

compilar o php 5.2

Tem o passo a passo para eu fazer isso? Compilar o PHP e usar o htacess. 

4 horas atrás, AngelCosta disse:

Conheço essa dor de ter um monte de aplicativo bacana, mas tudo em php velho. 

Isso é pra uso público ou só pra testes? Se for só testar joga eles numa máquina local ou um droplet na DO ou Vultr pra instalar manualmente.

 

 

Publico e privado também. A dica do pluginscpanelwhm de compilar o php é interessante, só que ainda estou aprendendo e nem tudo tenho o conhecimento para fazer. Mas de qualquer forma agradeço só o fato de dispor do seu tempo em responder.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

Do you agree with our terms?