Jump to content
Sign in to follow this  
joaohp

Problemas com módulo streaming

Recommended Posts

Oi, bom dia!

Este é o meu primeiro post, peço desculpas caso tenha postado no local errado.

Estou com um problema no meu WHMCS, tenho uma Revenda de Streaming e estou tentando integrar diretamente com o WHMCS com o módulo próprio da revenda VoxStream, porém o WHMCS não configura automaticamente o serviço após o pagamento da fatura, ele apresenta o seguinte erro: "mysql_data_seek is not supported".

O módulo está configurado exatamente como painel VoxStream indica e meu WHMCS está atualizado.

Muito obrigado desde já.

Share this post


Link to post
Share on other sites

Coloca php 5.4 que vai funcionar, esse modulo não roda em php 7 


Fox Soluções | (011) 3090 4444 / (011) 96841-9797 |  www.FoxSolucoes.com
 | Streaming Áudio | CentovaCast | Revendas de Streaming | Data Center Brasil  EUA | 
 | Streaming Vídeo | CastControl WOWZA | Revendas de Streaming | Data Center Brasil  EUA | 

Share this post


Link to post
Share on other sites
21 horas atrás, joaohp disse:

Oi, bom dia!

Este é o meu primeiro post, peço desculpas caso tenha postado no local errado.

Estou com um problema no meu WHMCS, tenho uma Revenda de Streaming e estou tentando integrar diretamente com o WHMCS com o módulo próprio da revenda VoxStream, porém o WHMCS não configura automaticamente o serviço após o pagamento da fatura, ele apresenta o seguinte erro: "mysql_data_seek is not supported".

O módulo está configurado exatamente como painel VoxStream indica e meu WHMCS está atualizado.

Muito obrigado desde já.

O módulo para VoxStream funcionará para versões mais avançadas do PHP, inclusive 7.1, desde que, você realize à atualização do módulo de MySQL para MySQLi. Como não sei o seu revendedor não tenho como saber de forma exata se a versão que está utilizando tem como realizar esta modificação (de forma mais fácil, sem precisar alterar todo o código).

Neste caso, infelizmente você terá que dar uma atualizada no plugin para o funcionando com o painel VoxStreaming, como disse alterando de MySQL para MySQLi, já que a função mysql_data_seek foi removida em versões mais recentes do PHP. O módulo que temos houve teve o mesmo problema, mas realizamos alterações para MySQLi e agora funciona como deveria.

E pelo fato do mysql_data_seek não ser suportado em versões mais novas do PHP, não é somente a criação da conta que irá falhar, mas o módulo simplesmente não irá funcionar para nada, ou seja, criar, suspender ou remover, etc..

Mas como disse o nosso amigo @Otavio altere sua versão do PHP para 5.3 ou 5.4 que irá funcionar (testamos também na versão 5.6 e funcionou, mesmo a função estando obsoleta, esta função foi removida totalmente à partir da versão 7.0), se não for possível, somente atualizando o plugin como dito acima de MySQL para MySQLi.

Creio que é mais vantajoso e seguro atualizar seu plugin, porque o WHMCS está cada vez exigindo versões mais novas do PHP, a mais nova por exemplo somente à partir da versão 5.6 do PHP, e se não atualizar o seu plugin, precisará também ficar preso a versões antigas do WHMCS.


-----------------------------------------------------------------------------------------------------------
Necessitamos sempre de ambicionar alguma coisa que, alcançada, não nos torna sem ambição.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.




×
×
  • Create New...