Jump to content

Xvarnish lento demais para responder


Guest felinto
 Share

Recommended Posts

Guest felinto

Fiz uns testes com xVarnish e os resultados foram ótimos, mas agora que tentei replicar a mesma configuração em outra máquina não deu certo.

O que mudou é que estou usando um datancer no BR com links de 15mbps e csf ativo. Porém já desativei o firewall para fazer um teste e o resultado foi igual.

Alguém pode me dá uma luz do que pode está acontecendo ?

O painel do xVarnish diz que tudo passou pelo Varnish, quase nada pelo backend, mas ele não tá suportando o pico de acessos...

Fico no aguardo, obrigado.

Link to comment
Share on other sites

Guest felinto

Atualização: Fiz um teste simples, eu mesmo recarregando a página no navegador várias vezes para testar o cache e descobri que uma parte ainda está passando para o backend, o que é mal =/

UX48OrY.png

Link to comment
Share on other sites

Vc só instalou o xvarnish, chegou a fazer alguma configuração? Eu não sei como estão as configurações que vem por padrão atualmente, mas até ano passado sempre tinha que mexer nas configurações.

Recomendo que veja as configurações.

Há, não realize postagens seguidas, edite seu post anterior e informe. Isso pode ser entendido como flood.

Link to comment
Share on other sites

Guest felinto

Não fiz nenhuma configuração adicional.

Porém em outra VPS nos EUA eu fiz do mesmo jeito, instalei e pronto e os resultados foram bons.

Para falar a verdade a configuração que eu fiz foi aumentar o tempo que o varnish guarda páginas dinâmicas para 180 segundos e outras coisinhas. Porém ambos os servidores estão com a mesma configuração na aba configurações do Varnish.

Eu não sei se é um firewall que tá bloqueando, bug do cPanel, PHP, nem tenho ideia. Não seria alguma maneira de desmistificar alguns logs e encontrar a raiz do problema ?

2 horas atrás, msaulohenrique disse:

Há, não realize postagens seguidas, edite seu post anterior e informe. Isso pode ser entendido como flood.

Desculpe, mas eu não lembro de ter feito duas postagens seguidas. Você pode ser mais específico  ?

Olha que estranho, rodei o HTOP e vi que o processo do xVarnish não chega no seu limite, no seu pico, usa no máximo uns 25% da CPU. Acho que se a VPS não suportasse tanta conexão o load subiria lá em cima e pronto, o servidor caia, mas não é assim o que acontece. Alguém pode me dá uma luz ?

Link to comment
Share on other sites

Guest felinto

Eu sinceramente acho que é algum tipo de firewall... de certo. O servidor está no BR e estou fazendo requisições de fora.

Também pode ser o link, 15mbps não é lá essas coisas, mas não aguentar umas 500, 1000 conexões simultâneas ? Usando o tema padrão do WP.

Link to comment
Share on other sites

Guest felinto

Estava testando o Engintron e os resultados foram ótimo. Minha surpresa foi ao descobrir que implementaram o micro-caching do Nginx, antes quando eu testei não tinha isso...

Show de bola

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...