Jump to content
Limestone de cara nova! ×
Portal do Host

Ajuda - dns linode + godaddy +cpanel/whm


tolascado
 Share

Recommended Posts

Salve, salve!!! Meu primeiro post na comunidade!

Antes de tudo, desculpe a ignorância, mas estou aprendendo ok? Se não acharem que a pergunta está colocada de forma errada, só avisar!

Vamos lá:

Fui na Linode, montei um VPS. Já tenho o domino na GoDaddy ex.: meudominio.com. Através do Terminal SHH mudei o hostname para um nome mais amigável ( sei lá pq) tipo: vps.meudominio.com. Instalei o cPanel em cima de um CentOs 7. Até ai belezinha...

Meu sofrimento está sendo o maldito DNS. Ainda não consegui entender como fazer ele ficar personalizado e trabalhar corretamente.

Fui no DNS MANAGER da Linode e add Zone e adicionei dominio com entradas adicionais de ns1 e ns2 (personalizadas) e ficou assim:

NS RECORDS
Name Server    Subdomain    TTL    Options
ns1.linode.com    meudominio.com    Default    Edit | Remove
ns2.linode.com    meudominio.com    Default    Edit | Remove
ns3.linode.com    meudominio.com    Default    Edit | Remove
ns4.linode.com    meudominio.com    Default    Edit | Remove
ns5.linode.com    meudominio.com    Default    Edit | Remove
ns1.meudominio.com    meudominio.com    300 (5 minutes)    Edit | Remove
ns2.meudominio.com    meudominio.com    300 (5 minutes)


A/AAAA RECORDS
ns1    12.234.56.789    Default    Edit | Remove
ns2    12.234.56.789    Default    Edit | Remove
www   12.234.56.789    Default    Edit | Remove

> No cPanel/WHM:

Alterei o nameserver para:

ns1.meudominio.com 
ns2.meudominio.com

Criei uma conta inicial, onde já apareceu os DNS personalizados. ok.

Após isso fui em "Change Site’s IP Address" e adicionei o site.

> Na GoDaddy:

Após isso fui em nome do host ( na Godaddy e adicionei o hostname) aguardei e dei ping... apontou para o IP normalmente!!!

64 bytes from vps.meudominio.com (12.234.56.789): icmp_seq=10 ttl=64 time=0.092 ms

Bem... após tudo isso feito, quando tento colocar as entradas ns1.meudominio.com e ns2.meu dominio.com dá erro!

Você deve inserir um servidor de nomes registrado.

Um ou mais servidores de nomes inválidos.

PQ? PQ?????? To ficando careca e não consigo ver o meu erro!!!

Onde estou errando?

Ajuda ai pessoal!!!

 

 

 

 

 

 

 

 

Link to comment
Share on other sites


  • Replies 6
  • Created
  • Last Reply

Top Posters In This Topic

@RevendaHost e @LeandroSA agora um outra situação derivada. Ok está tudo funcionando com o meudominio.com.

Mas quando criei uma outra  "conta de um cliente" no WHM com dominio .com.br  e aponto o ns1.meudomino.com e ns2 meudominio.com no registro.br recebo a seguinte mensagem:

Servidor DNS Master: Tempo esgotado
Servidor DNS Slave 1: Tempo esgotado

 

Eu deveria esperar mais a propagação do DNS? N DNS MANAGER da Linode está tudo ok. Quando dou o Check aparece:

Your zone looks good!

zone meudominio.com/IN: loaded serial 2017123784
OK

Existe algum teste ou comando no terminal que eu poderia validar se o ns1.meudominio.com e ns2.meudominio.com está funcionado? 

O que está faltando fazer para funcionar? Obrigado desde já pela ajuda!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information