Jump to content
Limestone de cara nova! ×
Portal do Host

Problema whois whmcs após atualizar cpanel, PHP e apache


Fernando Rafs
 Share

Recommended Posts

Fala pessoal,

Alguém já enfrentou um problema parecido que irei relatar....

Ontem atualizamos o servidor que hospeda o WHMCS, da seguinte maneira:

1. cPanel da 56 para versão 58.0

2. PHP da versão 5.3.x para versão 5.6.x

3. Apache da versão 2.2 para versão 2.4

A partir daí o Whois tem hora que funciona e na maioria da vezes não funciona, retornando a seguinte mensagem de erro:

There was a problem connecting to the domain registry. Please check port 43 is open in your servers firewall.

Error: 110 - Connection timed out

O problema é que a porta 43 está aberta normalmente no Firewall, nada foi alterado no CSF, de qualquer maneira testamos com o CSF desativado e o mesmo problema ocorre.

O mais estranho é que ocorre este problema apenas para domínios Internacionais, para domínios Nacionais funciona normalmente, além disto este erro ocorre tanto na versão do WHMCs 5.3.14 como na 6.3.1

Se alguém já teve problema semelhante e puder dar uma luz, agradeço.

Nota: Como falado, já foi desativado o CSF, reinstalado, IP6 desativado, entre outros procedimento em que nada ajudaram.

Nota 2: Um ticket já foi aberto tanto na WHMCS como na cPanel, mas ainda sem retorno.

Link to comment
Share on other sites


  • Replies 9
  • Created
  • Last Reply

Top Posters In This Topic

4 horas atrás, Guto disse:

Fala pessoal,

Alguém já enfrentou um problema parecido que irei relatar....

Ontem atualizamos o servidor que hospeda o WHMCS, da seguinte maneira:

1. cPanel da 56 para versão 58.0

2. PHP da versão 5.3.x para versão 5.6.x

3. Apache da versão 2.2 para versão 2.4

A partir daí o Whois tem hora que funciona e na maioria da vezes não funciona, retornando a seguinte mensagem de erro:


There was a problem connecting to the domain registry. Please check port 43 is open in your servers firewall.

Error: 110 - Connection timed out

O problema é que a porta 43 está aberta normalmente no Firewall, nada foi alterado no CSF, de qualquer maneira testamos com o CSF desativado e o mesmo problema ocorre.

O mais estranho é que ocorre este problema apenas para domínios Internacionais, para domínios Nacionais funciona normalmente, além disto este erro ocorre tanto na versão do WHMCS 5.3.14 como na 6.3.1

Se alguém já teve problema semelhante e puder dar uma luz, agradeço.

Nota: Como falado, já foi desativado o CSF, reinstalado, IP6 desativado, entre outros procedimento em que nada ajudaram.

Nota 2: Um ticket já foi aberto tanto na WHMCS como na cPanel, mas ainda sem retorno.

Você efetuou alguma personalização no arquivo whoisservers.php que está localizado em /includes/

Procure a linha .com e confira se está assim:

.com|whois.crsnic.net|No match for

 

Link to comment
Share on other sites

Em 26/08/2016 at 12:51, edvan disse:

Você efetuou alguma personalização no arquivo whoisservers.php que está localizado em /includes/

Procure a linha .com e confira se está assim:


.com|whois.crsnic.net|No match for

 

Então Edvan, não foi modificado nada no WHMCS, apenas atualização do servidor mesmo. E constatamos o problema tanto na versão 5.3.X como na 6.3.x

Havia aberto um ticket na cPanel e na WHMCS, e ambas acessaram o servidor, a cPanel realizou algumas verificações e constatou que o servidor estava conseguindo se comunicar normalmente com o Whois, e a WHMCS enviou um arquivo para o local de instalação do WHMCS mas não sei qual a sua finalidade.

(se você quiser até posso lhe enviar este arquivo caso deseje verificar o seu conteúdo, eles não haviam informado sobre o envio deste arquivo eu que constatei pelo log e o copiei antes da remoção, até porque você lida diretamente com a WHMCS e talvez quem sabe pode lhe ser útil. Pelo que verifiquei o arquivo é programado para se auto deletar após algumas horas, mas não posso confirmar porque não tive tempo de analisá-lo a fundo.)

Depois do acesso de ambas as empresas o Whois voltou a funcionar normalmente, me deixando intrigado já que ambas as empresas dizem que nada fizeram de modificação/correção, a cPanel informou apenas ter realizado testes no servidor e a WHMCS igualmente (não informou nem de ter enviado este arquivo).

O importante é que voltou kkkk.

Link to comment
Share on other sites

13 horas atrás, Guto disse:

Então Edvan, não foi modificado nada no WHMCS, apenas atualização do servidor mesmo. E constatamos o problema tanto na versão 5.3.X como na 6.3.x

Havia aberto um ticket na cPanel e na WHMCS, e ambas acessaram o servidor, a cPanel realizou algumas verificações e constatou que o servidor estava conseguindo se comunicar normalmente com o Whois, e a WHMCS enviou um arquivo para o local de instalação do WHMCS mas não sei qual a sua finalidade.

(se você quiser até posso lhe enviar este arquivo caso deseje verificar o seu conteúdo, eles não haviam informado sobre o envio deste arquivo eu que constatei pelo log e o copiei antes da remoção, até porque você lida diretamente com a WHMCS e talvez quem sabe pode lhe ser útil. Pelo que verifiquei o arquivo é programado para se auto deletar após algumas horas, mas não posso confirmar porque não tive tempo de analisá-lo a fundo.)

Depois do acesso de ambas as empresas o Whois voltou a funcionar normalmente, me deixando intrigado já que ambas as empresas dizem que nada fizeram de modificação/correção, a cPanel informou apenas ter realizado testes no servidor e a WHMCS igualmente (não informou nem de ter enviado este arquivo).

O importante é que voltou kkkk.

O arquivo foi um check.php?

Link to comment
Share on other sites

  • 6 months later...
4 horas atrás, criadorweb disse:

Estou com o problema de whois no WHMCS 7.1.2 também logo quando vai para a checagem após o cliente escolher um plano de hospedagem o whois só fica verificando e também já liberei a posta 43 e está do mesmo jeito!!!

Alguém poderia me ajudar?

1. Quando você tenta pesquisar um domínio através do Whois, disponível no Admin do WHMCS, a pesquisa ocorre normalmente? Retorna algum erro?

2017-03-07_1508.png.c67e5f6b01d483c74f554a5dabef802c.png

2. Se a resposta a primeira pergunta acima for "Sim normalmente, sem erro", já tentou alterar o template do OrderForm?

2017-03-07_1510.png.6026300ab14cb892dda239680930fc4f.png

3. O IP do Registro BR está liberado no seu Firewall, caso utilize? IP: 200.160.2.3

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.



×
×
  • Create New...

Important Information