Jump to content
Limestone de cara nova! ×
Portal do Host

Serverload alto com uso de cpu e memoria baixo qse 0


EvertonMorais
 Share

Recommended Posts

Pessoal, estou com um problema em um de meus servidores que está me incomodando a alguns dias.

Não consigo achar a causa do problema.
Uso um servidor dedicado para hospedagem compartilhada com varnish+nginx.
Tudo estava perfeito, mas essa semana começou esse problema.

O serverload fica super alto (15~30), mas o uso de CPU e memoria fica baixo, qse não usa CPU.

Já verifiquei se está sendo foco de ataque DDoS e não é.
Verifiquei se alguém está usando o servidor para fazer spam e também não é.
Não ta recebendo uma cara de visitas enorme para gerar isso (até por tenho cloudlinux no server ).

Não sei mais o que fazer, não consigo identificar a causa do problema, alguem já passou por isso ou tem alguma dica para me dar?
Será que os HD's do servidor estão pifando?

OBS: Pode ser coincidência ou não, mas isso começou a acontecer depois de ter atualizado o plugin do varnish/nginx embora não faça sentido, bem sei la. Me ajudem ai rsrs

Link to comment
Share on other sites


  • Replies 23
  • Created
  • Last Reply

Top Posters In This Topic

8 minutos atrás, EvertonMorais disse:

Pessoal, estou com um problema em um de meus servidores que está me incomodando a alguns dias.

Não consigo achar a causa do problema.
Uso um servidor dedicado para hospedagem compartilhada com varnish+nginx.
Tudo estava perfeito, mas essa semana começou esse problema.

O serverload fica super alto (15~30), mas o uso de CPU e memoria fica baixo, qse não usa CPU.

Já verifiquei se está sendo foco de ataque DDoS e não é.
Verifiquei se alguém está usando o servidor para fazer spam e também não é.
Não ta recebendo uma cara de visitas enorme para gerar isso (até por tenho cloudlinux no server ).

Não sei mais o que fazer, não consigo identificar a causa do problema, alguem já passou por isso ou tem alguma dica para me dar?
Será que os HD's do servidor estão pifando?

OBS: Pode ser coincidência ou não, mas isso começou a acontecer depois de ter atualizado o plugin do varnish/nginx embora não faça sentido, bem sei la. Me ajudem ai rsrs

Qual plugin você usa para varnish/nginx?

Link to comment
Share on other sites

42 minutos atrás, BSHosting disse:

Já tentou desinstalar eles para teste?

Sim, sem o varnish o server load vai pras alturas, o varnish que ta segurando.

Tpo, eu reinicio o servidor e fica legal, estabilizado entre 2~4, depois de umas 3 horas começa a ficar alto de novo.

O que não intendo é o fator do server load ficar alto pra caramba, e o uso de memoria e cpu super baixo.

Link to comment
Share on other sites

5 minutos atrás, hospedahost disse:

Suspeito dos HD's ou até mesmo com essas atualizações do cPanel algum bug, já ocorreu comigo depois de uma atualização cPanel o Cloudlinux bugo e deixo o servidor totalmente instável.

Pois é também to suspeitando dos HDS, entrei em contato com a OVH eles me disseram para colocar o servidor em modo rescue e verificar pela ferramenta se os hds estão com algum problema, vo tentar nessa madrugada pois é um servidor que está cheio de clientes ativos.

8 minutos atrás, brunowebmaster disse:

Você tem o whmsonic instalado? Ás vezes pode ser ele.

Já sofri muito com ele. Mas, fuçando muito, conseguir resolver.

Não, uso esse server só para hospedagem.

Link to comment
Share on other sites

# vmstat 5 7
procs -----------memory---------- ---swap-- -----io---- --system-- -----cpu-----
 r  b   swpd   free   buff  cache   si   so    bi    bo   in   cs us sy id wa st
 0  4      0 34800324 10571120 12953204    0    0    82   217  141   35  3  1 84 13  0	
 0  6      0 34797812 10571136 12953424    0    0     3   997 12730 1098  0  0 84 16  0	
 0  5      0 34800696 10571136 12953624    0    0    37  2068 12901 3486  0  0 86 13  0	
 0  1      0 35287372 10571160 12958440    0    0   869  3426 13374 6359  9  1 77 12  0	
 1  1      0 35250516 10571172 12958824    0    0   157   830 12866 3623  4  1 85 11  0	
 0  1      0 35386532 10571188 12960892    0    0   336  3146 12920 4425  2  0 90  8  0	
 4  0      0 35444208 10571360 12974988    0    0   751  1919 13013 5292  4  1 86  9  0	

htop: htop.jpg

Link to comment
Share on other sites

21 minutos atrás, EvertonMorais disse:

# vmstat 5 7
procs -----------memory---------- ---swap-- -----io---- --system-- -----cpu-----
 r  b   swpd   free   buff  cache   si   so    bi    bo   in   cs us sy id wa st
 0  4      0 34800324 10571120 12953204    0    0    82   217  141   35  3  1 84 13  0	
 0  6      0 34797812 10571136 12953424    0    0     3   997 12730 1098  0  0 84 16  0	
 0  5      0 34800696 10571136 12953624    0    0    37  2068 12901 3486  0  0 86 13  0	
 0  1      0 35287372 10571160 12958440    0    0   869  3426 13374 6359  9  1 77 12  0	
 1  1      0 35250516 10571172 12958824    0    0   157   830 12866 3623  4  1 85 11  0	
 0  1      0 35386532 10571188 12960892    0    0   336  3146 12920 4425  2  0 90  8  0	
 4  0      0 35444208 10571360 12974988    0    0   751  1919 13013 5292  4  1 86  9  0	

htop: htop.jpg

Ouxe! Ta bugado isso.

Você tem apenas 1GB de swap, mas lá diz que voce nao usa nenhum swap.

Faz o seguinte 

vi /etc/sysctl.conf

Adicione ou substitua esse campos
vm.swappiness=60
vm.vfs_cache_pressure=50

Adicione mais swap ao servidor

cd /
mkdir swap 
cd swap
dd if=/dev/zero of=/swap/swapfile bs=1024 count=500000
mkswap /swap/swapfile
swapon /swap/swapfile

O campo "500000" equivale a 500MB, aumente-o para +- 4GB = 4000000.
Seria melhor aumentar mais, mas vai depender do hd.
Se é um sata, é bom deixa-lo com nivel baixo, se for SSD, pode aumentar para um numero consideravel alto como 16GB.
Já que sua memoria Ram é de 64GB 

Reparei também, que o varnish esta tomando muita memoria, 13,1GB '-'.
Vendo só pelo top, mostra que o seu timeout esta a 800s. 
Isso é muito! Você deve reduzir isso, se você quer performance.

 

Já ia esquecendo, após fazer a alteração lá encima
 

cd /etc
vi fstab 
/swap/swapfile swap swap defaults 0 0

salva e dê um reboot

Você precisa configurar corretamente o varnish, ele esta pegando/querendo pegar muita memoria.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.



×
×
  • Create New...

Important Information