Clicky

Jump to content
  • Sign Up
Sign in to follow this  
sylassouza

Preciso rodar PHP 5.2 no VPS

Recommended Posts

Bom dia.

Estou tendo muita dificuldade de instalar o php 5.2 num VPS da Digital Ocean, isso porque as distribuições disponíveis possuem versões mais recentes, logo suas dependências e repositórios instalam sempre as últimas versões da linguagem, o mais próximo que consegui instalar foi a 5.3, mas essa não me interessa.

Minha dúvida é: Optando por instalar um painel de controle Open Source, seria me dado a opção de usar outra versões do PHP assim como ocorre no EasyApache do cPanel ou há alguma outra maneira de eu usar a versão 5.2?

Share this post


Link to post
Share on other sites

a maneira mais simples é instalar algum plugin de multiplas versões do PHP. 

https://www.nixtree.com/ntphp.php

  • Like 1

 Super T Host | Revenda de Hospedagem Ilimitada a partir de R$ 25,95 por mês
 Utilize o cupom PDH e ganhe 60% de desconto nos 3 primeiros meses nos planos de Revenda.
 www.superthost.com.br - Telefone e WhatsApp 21 4125 4334

Share this post


Link to post
Share on other sites
2 horas atrás, sylassouza disse:

Bom dia.

Estou tendo muita dificuldade de instalar o php 5.2 num VPS da Digital Ocean, isso porque as distribuições disponíveis possuem versões mais recentes, logo suas dependências e repositórios instalam sempre as últimas versões da linguagem, o mais próximo que consegui instalar foi a 5.3, mas essa não me interessa.

Minha dúvida é: Optando por instalar um painel de controle Open Source, seria me dado a opção de usar outra versões do PHP assim como ocorre no EasyApache do cPanel ou há alguma outra maneira de eu usar a versão 5.2?

CloudLinux ajuda também

  • Like 1

Share this post


Link to post
Share on other sites

Desde já agradeço a resposta de vocês, mas pelo que vi as possibilidades apresentadas são pagas, conhecem alguma opção onde eu possa instalar um seletor de versão mesmo que seja por linha de comando?

Share this post


Link to post
Share on other sites
53 minutos atrás, sylassouza disse:

Hum... No caso eu poderia por exemplo instalar o ntPHPselector  + VestaCP num servidor Ubuntu com a versão da distro atualizada?

Creio que seja possível, faça um teste. Não é compensável uma Hospedagem ou Revenda de Hospedagem que já tenha esses recursos?

Share this post


Link to post
Share on other sites
8 horas atrás, sylassouza disse:

Hum... No caso eu poderia por exemplo instalar o ntPHPselector  + VestaCP num servidor Ubuntu com a versão da distro atualizada?

Não sei se ele funciona no Ubuntu, recomendo que use o CentOS 6.x (o 7 não é compatível com PHP 5.2)


 Super T Host | Revenda de Hospedagem Ilimitada a partir de R$ 25,95 por mês
 Utilize o cupom PDH e ganhe 60% de desconto nos 3 primeiros meses nos planos de Revenda.
 www.superthost.com.br - Telefone e WhatsApp 21 4125 4334

Share this post


Link to post
Share on other sites

Bom dia.

 

Pelo que notei só funciona se estiver usando o cPanel, correto? Pois fiz a instalação do CentOS 6.7 x86, depois do httpd + suPHP que são pré-requisitos mas o script de não funciona. No meu caso eu precisaria de uma solução via linha de comando pois não pretendo utilizar painéis.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.




×
×
  • Create New...