Clicky

Hospedado por Limestone Networks

Jump to content
  • Sign Up

Sign in to follow this  
ThyagoSilva

Wonza Não inicia sem ser pelo putty logado

Recommended Posts

Olá boa tarde galerinha, então tó com um problema que não consigo solucionar, estou com um vps simples apenas para testes internos com ram de 128 1 núcleo e 10GB De hd, Oque acontece e que instalei o wonza e etc com licença até ai ok, porem o mesmo só inicia e roda o wonza se eu der o start pelo putty com o seguinte comando: 

cd /usr/local/WowzaMediaServer-2.2.4/bin
./startup.sh

Ate ai ok porem depois de fechar o putty o wonza para de funcionar, já utilizei os comandos:

chkconfig --add WowzaMediaServer
chkconfig WowzaMediaServer on

Para que ele inicie no boot mais nem água poderia me ajudar pessoal?

Share this post


Link to post
Share on other sites

@ThyagoSilva

Amigo provavelmente esteja fora dos pré-requisitos mínimos para rodar o Servidor:

http://www.wowza.com/products/streaming-engine/specifications

System Requirements

Minimum recommended production hardware

CPU: Single Quad Core, 3.00 GHz or better

RAM: 4GB

Disk: 2 or more in RAID 0 (striping)

Network: 1Gbps Ethernet

Java (required)

Java Runtime Environment (JRE) 8+
or
Java Development Kit (JDK) 8+

 

Abraços


Consultoria em TI - Soluções Hospedadas  - Licenças Plesk (Partner) - Assistência Técnica  - Site: tecsecret.com.br

Share this post


Link to post
Share on other sites

Nesse caso o problema é que você está iniciando pelo SSH e o comando fica ativo enquanto a sessão do SSH estiver ativa.

Instale o screen via apt-get install screen ou yum install screen

Ai abra o ssh, conecte ao servidor, digite o comando screen e ai inicie o Wowza normalmente e feche o ssh. Ele deve continuar a funcionar normalmente, se funcionar normalmente após fechar o ssh indo diretamente no X do Putty o problema é apenas em iniciar o serviço em background.

  • Like 1

Share this post


Link to post
Share on other sites

@ThyagoSilva

Amigo provavelmente esteja fora dos pré-requisitos mínimos para rodar o Servidor:

http://www.wowza.com/products/streaming-engine/specifications

System Requirements

Minimum recommended production hardware

CPU: Single Quad Core, 3.00 GHz or better

RAM: 4GB

Disk: 2 or more in RAID 0 (striping)

Network: 1Gbps Ethernet

Java (required)

Java Runtime Environment (JRE) 8+
or
Java Development Kit (JDK) 8+

 

Abraços

 não necessariamente , wowza roda tranquilamente com configurações abaixo do solicitado.

Porem tenho 95% de certeza que seja um wowza null este é um erro comum das versões null do wowza.

As versões null do wowza quase todas que conheço nenhuma inicia no null , a maior parte vc inicia pelo putty e ainda em alguns casos tem de dativar o iptabels .


Comando correto de start é esse: 

/sbin/service WowzaMediaServer start

 

 

  • Like 1

Fox Soluções  | Streaming Áudio - Revendas de Streaming | Data Center Brasil  EUA  | www.FoxSolucoes.com
 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×
×
  • Create New...