Jump to content

Atualização Do Whmcs 5.1.5 > 5.2.3 Problemas Com Senha Do Admin


Recommended Posts

Pessoal,

 

Alguém que tenha passado por este problema, se puder dar uma dica de como resolver será bem vindo.

 

Já abri um ticket no whmcs.com mas até este momento nenhuma ação ou resposta foi dada por parte deles.

 

Atualizei o whmcs para versão 5.2.3 a partir da versão 5.1.5, ocorre que após remover a pasta install, fui logar e a senha estava incorreta.

 

Insisti e obviamente fui banido...

 

Tentei acesso com outros logins admins que tenho nessa instalação e todos eles estavam com problema na senha.

 

Então resetei a senha, recebi a nova senha por email, ao tentar logar o erro persiste.

 

Encontrei um tópico do Edvan fornecendo informações de uma senha em MD5, substitui e tentei o acesso, mas sem sucesso também.

 

Eu consigo me desbanir pelo phpmyadmin, ao resetar a senha vejo que a tabela é gravada pela nova senha, mas o acesso é impossível.

 

Se alguém que tenha passado por este problema puder ajudar...

 

Obrigado

 

:)

Link to comment
Share on other sites

Pessoal,

 

Alguém que tenha passado por este problema, se puder dar uma dica de como resolver será bem vindo.

 

Já abri um ticket no whmcs.com mas até este momento nenhuma ação ou resposta foi dada por parte deles.

 

Atualizei o whmcs para versão 5.2.3 a partir da versão 5.1.5, ocorre que após remover a pasta install, fui logar e a senha estava incorreta.

 

Insisti e obviamente fui banido...

 

Tentei acesso com outros logins admins que tenho nessa instalação e todos eles estavam com problema na senha.

 

Então resetei a senha, recebi a nova senha por email, ao tentar logar o erro persiste.

 

Encontrei um tópico do Edvan fornecendo informações de uma senha em MD5, substitui e tentei o acesso, mas sem sucesso também.

 

Eu consigo me desbanir pelo phpmyadmin, ao resetar a senha vejo que a tabela é gravada pela nova senha, mas o acesso é impossível.

 

Se alguém que tenha passado por este problema puder ajudar...

 

Obrigado

 

smile.png

 

Vou te dá uma outra dica... rode esse SQL na sua base de dados:

INSERT INTO `tbladmins` VALUES (7,1,x'746573746573','e10adc3949ba59abbe56e057f20f883e','','',x'746573746573',x'746573746573',x'746573746573407465737465732E636F6D','','',x'626C656E64',x'656E676C697368',0,0,'','','');

 

Em seguida acesse seu admin e efetue login:

 

Usuário: testes

Senha: 123456

 

Outra dica, possa ser que exista algum arquivo corrompido na sua instalação... recomendo que reenviei todos os arquivos ( zipa e descompacta via cPanel/Gerenciador de arquivos ).

Link to comment
Share on other sites

Opa Edvan,

 

Tentei fazer este procedimento que você comentou, tentei rodar diretamente pela aba SQL e também criei um arquivo .sql com este codigo que passou, mas ambos apresentam o mesmo erro:

 

#1136 - Column count doesn't match value count at row 1

 

Quanto ao envio dos arquivos, eu enviei compactado e descompactei via gerenciador de arquivos do cpanel mesmo, após o problema, reenviei os arquivos.

Link to comment
Share on other sites

Opa Edvan,

 

Tentei fazer este procedimento que você comentou, tentei rodar diretamente pela aba SQL e também criei um arquivo .sql com este codigo que passou, mas ambos apresentam o mesmo erro:

 

#1136 - Column count doesn't match value count at row 1

 

Quanto ao envio dos arquivos, eu enviei compactado e descompactei via gerenciador de arquivos do cpanel mesmo, após o problema, reenviei os arquivos.

 

Estranho, rodei esse comando aqui e funcionou.

 

Rode outro comando:

 

UPDATE `tbladmins` SET `loginattempts`=0;
Link to comment
Share on other sites

Este não apresentou erros, veja o resultado:

 

0 linha afetada. ( Consulta levou 0.0002 segundos )

 

Então ótimo!

 

Quer dizer que não existe nenhum impedimento no campo loginattempts responsável pela contagem das tentativas inválidas de acesso.

 

Tente novamente com esse código... 

INSERT INTO `tbladmins` VALUES ('',1,x'746573746573','e10adc3949ba59abbe56e057f20f883e','','',x'746573746573',x'746573746573',x'746573746573407465737465732E636F6D','','',x'626C656E64',x'656E676C697368',0,0,'','','');

 

Utilizei o phpMyAdmin ( http://clip2net.com/s/4R9ynP ) e o MySQLFront ( http://clip2net.com/s/4R9AVF ) e foi processado normalmente ( http://clip2net.com/s/4R9Dsi ) as 3x.

Link to comment
Share on other sites

Realmente não funciona Edvan.

 

Eu pensei em remover os usuários (são 4 admins) e tentar fazer isso.

 

Mas a pouco o suporte do whmcs, deu um feedback, tenho receio de ficar mechendo paralelo a eles e acabar lascando mais ainda a situação hehehe

 

Vou aguardar uma nova posição deles, se nada for resolvido, vou remover os logins e tentar fazer este procedimento novamente.

Link to comment
Share on other sites

Muita calma nessa hora Chuva... remover usuários do WHMCS? Vai que a instalação do WHMCS tem um comportamente ainda mais inesperado e você remove junto os Planos, Clientes e faturas em aberto?

Quando algo dá errado, as chances de tudo mais dar errado são maiores

Confie no suporte, ele é "seu amigo" e se algo der errado é "culpa dele e somente dele". tongue.png

Link to comment
Share on other sites

Muita calma nessa hora Chuva... remover usuários do WHMCS? Vai que a instalação do WHMCS tem um comportamente ainda mais inesperado e você remove junto os Planos, Clientes e faturas em aberto?

Confie no suporte, ele é "seu amigo" e se algo der errado é "culpa dele e somente dele". tongue.png

 

Eu fiz um backup da tabela dos admins, estaria removendo apenas os dados dessa tabela para ver se a criação do admin padrão daria certo e se voltaria teria acesso ao whmcs novamente.

 

Dependendo da resposta do whmcs, vou ser obrigado a tentar o acesso a força bruta ou terei que restaurar o whmcs p/ versão anterior com um backup de uns dois dias atras... :(

 

Só espero que a próxima resposta do suporte não demore + 10 horas hehehehe

Link to comment
Share on other sites

Depois de aguardar por uma solução até essa madrugada, decidi restaurar o banco de dados do dia 2 e restaurar a instalação do whmcs 5.1.5

 

Assim fica registrado minha péssima experiência com o suporte do whmcs :(

 

Por sorte tive poucos pedidos, nenhum ticket e nenhuma confirmação de pagamento durante esse tempo que fiquei sem acesso ao admin...

 

Assim, recadastraremos manualmente os pedidos baseados nos emails recebidos (tenho receio de tentar sobrescrever tabelas do 5.2.3 em cima do 5.1.X)

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...