Clicky

Jump to content
Portal do Host
  • Sign Up

Sign in to follow this  
Angel Junior

Problemas com CRON

Recommended Posts

Bom Dia Senhores,

Estou com um problema, meu cron, simplesmente parou de funcionar, você aciona o link manualmente e nada, deixa o cron rodando e nada, não aparece erro nem nada, alguem viu algo assim na ultima versão ?!? Estas atualizações so me trazem dor de cabeça.


"Não encontro defeitos. Encontro soluções. Qualquer um sabe queixar-se." H.Ford

Share this post


Link to post
Share on other sites

Veja se os demais crons do servidor estão rodando pois eu tive esse problema e era problema do servidor e não do WHMCS. O pessoal da Hostgator não disse o que fez para resolver.


Essencial Host - Hospedagem de sites, blogs, lojas virtuais e administração de servidores
blogdohost.com.br - Dicas para quem trabalha com hospedagem de site

Share this post


Link to post
Share on other sites

Teko,

No entanto eu estou executando o cron manualmente e nada acontece.


"Não encontro defeitos. Encontro soluções. Qualquer um sabe queixar-se." H.Ford

Share this post


Link to post
Share on other sites
Teko,

No entanto eu estou executando o cron manualmente e nada acontece.

@Angel,

Perdi as contas de quantos WHMCS passam por isso.

Semana passada percebi que o WHMCS Cron Job Activity não chegou consequentemente é problema na cron job visto que as configurações SMTP estavam ok.

Ao executar a Cron Job via HTTP e não aparecer nenhum erro possa ser que não tem nada errado!

Para resolver fiz assim:

- Ative o debug no configuration.php

$display_errors="on";

Acesse http://www.seuwhmcs.com/seuadmin/cron.php?skip_backups=1

Esse macete acima ( skip_backups=1 ) vai fazer com que a CRON JOB seja executada "mais rápida" pois não fará backup do .SQL/transferir para um FTP externo e etc... Eu até optei por fazer backup a parte pois imagine fazer um backup de 500 megas e depois transferir via FTP externo? Tive N problemas com isso e o WHMCS ficava parado por conta disso.

Em seguida aguarde... Caso você não visualize nenhum erro respire aliviado!

No meu caso o problema era um módulo antigo que eu tinha excluído do /modules/gateways/ e com isso veio aquele erro chatinho ( Module Gateway Missing ). Daí troquei a fatura que estava com módulo antigo e rodei o cron, resolvido o problema!

Depois dá uma lida em http://www.whmcs.blog.br/principal/cron-job-whmcs/

Após resolver seu problema remova/comente a linha no configuration.php

#$display_errors="on";

Depois dá um retorno!

Abraços


Blog sobre WHMCS: http://whmcs.blog.br/
Serviços WHMCS: http://servicos.edvan.com.br/
Módulos WHMCS: http://modulos.edvan.com.br/

Share this post


Link to post
Share on other sites

Edvan,

Obrigado pela resposta rapida e rasteira.

Vou fazer os testes mais tarde.

Um fato estranho, é que realmente o cron rodou quando rodei ele manualmente como diz o log ao menos:

19/10/2011 08:18 Cron Job: Starting

No entanto o WHMCS Cron Job Activity não chegou realmente, e não pode ser smtp pois esta enviando para o mesmo servidor.

Estou aqui agora buscando o conhecimento para resolver.


"Não encontro defeitos. Encontro soluções. Qualquer um sabe queixar-se." H.Ford

Share this post


Link to post
Share on other sites
Edvan,

Obrigado pela resposta rapida e rasteira.

Vou fazer os testes mais tarde.

Um fato estranho, é que realmente o cron rodou quando rodei ele manualmente como diz o log ao menos:

19/10/2011 08:18 Cron Job: Starting

No entanto o WHMCS Cron Job Activity não chegou realmente, e não pode ser smtp pois esta enviando para o mesmo servidor.

Estou aqui agora buscando o conhecimento para resolver.

Blz.

Ativando o Debug e rodando a cron via http você achará uma luz!


Blog sobre WHMCS: http://whmcs.blog.br/
Serviços WHMCS: http://servicos.edvan.com.br/
Módulos WHMCS: http://modulos.edvan.com.br/

Share this post


Link to post
Share on other sites

É não vai ser agora que vou respirar aliviado.

Problema encontrado no modulo do pagseguro do Carlo, vou entrar em contato com ele.

Volto em breve para postar o retorno.


"Não encontro defeitos. Encontro soluções. Qualquer um sabe queixar-se." H.Ford

Share this post


Link to post
Share on other sites

Vai que alguem já resolveu o problema neh.

O Erro:

Fatal error: Uncaught exception 'Exception' with message 'String could not be parsed as XML' in /home/conta/public_html/central/modules/gateways/pagseguro.php:96 Stack trace: #0 /home/conta/public_html/central/modules/gateways/pagseguro.php(96): SimpleXMLElement->__construct('Unauthorized') #1 /home/conta/public_html/central/admin/../includes/functions.php(0): pagseguro_link(Array) #2 /home/conta/public_html/central/admin/cron.php(0): sendMessage() #3 {main} thrown in /home/conta/public_html/central/modules/gateways/pagseguro.php on line 96

"Não encontro defeitos. Encontro soluções. Qualquer um sabe queixar-se." H.Ford

Share this post


Link to post
Share on other sites
Vai que alguem já resolveu o problema neh.

O Erro:

Angel,

Edita o arquivo modules/gateways/pagseguro.php e insira acima da linha 57 o código:

$localizacao = basename($_SERVER['PHP_SELF']);

if ($localizacao=="viewinvoice.php" ){

E abaixo da linha 109 coloque:

}

Veja se continuará dando erro!

Edited by edvan
Localização Arquivo

Blog sobre WHMCS: http://whmcs.blog.br/
Serviços WHMCS: http://servicos.edvan.com.br/
Módulos WHMCS: http://modulos.edvan.com.br/

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×
×
  • Create New...