Jump to content

Erro ao instalar NGNIX


Andre Juliano

Recommended Posts

Boa tarde pessoal

Alguem já passou por esse problema ao instalar o Ngnix. Segue o erro abaixo:

root@de01 [/usr/local/src/publicnginx]# ./nginxinstaller install

/usr/local/src/publicnginx

Welcome to the Nginx Admin installer......Starting Install

Generating vhosts...

Traceback (most recent call last):

  File "/scripts/createvhosts.py", line 2, in ?

    import yaml

  File "/usr/lib/python2.4/site-packages/PyYAML-3.10-py2.4-linux-i686.egg/yaml/__init__.py", line 26

SyntaxError: 'yield' not allowed in a 'try' block with a 'finally' clause

Installing WHM interface...

deploying booster rockets

Traceback (most recent call last):

  File "/usr/local/src/publicnginx/nginxinstaller2", line 9, in ?

    import createvhosts

  File "/usr/local/src/publicnginx/createvhosts.py", line 2, in ?

    import yaml

  File "/usr/lib/python2.4/site-packages/PyYAML-3.10-py2.4-linux-i686.egg/yaml/__init__.py", line 26

SyntaxError: 'yield' not allowed in a 'try' block with a 'finally' clause

Já instalei o ngnix em varios servidores e essa é a primeira vez que isso acontece comigo. Alguem teria uma luz?

Obrigado.

Edited by donruan

WebChamp - Hospedagem de Sites, Revenda de Hospedagem, Revenda de VPS, Servidores Virtuais  (OpenVZ / KVM).

Link to comment
Share on other sites

Jordan o erro perciste.

O engraçado é que acabei de criar um outro vps no meu dedicado e aconteceu o mesmo erro na instalação do ngnix. Estou usando o hypervm para virtualizar. Será que é algo bugado no hypervm?

WebChamp - Hospedagem de Sites, Revenda de Hospedagem, Revenda de VPS, Servidores Virtuais  (OpenVZ / KVM).

Link to comment
Share on other sites

Pessoal, depois de semanas perdendo sono, consegui resolver o meu problema bastando atualizar o python para a versão 2.5.2

Reinstalei dessa forma:

wget http://www.python.org/ftp/python/2.5.2/Python-2.5.2.tgz

tar fxz Python-2.5.2.tgz

cd Python-2.5.2

./configure

make

make install

Obrigado a todos pela ajuda.

WebChamp - Hospedagem de Sites, Revenda de Hospedagem, Revenda de VPS, Servidores Virtuais  (OpenVZ / KVM).

Link to comment
Share on other sites

Não é recomendado fazer upgrade do Python, e sim atualizar o Pyaml.

Para 64 bits:

cd /usr/lib/python2.4/site-packages

mv PyYAML-3.10-py2.4-linux-x86_64.egg PyYAML-3.10-py2.4-linux-x86_64.egg_

wget http://alex-montana.co.cc/PyYAML-3.09-py2.4-linux-x86_64.egg[url=http://alex-montana.co.cc/PyYAML-3.09-py2.4-linux-x86_64.egg]

Para 32 bits:

cd /usr/lib/python2.4/site-packages

mv PyYAML-3.10-py2.4-linux-i686.egg PyYAML-3.10-py2.4-linux-i686.egg_

wget http://alex-montana.co.cc/PyYAML-3.09-py2.4-linux-i686.egg

Após isto, proceder com a instalação normalmente.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

Do you agree with our terms?