Jump to content

Erro módulo de registro - resellerclub


Recommended Posts

1 hora atrás, PetrusHenrique disse:

Pessoal, to com um erro quando o WHMCS tenta se conectar com o ResellerClub para registrar um domínio.info

 

O erro é esse: Required parameter missing: username 

 

Já rodei o fórum e a net procurando oq pode ser, o cadastro do cliente está todo preenchido.

Liberou os IPs na API?

Link to comment
Share on other sites

Pelo erro é algum problema no teu módulo de registro do WHMCS, ele não está enviando o nome de usuário para a API da ResellerClub.

Geralmente esse nome de usuário é o endereço de e-mail do cliente, você usa módulo de terceiros ou o nativo do WHMCS? Tenta verificar com o desenvolvedor senão há alguma atualização desse módulo.

Link to comment
Share on other sites

Poxa, essa me pegou kkk

O estranho é que registro de domínio não precisa de username, o WHMCS está tentando enviar esse campo que não é necessário e que está vazio para o registro.

Apenas por curiosidade, verifica se a opção "Habilitar Nomes de Usuários Aleatórios" está desmarcada na aba de pedidos.

Infelizmente você terá que pedir suporte para o desenvolvedor mesmo, esse erro não é comum, fala com o pessoal do WHMCS eles podem resolver essa questão mais rápida para você.

Link to comment
Share on other sites

Ta desmarcada sim! Estou tentando ver aqui o que pode ser, se conseguir resolver, coloco aqui caso alguém tenha o mesmo problema.

Gente, o problema foi simples. Agradeço a disposição de todos em ajudar.

Na verdade eu estava tentando rodar o módulo de registro antes de aceitar o pedido no WHMCS. Aceitei o pedido e o módulo rodou de boa.

Link to comment
Share on other sites

1 hora atrás, PetrusHenrique disse:

Ta desmarcada sim! Estou tentando ver aqui o que pode ser, se conseguir resolver, coloco aqui caso alguém tenha o mesmo problema.

Gente, o problema foi simples. Agradeço a disposição de todos em ajudar.

Na verdade eu estava tentando rodar o módulo de registro antes de aceitar o pedido no WHMCS. Aceitei o pedido e o módulo rodou de boa.

Às vezes é uma indisponibilidade na API.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...