Jump to content

problema custom field produto


Recommended Posts

Olá,

Tenho um produto cadastrado e estou com problema nos campos personalizados.

Esse produto tenho que enviar os dados de acesso manualmente, não existe módulo para ele.

Logo, eu criei um email de boas vindas e criei campos personalizados no produto para que quando eu preencher esses campos personalizados na conta do cliente e em seguida aceitar o pedido o email de boas vindas ser enviado e assim os dados de acesso serem enviados tbm.

Acontece que mesmo eu preenchendo tudo, os dados de acesso não vão no e-mail, os campos ficam em branco, veja exemplo:

IP: {$service_custom_field_ipftp}

Agora vou mostrar como preenchi os campos personalizado do produto em questão:

eu coloquei o nome do campo personalizado na string de validação, veja imagem:

wF0WLhG.png

O que to fazendo de errado?

 

Obrigado pela ajuda!

so pra dizer, eu segui a documentação aqui: http://docs.whmcs.com/Email_Templates#Product_Custom_Fields

Veja esse trecho que diz o que tenho que fazer:

Product Custom Fields

  • The same applies to Product custom fields, however they are referenced by{$service_custom_field_fieldnamehere}.

Abraço

Link to post
Share on other sites
  • Replies 9
  • Created
  • Last Reply

Top Posters In This Topic

O que voce esta fazendo de errado é a forma que esta a codificação do custom fields. O correto é ficar  {$service_custom_fields} mais como a ordem personalizada do seu campo personalizado é 2 voce tem que colocar da seguinte forma :  {$service_custom_fields.2}

 

Espero ter ajudado

Conecte Host - Soluções em Nuvem | Hospedagem Cloud | Registro de Domínios | Cloud Server | Servidores Dedicado EUA e BR | Cloud Server cPanel

Link to post
Share on other sites
Em 16/03/2016 at 21:37, BSHosting disse:

Talvez o @edvan possa te ajudar!

valeu, se ajudar vai ser bom mesmo =)

Em 16/03/2016 at 22:32, Breno Febronio disse:

O que voce esta fazendo de errado é a forma que esta a codificação do custom fields. O correto é ficar  {$service_custom_fields} mais como a ordem personalizada do seu campo personalizado é 2 voce tem que colocar da seguinte forma :  {$service_custom_fields.2}

 

Espero ter ajudado

Rapaz, eu fiz como falou, a ordem de exibição seria o custom field?

aqui funcionou, mas apareceu tudo fora de ordem, tipo no lugar de ip apareceu o nome de usuário, etc... tudo desorganizado kkk

Obrigado @Breno Febronio

Link to post
Share on other sites
  • 9 months later...
Guest felinto

O tópico foi aberto faz tempo, mas e aí @fastspeed, encontrou uma solução ? :D

Estou com o mesmo problema e talvez sua resposta possa ajudar outros usuários como eu.

Abs! :D

PS: @edvan você é fera nessa área, dá uma ajudinha aí pra nós :D

Link to post
Share on other sites
2 horas atrás, felinto disse:

O tópico foi aberto faz tempo, mas e aí @fastspeed, encontrou uma solução ? :D

Estou com o mesmo problema e talvez sua resposta possa ajudar outros usuários como eu.

Abs! :D

PS: @edvan você é fera nessa área, dá uma ajudinha aí pra nós :D

Criei um email template na categoria correta http://prntscr.com/dyfanf

Insere no email template o "ID" (na verdade é a posição) iniciando a partir de 0 (zero) http://prntscr.com/dyfa69 seguindo a ordem cadastrada http://prntscr.com/dyfay5

Confirmo se os campos estão preenchidos http://prntscr.com/dyf9ck

Faço o envio de testes e pronto http://prntscr.com/dyfagc

Blog sobre WHMCS: http://whmcs.blog.br/
Serviços WHMCS: http://servicos.edvan.com.br/
Módulos WHMCS: http://modulos.edvan.com.br/

Link to post
Share on other sites
3 horas atrás, fastspeed disse:

Obrigado @edvan, agora funcionou, o meu estava dando erro por eu está colocando o primeiro campo como 1, agora que iniciei como 0 funcionou perfeitamente!!!!

Grande abraço!

Disponha, abs

Blog sobre WHMCS: http://whmcs.blog.br/
Serviços WHMCS: http://servicos.edvan.com.br/
Módulos WHMCS: http://modulos.edvan.com.br/

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.


Chat

Chat

    You don't have permission to chat.
    ×
    ×
    • Create New...