Clicky

Jump to content
  • Sign Up
Sign in to follow this  
fastspeed

Erro ao enviar email depois de migração

Recommended Posts

Olá galera,

Acabei de migrar meu WHMCS para outro dedicado, estou no Cloudlinux 7

tento enviar email pelo WHMCS aparece a seguinte mensagem de erro no debug:

2015-12-08 02:19:36 Connection: opening to mail.meudominio.com.br:587, timeout=300, options=array ( ) 2015-12-08 02:19:37 SMTP ERROR: Failed to connect to server: php_network_getaddresses: getaddrinfo failed: Name or service not known (0) 2015-12-08 02:19:37 SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

Email Sending Failed - SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

Email Queue Processing Completed

 

Alguem sabe como resolver isso ai?

Preciso usar o sistema para enviar emails e não estou conseguindo, ja testei outras versões do php, meu servidor de emails funciona perfeitamente.

 

Alguma dica galera?

 

Abraço


Tudo para seu host você vai encontrar aqui  Meu Site | Hospedagem cPanel | Ubuntu | Gerador de Senha

Share this post


Link to post
Share on other sites

Uma dúvida, a versão do PHP que apresenta o erro, por acaso é 5.6?

#Edit

Agora eu entendi... pensei que tinha dito que funcionava nas outras versões e funcionava.


Logs... logs, muitas logs :3

Share this post


Link to post
Share on other sites
12 horas atrás, Clayderson disse:

Uma dúvida, a versão do PHP que apresenta o erro, por acaso é 5.6?

#Edit

Agora eu entendi... pensei que tinha dito que funcionava nas outras versões e funcionava.

em qualquer versão isso acontece =(


Tudo para seu host você vai encontrar aqui  Meu Site | Hospedagem cPanel | Ubuntu | Gerador de Senha

Share this post


Link to post
Share on other sites
20 minutos atrás, registroinfoweb disse:

Já verificou a porta que o EXIM está executando?

Sim, não a problema com o servidor de emails, já fiz vários testes.

Acho que é algo com meu servidor, pois fiz uma instalação nova do WHMCS e apresentou o mesmo problema, alguem já passou por isso? 

não achei nada na internet que eu soubesse como resolcver.

Obrigado


Tudo para seu host você vai encontrar aqui  Meu Site | Hospedagem cPanel | Ubuntu | Gerador de Senha

Share this post


Link to post
Share on other sites

Pode ser que não seja problema no servidor, e sim nas configurações de email do WHMCS.

Ao migrar de servidor, alguma configuração pode ser diferente e por isso ele não consegue conectar. Eu recomendo que vá nas configurações de email do WHMCS e comece a preencher os dados lá de todas as formas possíveis. Tem opção pra enviar e-mail autenticado, usar certificado tls ou ssl, alterar a porta... enfim.

Além disso, no link que é passado na mensagem de erro, tem uma lista com os vários motivos que podem causar esse problema. Recomendo que leia também.

  • Like 1

Logs... logs, muitas logs :3

Share this post


Link to post
Share on other sites

Pelo que me parece, você esta enviando um e-mail autenticado. Você já tentou usar o PHP Mail ? Ele enviou?

A algumas semanas atrás, obtive esse erro e foi a configuração do servidor, ele estava recusando o acesso ao servidor smtp criptografado.
Tente enviar o e-mail autenticado sem criptografia 


Hospedagem de sites, Streamings, Revendas, Dedicados e vps >> www.maximalhost.com | Desenvolvimento de sistemas PHP, Python, JAVA, C# e Gerenciamento de Servidores >> brunowebmaster@live.com

Share this post


Link to post
Share on other sites
Em 09/12/2015 at 23:43, brunowebmasterr disse:

Pelo que me parece, você esta enviando um e-mail autenticado. Você já tentou usar o PHP Mail ? Ele enviou?

A algumas semanas atrás, obtive esse erro e foi a configuração do servidor, ele estava recusando o acesso ao servidor smtp criptografado.
Tente enviar o e-mail autenticado sem criptografia 

Acho que não é isso @brunowebmasterr 


Tudo para seu host você vai encontrar aqui  Meu Site | Hospedagem cPanel | Ubuntu | Gerador de Senha

Share this post


Link to post
Share on other sites

achei isso aqui no forum WHMCS.

http://forum.whmcs.com/showthread.php?109163-Error-Message-shown-when-trying-sending-email&p=447163#post447163

tenho meu próprio server mas ja alterei os valores conforme solicitado no arquivo /etc/my.cnf porem não resolveu.

Alguem tem alguma luz ai?


Tudo para seu host você vai encontrar aqui  Meu Site | Hospedagem cPanel | Ubuntu | Gerador de Senha

Share this post


Link to post
Share on other sites
9 horas atrás, fastspeed disse:

achei isso aqui no forum WHMCS.

http://forum.whmcs.com/showthread.php?109163-Error-Message-shown-when-trying-sending-email&p=447163#post447163

tenho meu próprio server mas ja alterei os valores conforme solicitado no arquivo /etc/my.cnf porem não resolveu.

Alguem tem alguma luz ai?

Em 99,9% dos casos que atendo é bloqueio no firewall ou configurações incorretas (porta, usuário ou senha).

Utilizar phpMail não é recomendável pois não garante a entrega de emails.

  • Like 1

Blog sobre WHMCS: http://whmcs.blog.br/
Serviços WHMCS: http://servicos.edvan.com.br/
Módulos WHMCS: http://modulos.edvan.com.br/

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.




×
×
  • Create New...