Jump to content
  • Sign Up
Sign in to follow this  
Jaime Silva

Seletor de Versões do PHP para cPanel

Recommended Posts

Permite a cada usuário cPanel selecionar a versão do PHP usada em determinado domínio (principal, adicional ou subdomínio).

Versões disponíveis e instaladas pelo aplicativo: 5.2, 5.3, 5.4, 5.5 e 5.6

  • Customização aplicável também a domínios adicionais e subdomínios
  • Pode ser habilitado ou desativado através do Feature Manager
  • Pode ser usado tanto em dedicado quanto em VPS
  • Não é necessário ter CloudLinux com CageFS ativado
  • Extensões instaladas: mbstring, mcrypt, curl, Ioncube/SourceGuardian/Zend Guard Loader

Para instalar:
wget http://rgaidc.com/apps/seletor_versoes_php.sh
sh seletor_versoes_php.sh -i
Para remover:
wget http://rgaidc.com/apps/seletor_versoes_php.sh
sh seletor_versoes_php.sh -u

 

Após instalação, fica disponível no cPanel em Software/Services » Mudar Versão do PHP

Aos usuários, ficaria agradecido se me enviasse R$ 20,00 via Paypal, Moip ou ContaSuper (solicite o endereço via Mensagem Particular)

Para os desconfiados: o sistema é código-aberto e você pode ver o que é instalado.

 

PHP.png

 

Requerimentos:

  • [a ser removido na próxima versão] a conta cPanel deve ter acesso CGI*
  • se usa CageFS, poder ser necessário rodar /usr/sbin/cagefsctl --update
  • para instalar, necessário ter acesso root

* Se já não estiver habilitado, você pode ativar para determinada conta (Account Functions » Modify an Account) ou para todos sob um mesmo plano (Packages » Edit a Package)

   Recomendado ativar o SuEXEC para rodar scripts com as permissões do usuário (Service Configuration » Configure PHP and suEXEC)

  • Like 2

Share this post


Link to post
Share on other sites

Alguém já utilizando em servidor já em produção?

 

@Jaime

Onde ficaria o php.ini de cada versão do PHP? Esse script alteraria as configurações do PHP original no servidor? Tem alguma documentação sobre o mesmo para obtermos informações sobre o funcionamento deste incrível script?

 

Obrigado!

Share this post


Link to post
Share on other sites

Alguém já utilizando em servidor já em produção?

 

@Jaime

Onde ficaria o php.ini de cada versão do PHP? Esse script alteraria as configurações do PHP original no servidor? Tem alguma documentação sobre o mesmo para obtermos informações sobre o funcionamento deste incrível script?

 

Obrigado!

 

O php.ini fica em /opt/php/numero_versao_usada/etc

Não altera configuração alguma, visto que se trata de uma instalação independente.

Não possui documentação.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...