Jump to content

Problemas Com Ftp Modo Passivo Em Vps Xen


PauloNichio

Recommended Posts

Olá galera, olha eu voltando aqui com mais um problema para pedir ajuda a vocês.

 

É o seguinte: Terça-feira (11/03) contratei um VPS Xen para efetuar alguns testes, pois bem, tudo está nos conforme, funcionando certinho, porém o FTP Modo Passivo não funciona nem por decreto (o modo ativo está OK, sem qualquer problema).

 

Quando eu tento conectar pelo FileZilla, recebo a seguinte mensagem:

 

Estado:    Conectando xxx.xxx.xx.xxx:21...
Estado:    Conexão estabelecida, esperando mensagem de boas-vindas...
Resposta:    220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Resposta:    220-You are user number 1 of 50 allowed.
Resposta:    220-Local time is now 13:49. Server port: 21.
Resposta:    220-This is a private system - No anonymous login
Resposta:    220-IPv6 connections are also welcome on this server.
Resposta:    220 You will be disconnected after 15 minutes of inactivity.
Comando:    USER xxxx
Resposta:    331 User xxxxx OK. Password required
Comando:    PASS *********
Resposta:    230 OK. Current restricted directory is /
Comando:    SYST
Resposta:    215 UNIX Type: L8
Comando:    FEAT
Resposta:    211-Extensions supported:
Resposta:     EPRT
Resposta:     IDLE
Resposta:     MDTM
Resposta:     SIZE
Resposta:     MFMT
Resposta:     REST STREAM
Resposta:     MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
Resposta:     MLSD
Resposta:     AUTH TLS
Resposta:     PBSZ
Resposta:     PROT
Resposta:     TVFS
Resposta:     ESTA
Resposta:     PASV
Resposta:     EPSV
Resposta:     SPSV
Resposta:     ESTP
Resposta:    211 End.
Estado:    O servidor não suporta caracteres que não sejam ASCII.
Estado:    Conectado
Estado:    Obtendo lista de pastas...
Comando:    PWD
Resposta:    257 "/" is your current location
Comando:    TYPE I
Resposta:    200 TYPE is now 8-bit binary
Comando:    PASV
Erro:    A conexão excedeu limite de tempo
Erro:    Falha na obtenção da lista de pastas

 

E imediatamente, no SSH recebo as seguintes mensagens:

 

Message from syslogd@server at Mar 16 13:50:52 ...
 kernel:nf_ct_ftp: dropping packetIN= OUT=eth0 SRC=xxx.xxx.xxx.xxx DST=xxx.xxx.xx.xxx LEN=65 TOS=0x10 PREC=0x00 TTL=64 ID=42134 DF PROTO=TCP SPT=21 DPT=59643 SEQ=815198264 ACK=2498732062 WINDOW=115 RES=0x00 ACK PSH FIN URGP=0 OPT (0101050A94EFA01D94EFA01E)

 

Primeira coisa que pensei era, opaaa o CSF está bloqueando a conexão, vamos liberar lá, então fiz o seguinte, editei o arquivo /etc/pure-ftpd.conf, liberando as PassivePortRange  30000 35000 e logo após no firewall em TCP_IN adicionei 30000:35000 - reiniciei os serviços e nada, até exclui o CSF e nada também.

 

O engraçado de tudo isto é que pelo modo Ativo funciona normalmente, apenas pelo modo passivo está dando problemas, pois bem contatei o suporte do servidor e o suporte do cPanel. O suporte do cPanel fez uns testes e conseguiu acessar pelo modo passivo via SSH, onde eu testei também e realmente funcionou, apenas pelo Filezilla e programas similares não está funcionando, não sei se está ocorrendo algum bloqueio de conexões de fora ao servidor, enfim, e o suporte do VPS disse que está tudo OK.

Moral da história, o FTP não funciona e ninguém sabe resolver... O duro é o seguinte, poderia usar sem problemas o modo ATIVO, porém se eu colocar esta máquina em produção, como que eu vou falar para os clientes: Viu, tem que trocar do modo passivo para ativo senão não vai funcionar. (O pior é que o modo passivo vem como padrão em todos os programas de FTP)

 

Pois bem, aqui é minha última esperança... alguém já se deparou com um problema como este e saberia me informar o que deve ser feito para resolver o problema? Desde já agradeço demais a atenção dispensada e desculpe pelo longo texto.
 

Link to comment
Share on other sites

Você usa iptables?

Experimente retirar a linha IPTABLES_MODULES do iptables

 

Muito obrigado pela rápida resposta, Felipe.

Eu já cheguei a mexer nesta linha também, porém não resolveu, atualmente as configurações do iptables está assim:

 

140316062257566390.png

Link to comment
Share on other sites

Olá, boa tarde!

 

Apenas para comunicar qual foi a solução deste problema, infelizmente não teve outro jeito a não ser a formatação da máquina.

Na instalação do cPanel havia feito da seguinte maneira:

 

cd /home
wget http://layer1.cpanel.net/latest
chmod 0777 latest
yum install perl
./latest

 

Porém, o correto a se instalar, segundo informação que recebi é:

 

cd /home
wget http://layer1.cpanel.net/latest
chmod 0777 latest
yum install perl

chkconfig iptables off
service iptables stop
yum update
./latest

 

De um jeito ou de outro, desta forma consegui resolver o problema :D

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

Do you agree with our terms?