Jump to content

Centavos


kklo

Recommended Posts

Boa noite a todos!

Sou novo neste forum como também no WHMCS e estou com uma dúvida primária.

Estou dando descontos em percentagem no valor dos planos e logicamente fica quebrados de centavos. Como configurar o sistema para que aceite os centavos?

Uso a versão 5.1.2

Obrigado

Ricardo

Link to comment
Share on other sites

Mateus!

Quando se coloca o preço dos planos em produtos/serviços é colocado o valor mensal, trimestral, etc... se eu coloco um valor como R$ 19,90 em um plano, ao salvar, na tela do frontend aparece o valor arredondado, como R$ 19,00.

Gostaria que continuasse com os centavos.

Link to comment
Share on other sites

Também estou com problema parecido depois que atualizei para versão 5.2.7.

 

O problema é o seguinte, não adianta colocar " . " ou " , " em qualquer parte da adminstração do whmcs que zera os centavos, e também esta acontecendo o mesmo ao gerar as faturas automaticamente pelo cron, todas as fatura estão ficando sem os centavos.

 

Exemplo, se a fatura do cliente é 49.99 esta ficando 49.00.

Link to comment
Share on other sites

Também estou com problema parecido depois que atualizei para versão 5.2.7.

 

O problema é o seguinte, não adianta colocar " . " ou " , " em qualquer parte da adminstração do whmcs que zera os centavos, e também esta acontecendo o mesmo ao gerar as faturas automaticamente pelo cron, todas as fatura estão ficando sem os centavos.

 

Exemplo, se a fatura do cliente é 49.99 esta ficando 49.00.

 

Isso é decorrente de um erro na dica 70 (já corrigida) http://www.whmcs.blog.br/principal/dicas-whmcs-parte-14/

 

Abra seu configuration.php e altere a linha:

setlocale(LC_ALL,'pt_PT');

Para:

setlocale(LC_TIME,'pt_PT');

Problema será resolvido!

Link to comment
Share on other sites

Isso é decorrente de um erro na dica 70 (já corrigida) http://www.whmcs.blog.br/principal/dicas-whmcs-parte-14/

 

Abra seu configuration.php e altere a linha:

setlocale(LC_ALL,'pt_PT');

Para:

setlocale(LC_TIME,'pt_PT');

Problema será resolvido!

Isso mesmo tinha usado essa dica do http://whmcs.blog.br/ fiz a alteração que você falou e problema resolvido.

Obrigado pela dica !

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

Do you agree with our terms?