Clicky

Jump to content
  • Sign Up
Sign in to follow this  
filipi

Problemas com IP Direcionando para Dedicado no SolusVM

Recommended Posts

Olá! Galera Estou com Um problema No Solusvm Que não consigo resolver

bom seguinte, Instalei o openvz No Master do Solusvm, o vps inicia normalmente, Mais o ip que e setado No vps, Não funciona,

é se eu acessar o SSH do vps que setei o ip, O IP vai para o do dedicado Principal.

Se alguem sober como resolver Agradeço!

obs: o vps liga normal So o ip que nao funciona, ele redireciona para o principal.

Share this post


Link to post
Share on other sites

amigo é o seguinte geralmente temos que configurar os ips no node correto la na opção "add ipv4 adress" se os ips foram colocados lá da maneira correta voce precisa fazer uma regra de FORWARD no firewall do dedicado informando que aquela vps tem aquele tal IP. Isso é um tipo de regra de iptables além disso não se esqueça de adicionar o gateway dos ips cadastrados no solusvm colocando como ip de gateway o próprio ip do gateway do dedicado e não o ip do dedicado propriamente dito. No caso o gateway dos ips cadastrados lá no "add ipv4 adress" precisa ver se tudo está devidamente revisado, isso já ocorreu comigo quando eu não tinha colocado o gateway daquela lista de ips que o solusvm pede ai o teu vps não está conseguindo achar o ip dele. Outro detalhe é verificar se sua placa de rede virtual da vps está devidamente configurada porque acontece de algumas distribuições do linux em openvz não instalar a placa de rede virtual da forma correta e ai ocorre o problema. Se está tentando usar o ubuntu 64 bits esse problema também pode ocorrer. Primeiramente tente fazer o seguinte:

1 - de o comando lspci e veja se a placa de rede aparece

2- de o comando ifconfig e veja se a placa de rede aparece com o ip definido no solusvm

3 - Caso a placa de rede esteja aparecendo porém sem o ip rode o comando via ssh system-config-network para configurar a placa de rede e setar os ips

4- se preferir pode também rodar o comando vi /etc/sysconfig/network-script/ e abrir esse script para configurar sua placa de rede

Lembre-se de colocar o ip correto sendo sempre o mesmo usado no solusvm e verificar se o gateway , DNS e demais configurações estão colocadas corretamente

no script da placa de rede. Inclusive minha sugestão é colocar como ip fixo porque assim ficará com tudo configurado correto manualmente mesmo.

Verifique as regras de firewall se elas estão colocadas na vps listando também as portas para verificar se isso pode ter algo com firewall

Para verificar as portas basta rodar o comando iptables -L

Para configurar manualmente os ips existe também um outro comando que é mais ou menos assim:

ifconfig eth0 ip do vps netmask mascara de rede do vps

route add default gw ip do gateway (mesmo gateway do dedicado)

Após as alterações reinicie o VPS

Caso ocorra erro avisa que te ajudo a verificar esse problema


Felipe Ramos !   E-mail: saturnoservidores@gmail.com  Skype: Nobuyko

Share this post


Link to post
Share on other sites
Guest

Correção: não é /etc/sysconfig/network-script, e sim:

/etc/sysconfig/network-scripts/ifcfg-eth0

Correção 2: se ele só digitar os comandos como ifconfig eth0:1 10.6.2.2 no VPS, ele irá perder as configurações após reiniciar, coloque essas configs em um arquivo dentro do init.d.

Edited by Guest

Share this post


Link to post
Share on other sites

Problema Resolvido!, O Marcelo Mandou eu rodar Alguns comandos No Shell, e printei para ele, é achamos o problema que era na netmask, estava errado.

Muito Obrigado A todos, que me ajudou, Moderadores Por favor Feche o topico.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.




×
×
  • Create New...