Clicky

Hospedado por Limestone Networks

Jump to content
  • Sign Up

Sign in to follow this  
Henriquegs

Problema ao Configurar rede do Servidor.

Recommended Posts

Eu comprei um dedicado na soyoustart. e comprei 2 IPS adicionais para criar 2 maquinas virtuais nesse Dedicado, em breve irei criar mais.

 

Instalei o XEN pelo painel do servidor.

Não consigo configurar a rede do servidor, pois a mesma não funciona mesmo fazendo a configuração do gateway do servidor IP adress e mascara de rede.

 

Oque eu fiz, criei a VM, copiei o MAC adress da vm e adicionei no IP do servidor no painel da soyoustart, aí a rede funcionou e consegui instalar o centOs pela url de download, rede funcional perfeitamente, assim que termina de baixar os arquivos e instalar após o reboot a rede simplesmente para de funcionar.

 

O Erro que ocorre é o seguinte:

 

erface eth0:  Determining if ip address 192.95.36.xxx is already in use for device eth0...
[  OK  ]
 
Alguém sabe como resolver isso ?? 
 
e por que a rede funciona quando adiciono o mac no painel do IP e assim faz reboot ele para de funcionar?
 
Como configurar a rede nas maquinas virtuais com os ips adicionais que comprei ?

post-7228-0-62252900-1415632659_thumb.jp

Share this post


Link to post
Share on other sites

O MAC que é criado no painel obrigatoriamente deve bater com o MAC de quando foi criada a VM.

Se antes de reiniciar funciona normalmente, apos reiniciar o Linux deve estar setando outro MAC automaticamente ?

A Ordem seria a seguinte

1- Criar MAC pelo painel

2- Criar a vm com o MAC

3- Seguir o padrão de rede deles http://guides.ovh.com/BridgeClient


HastleHost  | Servidores Virtual | Revenda Brasil/Canadá | Revenda Master | Cloudlinux | WHMCS Free | Rvsitebuilder | Cluster DNS e muito mais 

Share this post


Link to post
Share on other sites

Olá Henrique, tudo bem?

 

Deixa eu ver se entendi bem. Você copiou o MAC gerado no XEN pra essa VM no painel da Soyoustart? Bom, acredito que eles usem o mesmo sistema da OVH. Você teria que ter gerado o MAC no Data Center e ter colado nas configurações da placa de rede da VM no XEN Center. Você fez o contrário, não?

 

Poste aqui também o resultado dos seguintes comandos.

 

ifconfig

 

e

 

route -n

 

Abraços!

Share this post


Link to post
Share on other sites

Olá Henrique, tudo bem?

 

Deixa eu ver se entendi bem. Você copiou o MAC gerado no XEN pra essa VM no painel da Soyoustart? Bom, acredito que eles usem o mesmo sistema da OVH. Você teria que ter gerado o MAC no Data Center e ter colado nas configurações da placa de rede da VM no XEN Center. Você fez o contrário, não?

 

Poste aqui também o resultado dos seguintes comandos.

 

ifconfig

 

e

 

route -n

 

Abraços!

Olá, foi isso mesmo que eu fiz, copei o mac e adicionei no painel, não gerei o mac por lá.

 

root@localhost network-scripts]# ifconfig
eth0      Link encap:Ethernet  HWaddr 02:00:00:5C:6F:C5  
          inet addr:192.95.36.1xx Bcast:192.95.36.1xx  Mask:255.255.255.255
          inet6 addr: fe80::ff:fe5c:6fc5/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1502 errors:0 dropped:0 overruns:0 frame:0
          TX packets:44 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:126190 (123.2 KiB)  TX bytes:2760 (2.6 KiB)
          Interrupt:247 
 
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
 
_______
 
 route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
169.254.0.0     0.0.0.0         255.255.0.0     U     1002   0        0 eth0

Share this post


Link to post
Share on other sites

Então, o correto é seguir os passos que o nosso amigo @Glariston citou.

 

Faça o seguinte:

 

1- Entre no painel do DC e apague o MAC que está lá. Aguarde uns 5min, se necessário, e gere um MAC novo no próprio painel do DC.

2- Com a VM desligada, tente trocar o MAC no XEN Center para o valor gerado no painel do DC.

3- Ligue a VM e verifique se os arquivos de rede estão bem configurados, conforme o tutorial da OVH do link http://guides.ovh.com/BridgeClient

 

Veja:

 

/etc/sysconfig/network-scripts/ifcfg-eth0

 

DEVICE=eth0
BOOTPROTO=none
ONBOOT=yes
USERCTL=no
IPV6INIT=no
PEERDNS=yes
TYPE=Ethernet
NETMASK=255.255.255.255
IPADDR=IP.FAIL.OVER
GATEWAY=GATEWAY_VM
ARP=yes
HWADDR=MA:MAC:VI:RT:UEL:LE

 

/etc/sysconfig/network-scripts/route-eth0

 

GATEWAY_VM dev eth0
default via GATEWAY_VM dev eth0

 

/etc/resolv.conf

 

nameserver 213.186.33.99

nameserver 8.8.8.8

 

Dessa forma vai dar certo. Não esqueça de reiniciar a rede da VM após as alterações que forem necessárias.

 

Aguardo um retorno, pra saber se você conseguiu. Abraços!

Share this post


Link to post
Share on other sites

Não deu certo.

 

Dessa vez eu tentei criar outra VM, criando o MAC pelo painel do DC, adicionei na VM e configurei o IP e gateway, mascara tudo certinho mas a rede nem conecta.

 

Se alguém tiver em interesse em mexer com isso aqui me manda MP com preço que eu passo os dados.

Share this post


Link to post
Share on other sites

Não deu certo.

 

Dessa vez eu tentei criar outra VM, criando o MAC pelo painel do DC, adicionei na VM e configurei o IP e gateway, mascara tudo certinho mas a rede nem conecta.

 

Se alguém tiver em interesse em mexer com isso aqui me manda MP com preço que eu passo os dados.

 

Eu posso te ajudar, mas estou no trabalho agora. Daqui não tenho como acessar.

 

Qualquer coisa, me passa seu skype por MP. Lá pelas 17h eu chego em casa e tento dar uma olhadinha rápida pra você.

 

Abraços!

Share this post


Link to post
Share on other sites

Eu posso te ajudar, mas estou no trabalho agora. Daqui não tenho como acessar.

 

Qualquer coisa, me passa seu skype por MP. Lá pelas 17h eu chego em casa e tento dar uma olhadinha rápida pra você.

 

Abraços!

MP enviada, e obrigado desde já !

Share this post


Link to post
Share on other sites

Podem fechar o tópico, o LeandroTC me ajudou e não fez nem questão de cobrar nada por isso, mesmo eu querendo paga-lo pela ajuda.

Meus agradecimentos a ele.

Share this post


Link to post
Share on other sites

Podem fechar o tópico, o LeandroTC me ajudou e não fez nem questão de cobrar nada por isso, mesmo eu querendo paga-lo pela ajuda.

Meus agradecimentos a ele.

 

Muito obrigado pelo reconhecimento amigo! Precisando, pode contar comigo!

 

Abraços! :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×
×
  • Create New...