Jump to content

Conexão Através de Rede/Interface Privada


Fernando Rafs

Recommended Posts

Pessoal,

 

Estou criando este tópico apenas para deixar como registro, caso algum dos amigos possa ter o mesmo problema futuramente ao utilizar servidores com cPanel/CSF Firewall + Conexão através da Rede Privada do DC.

 

Estava configurando a minha rede privada junto ao meu DC para conectar meus servidores entre si, para o envio de backups entre eles.

 

Acontece que sempre que utiliza os meus ips privados através do comando abaixo os servidores não conseguiam se conectar entre eles. (Independente do comando, mas era este que precisa utilizar para testar a conexão)

 

# sftp -oPort=PORTADOSSH root@IPPRIVADO

 

Erro:

 

====

Connecting to IPPRIVADO...
ssh: connect to host IPPRIVADO port PORTADOSSH: Connection refused
Couldn't read packet: Connection reset by peer
===

 

Se alterava o IPPRIVADO para o IP Público do servidor funcionava corretamente, mas não era isto que eu queria, já que pela rede privada não é contabilizado/cobrado o tráfego.

 

Nem mesmo o suporte do DC conseguiu me informar o motivo deste problema e através de algumas pesquisas/estudos cheguei a conclusão que o problema estava na configuração de interface no CSF Firewall, que deve ficar da seguinte forma:

 

Esta é a minha configuração, alterar de acordo com a sua interface: (Configuração feita no CSF Firewall através da opção 'General ' Settings')

 

===

ETH_DEVICE = eth0

===

 

Agora vem o pulo do gato, é necessário informar também a sua interface privada conforme abaixo:

 

===

ETH_DEVICE_SKIP = eth1

===

 

Para funcionar a rede privada, exemplo 10.0.0.0/8 é necessário colocar a interface pública em ETH_DEVICE e a interface privada em ETH_DEVICE_SKIP. Em meu caso 'eth0' é a interface pública e 'eth1' a privada.

 

Esta configuração foi a única forma que funcionou sem problemas, pelo menos para mim.

 

Nota 1: Eu também adicionei o meu range privado na whilitist do CSF, bem como os IPs dos servidores.
Nota 2: Se houver algum erro de português no Post me desculpe, o fiz na maior correria para não esquecer.

 

Valeu.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

Do you agree with our terms?