Jump to content

Ip Do Usuário É O Mesmo Do Hostname


Leo Amarante

Recommended Posts

Olá galera,

 

Estou com um VPS com um problema estranho.

De um dia para o outro notei pelo Awstats de um dos domínios que as visitas cairam de média 200 para 1, achei que era problema neste sistema e verifiquei que o logaholic e a mesma coisa.

 

Então verifiquei em Últimos visitantes e constatei que todos os acessos à este site é mostrado o IP compartilhado ou o hostname do próprio servidor como sendo o IP do usuário.

 

Já fiz diversos procedimentos, reiniciei o apache, reinstalei o nginx e nada. Nem mesmo o gerenciamento que a empresa oferece descobriu o problema.

 

Alguém já passou por isso ou pode me dizer como resolver isso?

Link to comment
Share on other sites

Olá galera,

 

Estou com um VPS com um problema estranho.

De um dia para o outro notei pelo Awstats de um dos domínios que as visitas cairam de média 200 para 1, achei que era problema neste sistema e verifiquei que o logaholic e a mesma coisa.

 

Então verifiquei em Últimos visitantes e constatei que todos os acessos à este site é mostrado o IP compartilhado ou o hostname do próprio servidor como sendo o IP do usuário.

 

Já fiz diversos procedimentos, reiniciei o apache, reinstalei o nginx e nada. Nem mesmo o gerenciamento que a empresa oferece descobriu o problema.

 

Alguém já passou por isso ou pode me dizer como resolver isso?

Isso acontece quando o servidor não consegue resolver o IP, provavelmente voce tem o nginx instalado e ele está causando esse problema, tente atualizar o nginx ou tente instalar o mod_reverseproxy (https://github.com/Prajithp/mod_reverseproxy).

Obs: Não cheguei a testar o mod_reverseproxy

Link to comment
Share on other sites

Por eliminação: já desativou o NGINX (seguido do reinicio do Http server) pra conferir?

Olá Eltern,

 

Sim, já realizei esse procedimento.

Descobrimos que é algo no Ngnix mesmo, quando desativo ele volta ao normal.

Estamos reinstalando e atualizando neste momento.

Link to comment
Share on other sites

Isso acontece quando o servidor não consegue resolver o IP, provavelmente voce tem o nginx instalado e ele está causando esse problema, tente atualizar o nginx ou tente instalar o mod_reverseproxy (https://github.com/Prajithp/mod_reverseproxy).

Obs: Não cheguei a testar o mod_reverseproxy

O estranho é que só acontece com um dos domínio  entre os 4 ativos. Estamos atualizando o nginx e vamos ver se resolve.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

Do you agree with our terms?