Clicky

Jump to content
  • Sign Up
Sign in to follow this  
RevendaHost

Cpnel com problemas no processo spamd

Recommended Posts

Boa noite.

Estou a 2 horas esperando resposta do suporte do cpanel, por isso resolvi postar aqui caso alguém tenha noção do problema e me dê um help.

Hoje criei um vps para um cliente com Centos 7.3 instalei o cpanel e descobri que o processo spamd estava off. Tentei subir manualmente(via ssh) e ele da uma erro, "nenhuma regra encontrada" ou algo assim e pede para rodar o sa-update, mas o retorno do mesmo informa que o mirror requisitado não foi encontrado. Resolvi formatar o vps e com Centos 6.9, deu o mesmo problema, então resolvi criar um outro vps com Centos 6.9, e o problema permanece. Processo spamd (spamassassin) não inicia nem na bala! Outros vps cpanel no mesmo node estão com spamd normal, porém são cpanel 66.

Alguém ja passou por isso?  Detalhe: O Cpanel é 68, e por acaso estou vendo alguns bugs nele, em todos os servidores que tenho e que estão sob minha gerência.

 

Tentando reiniciar pelo whm dão os erros:

Starting spamd: [2017-11-13 21:14:47 -0200] warn [restartsrv_spamd] The 'spamd' service's PID file '/var/run/spamd.pid' did not appear after 10 seconds.
warn [restartsrv_spamd] The 'spamd' service's PID file '/var/run/spamd.pid' did not appear after 10 seconds.
[2017-11-13 21:14:52 -0200] info [restartsrv_spamd] The service 'spamd' failed to restart. Trying '/usr/local/cpanel/3rdparty/perl/524/bin/spamd'.
[2017-11-13 21:14:53 -0200] warn [restartsrv_spamd] The system encountered an error while starting the “spamd” service with the command “/usr/local/cpanel/3rdparty/perl/524/bin/spamd --daemonize --max-spare=1 --max-children=3 --allowed-ips=127.0.0.1,::1 --pidfile=/var/run/spamd.pid”: The subprocess reported error number 255 when it ended. at /usr/local/cpanel/Cpanel/ServiceManager/Base.pm line 1358.
Cpanel::ServiceManager::Base::warn(Cpanel::ServiceManager::Services::Spamd=HASH(0x1c4a928), "The system encountered an error while starting the \x{e2}\x{80}\x{9c}spamd\x{e2}\x{80}"...) called at /usr/local/cpanel/Cpanel/ServiceManager/Manager/Initd.pm line 103
Cpanel::ServiceManager::Manager::Initd::start(Cpanel::ServiceManager::Manager::Initd=HASH(0x1d1d3a0), Cpanel::ServiceManager::Services::Spamd=HASH(0x1c4a928)) called at /usr/local/cpanel/Cpanel/ServiceManager/Base.pm line 828
Cpanel::ServiceManager::Base::start(Cpanel::ServiceManager::Services::Spamd=HASH(0x1c4a928)) called at /usr/local/cpanel/Cpanel/ServiceManager/Services/Spamd.pm line 212
Cpanel::ServiceManager::Services::Spamd::start(Cpanel::ServiceManager::Services::Spamd=HASH(0x1c4a928)) called at /usr/local/cpanel/Cpanel/ServiceManager/Base.pm line 703
Cpanel::ServiceManager::Base::restart(Cpanel::ServiceManager::Services::Spamd=HASH(0x1c4a928), "graceful", undef) called at /usr/local/cpanel/Cpanel/ServiceManager/Base.pm line 537
Cpanel::ServiceManager::Base::run_from_argv(Cpanel::ServiceManager::Services::Spamd=HASH(0x1c4a928), "--verbose", "--no-verbose") called at bin/restartsrv_base.pl line 74
main::__ANON__() called at /usr/local/cpanel/3rdparty/perl/524/lib64/perl5/cpanel_lib/Try/Tiny.pm line 99
eval {...} called at /usr/local/cpanel/3rdparty/perl/524/lib64/perl5/cpanel_lib/Try/Tiny.pm line 90
Try::Tiny::try(CODE(0xbdf420), Try::Tiny::Catch=REF(0xbdda88)) called at bin/restartsrv_base.pl line 109
warn [restartsrv_spamd] The system encountered an error while starting the “spamd” service with the command “/usr/local/cpanel/3rdparty/perl/524/bin/spamd --daemonize --max-spare=1 --max-children=3 --allowed-ips=127.0.0.1,::1 --pidfile=/var/run/spamd.pid”: The subprocess reported error number 255 when it ended.
(XID 2m68f9) Falha ao iniciar o serviço “spamd”.
The “spamd” service failed to start.
[FAILED]
 


Gerenciamento e otimização de servidores: Centos, Debian, Ubuntu, Cpanel e VestaCP.
Cloud otimizado e otimização para: Wordpress e Magento.
Virtualização: Implementação e gerenciamento Virtualizor, Proxmox, Openstack e VMware.

Share this post


Link to post
Share on other sites

A quem possa interessar, o suporte me respondeu e pela infomação parece que o problema é no servidor de atualização das regras do spamassassin.  Conforme podem ver na mensagem abaixo o servidor está indisponivel quando tenta baixar o arquivo http://sa-update.secnap.net/1799552.tar.gz. Tentei baixar ele no meu PC e dá erro 404

404 Not Found


nginx/1.6.2

 

 

Resposta do suporte:

 

Hello again! Thank you for your message.

This appears to be an upstream issue with the SpamAssassin update rules:

6320 sendto(3, "GET /1799552.tar.gz HTTP/1.1\r\nUser-Agent: curl/7.19.7 (x86_64-redhat-linux-gnu) libcurl/7.19.7 NSS/3.27.1 zlib/1.2.3 libidn/1.18 libssh2/1.4.2\r\nHost: sa-update.secnap.net\r\nAccept: */*\r\n\r\n", 187, MSG_NOSIGNAL, NULL, 0) = 187
6320 poll([{fd=3, events=POLLIN|POLLPRI|POLLRDNORM|POLLRDBAND}], 1, 0) = 0 (Timeout)
6320 poll([{fd=3, events=POLLIN|POLLPRI|POLLRDNORM|POLLRDBAND}], 1, 0) = 0 (Timeout)
6320 clock_gettime(CLOCK_MONOTONIC, {7049, 392415698}) = 0
6320 clock_gettime(CLOCK_MONOTONIC, {7049, 392432591}) = 0
6320 clock_gettime(CLOCK_MONOTONIC, {7049, 392450407}) = 0
6320 poll([{fd=3, events=POLLIN|POLLPRI|POLLRDNORM|POLLRDBAND}], 1, 1000) = 1 ([{fd=3, revents=POLLIN|POLLRDNORM}])
6320 poll([{fd=3, events=POLLIN|POLLPRI|POLLRDNORM|POLLRDBAND}], 1, 0) = 1 ([{fd=3, revents=POLLIN|POLLRDNORM}])
6320 recvfrom(3, "HTTP/1.1 404 Not Found\r\nServer: nginx/1.6.2\r\nDate: Mon, 13 Nov 2017 23:39:15 GMT\r\nContent-Type: text/html\r\nContent-Length: 168\r\nConnection: keep-alive\r\nKeep-Alive: timeout=20\r\n\r\n<html>\r\n<head><title>404 Not Found</title></head>\r\n<body bgcolor=\"white\">\r\n<center><h1>404 Not Found</h1></center>\r\n<hr><center>nginx/1.6.2</center>\r\n</body>\r\n</html>\r\n", 16384, 0, NULL, NULL) = 346

[21:40:16 srv root@9001010 ~]cPs# wget sa-update.secnap.net/1799552.tar.gz
--2017-11-13 21:40:28-- http://sa-update.secnap.net/1799552.tar.gz
Resolving sa-update.secnap.net... 204.89.241.6
Connecting to sa-update.secnap.net|204.89.241.6|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2017-11-13 21:40:28 ERROR 404: Not Found.

I am going to attempt to reproduce this issue on a test server. I will update you again shortly with my results.

Sincerely,
Shoshana


Gerenciamento e otimização de servidores: Centos, Debian, Ubuntu, Cpanel e VestaCP.
Cloud otimizado e otimização para: Wordpress e Magento.
Virtualização: Implementação e gerenciamento Virtualizor, Proxmox, Openstack e VMware.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.




×
×
  • Create New...