Clicky

Ir para conteúdo
Antonio Marques

Erro no ssl

Posts Recomendados

Estou a dês de o inicio do ano com grande baixa nas vendas e somente agora vi que meu site não tem o SSL então isso baixou muito minhas vendas,  agora venho tentando colocar um certificado ssl gratis do site https://www.sslforfree.com assim como mostra esse video: https://www.youtube.com/watch?v=aNLpwfukWhc o que não deu certo foi o seguinte: O cadeado do meu site fica em amarelo no mozila quando eu digito o link https://programadivulgarsite.com.br ja no google chrome na hora que carrega fica verde e 1 segundo depois aparece cinza como inseguro, ja no explore não aparece nada mais em todos eles, quando eu clico em um botão registrar ai do meu site ele vai para pagina de registro e o cadeado fica verde, Por qual motivo não fica verde no site principal https://programadivulgarsite.com.br ? citando também que quando digito www.programadivulgarsite.com.br o site não fica verde, assim tive que ir no htaccess e fzer uma função para redirecionar o site para http://programadivulgarsite.com.br porem isso parece não esta funcionando muito bem. Alguem poderia por por gentileza me dar uma dica para solucionar isso?

abaixo estão as imagens 1 usando o Navegador Chrome onde esta dando o erro já limpei cookies e tudo mais ate os links de imagens que erram http já mudei para https etc.. a imagem 2 onde uso o mozila e aparece em amarelo e a imagem 3 quando clico em cadastrar no site ai sim fica tudo ok na pagina de cadastro. 

1.png

2.png

3.png

Compartilhar este post


Link para o post
Compartilhar em outros sites

Primeiro passo:

- Acesse o seu site normalmente, como um visitante

- Pressione ctrl+u, para ver o código fonte do site

- Com o código aberto, agora pressione ctrl+f, para fazer uma busca. Digite na busca: "http://".

- Agora a parte difícil e que só você ou seu webmaster pode resolver. Tudo o que estiver como "http://", dever ser alterado para "https://", como fazer isso? Somente no código HTML do seu site.

Obs: se você usa WordPress, faça o seguinte:

Acesse o seu painel >> Configurações >> Geral. Altere "Endereço do WordPress (URL)" e "Endereço do site (URL)" para a sua URL começando com "https://".

Com isso, seu site vai carregar corretamente com o certificado funcionando e somente assim, tudo deve ser carregado em https e não em http.

Acessando o seu site agora, vejo ele carregando normalmente com o SSL ativado, mas só se eu digitar o https://, se acessar direto ele não está redirecionando.

Use: 

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

No seu .htaccess se for servidor Linux. Ou para servidores Windows:

<configuration>
<system.webServer>
<rewrite>
    <rules>
	<rule name="HTTP to HTTPS redirect" stopProcessing="true"> 
	<match url="(.*)" /> 
	<conditions> 
		<add input="{HTTPS}" pattern="off" ignoreCase="true" />
	</conditions> 
	<action type="Redirect" redirectType="Permanent" url="https://{HTTP_HOST}/{R:1}" />
</rule>   
    </rules>
</rewrite>
</system.webServer>
</configuration>

No arquivo web.config.

Compartilhar este post


Link para o post
Compartilhar em outros sites

@thiagosantos Muitissimo obrigado cara, sou Programador tenho um bom conhecimento Agradeço muito a sua resposta valeu mesmo, eu já tinha trocado os links e tudo mais nada dava certo, agora nesse exato momento consegui descobrir que o SSL não suporta Iframe ou algo do tipo, pois foi só eu remover um iframe do site e tudo ficou lindo, eu tinha um iframe para capturar o email dos clientes que vinham a meu site tipo newsletter, agora estou sem isso, tem alguma sugestão referente a como posso capturar esses emails ? 

Voltando a questão do SSL quanto a digitar www.programadivulgarsite.com.br sempre da erro também não sei porque mais acho que devido ao www ai fui no .htaccess e inclui uma função para sempre que o usuario digitar www ele vai ser redirecionado para o link sem o www. e com o https

Para redirecionar eu estava usando iss:

# Option 1a: rewrite www.example.com &#8594; example.com

<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTPS} !=on
    RewriteCond %{HTTP_HOST} ^www\.(.+)$ [NC]
    RewriteRule ^ http://%1%{REQUEST_URI} [R=301,L]
</IfModule>

# Option 1b: rewrite https://www.example.com &#8594; https://example.com

<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTPS} on
    RewriteCond %{HTTP_HOST} ^www\.(.+)$ [NC]
    RewriteRule ^ https://%1%{REQUEST_URI} [R=301,L]
</IfModule>

 

ate tentei usar o seu mais mesmo assim quando se digita https://www.programadivulgarsite.com.br ele não redireciona e da erro de conexão não segura, sab como resolver, sou leigo em htaccess consegui isso ai online.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Participe da conversa

Você pode postar agora e se cadastrar mais tarde. Se você tem uma conta, faça o login para postar com sua conta.

Visitante
Responder

×   Você colou conteúdo com formatação.   Remover formatação

  Apenas 75 emojis são permitidos.

×   Seu link foi automaticamente incorporado.   Mostrar como link

×   Seu conteúdo anterior foi restaurado.   Limpar o editor

×   Não é possível colar imagens diretamente. Carregar ou inserir imagens do URL.


  • Quem Está Navegando   0 membros estão online

    Nenhum usuário registrado visualizando esta página.



O Portal do Host

Dicas para sua empresa de hospedagem. Artigos, notícias, tutoriais e os aspectos da indústria de hospedagem.

Limestone Networks

A LSN tem sido parceira e patrocinadora do PDH, fornecendo uma plataforma segura e confiável.

Cloud - Servidores decicados - Co-location
×
×
  • Criar Novo...