Clicky

Ir para conteúdo
Arthurcvm

Invalid csrf protection token - vestacp

Posts Recomendados

Estou recebendo esse erro de invalidez logo após uma página de erro 500 ser recarregada durante a execução do módulo para o VestaCP, já fiz o seguinte no configuration.php (como vi aqui no fórum):

<?php
session_name("WHMCS");

Mas não resolveu.

Vi que poderia ser um problema de sessão, se alguém puder me ajudar, estou com um CentOS 7, PHP 7.0.15, PHP-FPM + Nginx, Varnish Cache.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 15/02/2017 em 17:05, LucasOliveira disse:

E qual o erro no log do php?

Perdão Lucas, mas eu não lembro qual o nome do arquivo de Log do PHP, pode me ajudar? Acho que devo ter recorrido poucas vezes a esse arquivo e acabei não fixando.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Não consigo encontrar nenhum retorno de erro, no meu caso os log de erros ficam na pasta do nginx, mas só tem log do http (GET e POST), nada do PHP, ainda mexi no php.ini, mas não deu em nada.

Meu problema se assemelha a esse: 

Detalhe: meu WHMCS está na versão 7.0.1.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 17/02/2017 em 14:40, LucasOliveira disse:

Olá,

Da uma olhadinha, na própria documentação tem os endereços e muito mais.

https://vestacp.com/docs/#config-log-location-rhel-centos

https://vestacp.com/docs/#config-log-location-debian-ubuntu

Tentei aumentar a memória do PHP no php.ini, mas nada feito.

Finalmente achei um log que faça sentido, nos logs do Nginx na pasta de domínios havia um error.log específico pra ele, a linha relacionada ao erro do WHMCS é a seguinte:

2017/02/21 09:45:52 [error] 17896#17896: *1 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: 5.189.161.116, server: youster.com.br, request: "POST /central/admin/orders.php?action=view&id=2&activate=true HTTP/1.1", upstream: "fastcgi://127.0.0.1:9003", host: "youster.com.br", referrer: "http://youster.com.br/central/admin/orders.php?action=view&id=2"

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Provavelmente está usando php-fpm. Disse que aumentou o php.

Tente dar um restar nele. e acompanhe o log pelo horario.

service php5-fpm restart

Veja os logs do php5-fpm tambem. E veja se está usando APCU cache.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Já tinha resetado o PHP-FPM, refiz por desencargo de consciência, daí tentei novamente e obtive o mesmo erro, esse é o log do PHP-FPM (creio eu que nada muito relevante):

[21-Feb-2017 21:14:27] NOTICE: Terminating ...
[21-Feb-2017 21:14:27] NOTICE: exiting, bye-bye!
[21-Feb-2017 21:14:27] NOTICE: fpm is running, pid 15600
[21-Feb-2017 21:14:27] NOTICE: ready to handle connections
[21-Feb-2017 21:14:27] NOTICE: systemd monitor interval set to 10000ms

Olhei no php.info e não achei nada sobre o OpCache ou APCU cache, a única coisa foi:


Module Authors
Module	Authors

Opcache	Andi Gutmans, Zeev Suraski, Stanislav Malyshev, Dmitry Stogov, Xinchen Hui

no php.info, mas nada no sistema.

Compartilhar este post


Link para o post
Compartilhar em outros sites

@LucasOliveira Continuo tendo o error 104 no log de erro do Nginx:

2017/02/23 12:04:31 [error] 25097#25097: *1 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: 5.189.161.116, server: youster.com.br, request: "POST /central/admin/orders.php?action=view&id=6&activate=true HTTP/1.1", upstream: "fastcgi://127.0.0.1:9003", host: "youster.com.br", referrer: "http://youster.com.br/central/admin/orders.php?action=view&id=6"

Encontrei algumas fontes que falam do FastCGI, o que acha?

https://talk.plesk.com/threads/error-502-bad-gateway-nginx-104-connection-reset-by-peer.333341/

O interessante é que é só na criação da nova conta, quando a conta é existente ele retorna um erro no próprio whmcs que a conta já existe. E a conta é criada, apesar dos erros, mas é como se o servidor não retornasse pra o WHMCS.

Compartilhar este post


Link para o post
Compartilhar em outros sites

É que provavelmente ele envia um reset ao servidor web. E como no seu caso é nginx tem de ir adaptando, em vista que praticamente todo sistema é pensado em apache.

Recomendo dar uma pesquisada ai para rodar whmcs em nginx, e ver quais as diferenças a serem implementadas.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Participe da conversa

Você pode postar agora e se cadastrar mais tarde. Se você tem uma conta, faça o login para postar com sua conta.

Visitante
Responder

×   Você colou conteúdo com formatação.   Remover formatação

  Apenas 75 emojis são permitidos.

×   Seu link foi automaticamente incorporado.   Mostrar como link

×   Seu conteúdo anterior foi restaurado.   Limpar o editor

×   Não é possível colar imagens diretamente. Carregar ou inserir imagens do URL.


  • Quem Está Navegando   0 membros estão online

    Nenhum usuário registrado visualizando esta página.



O Portal do Host

Dicas para sua empresa de hospedagem. Artigos, notícias, tutoriais e os aspectos da indústria de hospedagem.

Limestone Networks

A LSN tem sido parceira e patrocinadora do PDH, fornecendo uma plataforma segura e confiável.

Cloud - Servidores decicados - Co-location
×
×
  • Criar Novo...