Clicky

Ir para conteúdo

edvan

Bug "Recent News" WHMCS v602

Posts Recomendados

Hoje um cliente entrou em contato informando que estava ocorrendo um bug no seu WHMCS e perguntou se eu sabia como resolver.

Esse problema também está ocorrendo com meu WHMCS, segue problema:

No painel do cliente (após efetuar login) caso você utilize o template "Six" haverá um "box" chamado "Notícias Recentes" conforme imagem abaixo:

edvancombr_2015_09_15.jpg

É possível verificar que o endereço "financeiro" está sendo duplicado e com isso o cliente é redirecionado para página 404... entrei em contato com a WHMCS.com (a poucos minutos atrás) e ainda não obtive respostas (óbvio).

Tentei pesquisar na documentação, fórum e não consegui encontrar uma forma de desabilitar ou corrigir.

Analisei a estrutura do arquivo clientareahome.tpl e tive uma simples ideia, ocultar o "box" e meu problema estaria "resolvido" até o fabricante corrigir o bug.

Abra o arquivo e localize a linha 78 http://pastebin.com/Uf6KhKSN

Substitua por http://pastebin.com/X3tv9bS6

Pronto, agora só serão listados os 2 "box" padrão.

edvancombr_2015_09_15.jpg

Se desejar ocultar outro box, é simples... visualize o código HTML e procure pelo nome.

edvancombr_2015_09_15.jpg

Exemplo http://pastebin.com/h4KeazAa

Quando a WHMCS.com resolver o problema irei avisar!

Editado por edvan
  • Gostei! 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Eu utilizo Subdomínio e não tenho esse bug, tem algo haver? rsrs
Cliquei na notícia que eu fiz e abre normal.

A notícia dentro do painel do cliente (cliente logado) ou na página inicial? Enviado do meu iPhone usando Tapatalk

Compartilhar este post


Link para o post
Compartilhar em outros sites

@edvan

Tanto na página principal (http://noc.meudominio.com.br), tanto na (http://noc.meudominio.com.br/clientarea.php) estão normais. Não fiz nenhuma alteração de template, também uso o novo template da WHMCS (Six).

Verifiquei no outro WHMCS que possuo alocado em um sub-domínio e o erro não ocorre kkk

Fomos contemplados! rs

Compartilhar este post


Link para o post
Compartilhar em outros sites

Recebi uma resposta da WHMCS.com e confirmaram o bug.

Infelizmente não tem previsão de resolução... 

Hi Edvan Sampaio,

Thanks for contacting WHMCS. I've been able to replicate this issue on my end as well. As such I have opened case #CORE-9073 with our developers in order to have this reviewed for future releases. Unfortunately, I cannot provide an estimated time for completion for this. However, once we resolve cases and push features they are available at our change log, here:

http://changelog.whmcs.com/

I apologize for the inconvenience, and appreciate your patience as we work to resolve this.

In the meantime you can switch off the KB SEO Friendly URLs option from the Setup > General Settings > Support page and you should be able to use the links without issues.

Thanks again for taking the time to report your findings. We welcome bug reports at http://bugs.whmcs.com/

Best Regards,
Joshua Stanford
Technical Analyst I
WHMCS

Foi sugerido que desabilitasse as urls amigáveis removendo o .htaccess ou seguindo o procedimento abaixo:

edvancombr_2015_09_15.jpg

Particularmente eu prefiro a remoção desse painel, na documentação oficial não cita como remover... acabei de perguntar.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Participe da conversa

Você pode postar agora e se cadastrar mais tarde. Se você tem uma conta, faça o login para postar com sua conta.

Visitante
Responder

×   Você colou conteúdo com formatação.   Remover formatação

  Apenas 75 emojis são permitidos.

×   Seu link foi automaticamente incorporado.   Mostrar como link

×   Seu conteúdo anterior foi restaurado.   Limpar o editor

×   Não é possível colar imagens diretamente. Carregar ou inserir imagens do URL.


  • Quem Está Navegando   0 membros estão online

    Nenhum usuário registrado visualizando esta página.



×
×
  • Criar Novo...