Clicky

Hospedado por Limestone Networks

Jump to content
  • Sign Up

Sign in to follow this  
rodrigo286

IP Publico no KVM

Recommended Posts

Pessoal estou com 5 IPs justificados em um dedicado.

Instalei QEMU/KVM, já está rodando tudo certinho, porêm tento criar um VLAN no QEMU para distruibuir os IPs para as VM's com o DHCP, está da seguinte forma:

Servidor

eth0 - xxx.xxx.xxx.11

Preciso que fique assim:

Servidor

Interface eth0 - xxx.xxx.xxx.114

QEMU/KVM

Interface rede - xxx.xxx.xxx.115

Interface rede0 - xxx.xxx.xxx.116

Interface rede1 - xxx.xxx.xxx.117

Interface rede2 - xxx.xxx.xxx.118

Mas ao tentar fazer essa config eu recebo o erro que a eth0 já usa essa network, eu consigo adicionar conexões vinculadas pelo linux como eth0:0, eth0:1 com esses IPs mas preciso atrelar os mesmos as VM's para que os clientes consiga acessar as mesmas e ter seu IP FIXO.

Alguém tem ideia de como posso fazer isto?

Abraço.

 

Share this post


Link to post
Share on other sites

O Lucas ai sabe do meu sofrimento, também andei apanhando esses dias. E também era com o KVM/LibVirt. Você deve está tentando fazer NAT?

Mesma faixa, ele vai dá este erro mesmo. Eu recomendo alterar a netmask da interface eth0. Alterando-a você vai conseguir utilizar a netmask fornecida pelo DC na vlan.

Share this post


Link to post
Share on other sites

Oi, desculpe pera demora, eu alterei a netmask e alterei o final de 248 para 0 e consegui add a rede virtual dentro do KVM/LibVirt como NAT para a eth0, a VM recebe um IP pelo DHCP, mas mesmo assim pingando esse IP ele não responde, existe outro modo de fazer isso?

Sobre o que o Lucas disse em colocar como bridge, você está dizendo fazer bridge com a eth0 e colocar o IP na VM manualmente?

 

Abraço.

#EDIT

Eu coloquei a network em bridge para o eth0 e forcei o IP e funcionou.

Obrigado.

Edited by rodrigo286

Share this post


Link to post
Share on other sites

Pessoal, é possível deixar um clock speed custom?

Por exemplo se eu tiver um dedicado bi-processado com dois xeon quad core de 4.0GHz e forçar nas VM's que cada core seja de 2.0GHz e não 4.0GHz é possível?

Procurei bem tanto dentro do Virtualizor quanto no google e não encontrei nada.

Obrigado.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×
×
  • Create New...