Clicky

Jump to content
  • Sign Up
Sign in to follow this  
Daniel Lemes

Edição do sshd_config sem shell

Recommended Posts

Olá,

Há meses atrás desativei o acesso root ao VPS que uso (Centos), por questão de segurança, e passei a usar chaves pública e privada para acesso via Putty. Acontece que perdi a chave privada, e claro, passou a não conectar mais.

 

Tentei criar outra chave, tanto usando o puttygen quanto a ferramenta do painel do WHM, mas sempre que tento acesso, a resposta é "Server refused our key", mesmo dando autorização e tendo o user no "Manage Wheel Group Users".

 

Parece que o único jeito de corrigir a confusão toda seria reabilitar o acesso root, mas como fazer isso se pelo WHM não tem como, que eu saiba? Tenho o KVM, mas honestamente não estou sabendo usar, fica só rodando um log do firewall, não sei usar comandos nele.

Alguém pode ajudar? Obrigado.

Share this post


Link to post
Share on other sites
Guest dessideriojr

Desative o acesso via key e ative acesso via root, no WHM tem algo como ajuste de SSH, ajuste de autorização, algo desse tipo.

Share this post


Link to post
Share on other sites

Mudei o "PermitRootLogin" para yes, mas não adiantou, dá "Access denied", tanto para o user quanto para root...

Aqui está em português, é a opção "Ajuste de autorização de senha SSH", mas também está em enabled.

Edit: reiniciei o servidor depois das alterações.

Share this post


Link to post
Share on other sites

--

 

Daniel,

 

Poderá tentar conectar ISO/LiveCD ou qualquer CD de rescue no servidor, e montar a partição root, após montada, poderá usar chroot e remover as Keys / Editar o SSHD.

 

@Edit,

 

Poderá também entrar no /etc/ssh (ou sshd) e remover as chaves públicas e privadas.

 

Deverá ter linhas assim:

 

 
# HostKey for protocol version 1
#HostKey /etc/ssh/ssh_host_key
# HostKeys for protocol version 2
#HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_dsa_key
 
 
#RSAAuthentication yes
#PubkeyAuthentication yes
#AuthorizedKeysFile     .ssh/authorized_keys
#AuthorizedKeysCommand none
#AuthorizedKeysCommandRunAs nobody
 
Tenta aí :)
 
 
Então, comente elas 

Huge Networks - Especialistas em DDoS Mitigation - AS264409
● Infraestrutura DDoS Mitigation 280+ Gbps. DDoS Mitigation remoto / local. Proteção DDoS via Proxy, GRE ou cross connect.

Share this post


Link to post
Share on other sites
Guest dessideriojr

Se você tem KVM, quebra a senha root via GRUB.

 

No google tem tutorias.

Share this post


Link to post
Share on other sites

Consegui editar o sshd_config pelo ConfigServer Explorer (instalei pelo KVM, que continua rodando uns logs que atrapalham muito). Realmente tem essas linhas que o Erick mostrou, mas já estão todas comentadas ou "descomentadas" adequadamente, eu acho:

 

#LoginGraceTime 2m
PermitRootLogin yes
#StrictModes yes
#MaxAuthTries 6
 
#RSAAuthentication yes
#PubkeyAuthentication yes
#AuthorizedKeysFile .ssh/authorized_keys

 

# To disable tunneled clear text passwords, change to no here!
#PasswordAuthentication yes
#PermitEmptyPasswords no
PasswordAuthentication yes

Share this post


Link to post
Share on other sites

Não tem exatamente a ver com o tópico, mas pra esclarecer, resolvi o problema com o AllowUsers, adicionando root a ele. Pensei que ao setar PermitRootLogin em yes já estava implícita a autorização ao root, mas não estava...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.




×
×
  • Create New...