Jump to content

Problema Com Php


Recommended Posts

Olá,
Tenho um programa em php 5.1.
Instalei o Cpanel/WHM no meu servidor com php 5.3, mas tento rodar o programa e gera erro.
 
Tentei usar o .htaccess com o seguinte conteudo:
 
Primeiro:
 
AddType application/x-httpd-php .php
 
E depois:
 
AddType application/x-httpd-php .php
AddHandler x-httpd-php .php
 
Mas ele daí, em vez do erro, me da a opção de fazer download do arquivo php.
 
No meu servidor shared que usava antes, com o .htaccess funcionava normalmente.
 
Se alguém tiver uma dica agradeço.
 
Obrigado.
Link to comment
Share on other sites

Não sei se funciona mas, não custa tentar.

 

AddType application/x-httpd-php53 .php

 

Acontece o mesmo problema, ele faz o download do arquivo php. Se deixo sem o .htaccess, ele até funciona, mas da erro na hora de enviar e-mail pelo sistema em php (por causa da versão).

 

Na verdade, eu estava usando o comando:

 

AddType application/x-httpd-php51 php51 .php
 
No .htaccess no meu antigo servidor shared.
 
Tem algo relacionado com suphp algo assim?
Tentei pesquisar bastante mas não achei ninguém com o mesmo problema.
 
Abraços.
Link to comment
Share on other sites

É complicado porque sua aplicação foi desenvolvida para php 5.1, mesmo que funcione em outra versão, nunca ela irá funcionar tão bem quanto funcionava na versão para qual ela foi desenvolvida.

 

Recomendo que você vá no seu WHM e em Easy Apache, escolha a versão do php adequada.

 

Se você julgar necessário ter um servidor 5.3 e ter a aplicação, você poderia fazer uma gambiarra mas, iria gastar um pouco mais para isso.

 

Você poderia continuar com seu servidor php 5.3 e contratar outro servidor bem barato mesmo, com php 5.1. Nele você iria hospedar o seu formulário, e para chamar o mesmo em seu site, você poderia utilizar frames. No caso não precisa de um domínio no servidor do formulário, pode ser pelo ip mesmo, visto que, ninguém vai ver ou ter que digitar o ip, já que está em frames.

Link to comment
Share on other sites

Clayderson, obrigado amigo, consegui resolver meu problema com ajuda do suporte do Cpanel (por sinal, muito bom mesmo).

 

No .htaccess, foi colocado:

 

AddType application/x-httpd-php5 .php5 .php4 .php .php3 .php2 .phtml
AddType application/x-httpd-php51 .php5 .php4 .php .php3 .php2 .phtml
AddHandler application/x-httpd-php51 .php
AddHandler application/x-httpd-php5 .php
 
E descobri que meu script estava com problema no eAccelerator do php, então coloquei no php.ini:
 
php_flag eaccelerator.enable 0
php_flag eaccelerator.optimizer 0
date.timezone = America/Sao_Paulo
 
E finalmente está 100%.
 
Se algum um dia tiver o mesmo problema, está aí a solução.
 
Abraços.
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...