Clicky

Ir para conteúdo

ricardolucas

Membro Bronze
  • Total de itens

    40
  • Registro em

  • Última visita

Informações pessoais

  • Nome
    Ricardo Lucas da Silva

Meios de contato

Últimos Visitantes

683 visualizações
  1. Eu estou tendo o mesmo problema. IP em zero lista e nota 10 no mail-tester. Mesmo assim o email vai direto pro SPAM do gmail. Também não sei como proceder. Se alguém tiver uma dica pra onde ir. Obrigado.
  2. Vai com o @rubensk e coloca uma maquininha simples pra ser DNS. Se for cpanel vai ter um servidor principal com o cPanel em si + um servidor simples com DNSOnly.
  3. Oi @RevendaHost obrigado pela ajuda.. vou testar. Uma dúvida besta.. eu estou pegando o parâmetro pela url usando ?pg=home Devo mudar o location, certo ? location / { try_files $uri $uri/ /?pg=$args; }
  4. @marcussombra pensei nisso também.. tenho um servidor vesta desta maneira. Mas como a solução usando as regras do nginx pareciam tranquilas, eu decidi usar apenas ele como servidor web, proxy reverso e para balanceamento de carga no futuro. Mas com essa dificuldade toda realmente é uma opção que vou considerar. Ainda vou tentar mais um pouco.. não posso deixar a maquina vencer assim tão fácil heheh. Obrigado.
  5. Tentei alguns desses, todos sem sucesso. No geral eles mandam usar isto: location / { if (!-e $request_filename){ rewrite ^(.*)$ /?pg=$1; } } Ou isto: location / { if ($rule_0 = "21"){ rewrite ^/(.*)$ /?pg=$1; } } Nenhum funcionou. Já tentei dentro e fora do location.. nenhum dá resultado algum.
  6. Oi @Rocha Neto obrigado por responder. Inserir dentro de server { } ?
  7. Olá pessoal, tudo bem ? Estou migrando um site para outro servidor, agora com Nginx+PHP-FPM+MariaDB. Entre trancos e barrancos consegui colocar pra rodar. O problema é que eu tinha regras no .htaccess que não consigo portar para o Nginx. Tentei diversas coisas sem sucesso. Minha URL original é www.meusite.com.br?pg=servicos e usando o htaccess ela fica www.meusite.com.br/servicos Pego essa parametro "servicos" para usar na minha consulta. No apache vai de boa com este código: RewriteEngine On RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule ^(.*)$ ?pg=$1 No nginx não consigo. Estou testando agora com: server { listen 80 default_server; listen [::]:80 default_server; root /var/www/html; index index.html index.htm index.nginx-debian.html; server_name meusite.com.br www.meusite.com.br; location / { try_files $uri $uri/ /?pg=$args; } location ~ \.php$ { include snippets/fastcgi-php.conf; fastcgi_pass unix:/var/run/php/php7.2-fpm.sock; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; include fastcgi_params; } Se alguém puder dar uma dica... Muito obrigado pessoal.
  8. Ainda nada. Zerei o cache e já verifiquei em todos os DNSs checkers que pude. O servidor responde ao novo ip.. creio que possa ser algo interno . Verifiquei no httpd e o novo ip está lá. 🤔 até o rebuildhttpdconf usei (já no desespero)
  9. Quando dou um nslookup ele mostra 2 IPs 😶 Ricardos-Air:~ ricardo$ nslookup meusite.com.br Non-authoritative answer: Name: meusite.com.br Address: 155.111.111.111 Name: meusite.com.br Address: 175.111.111.222
  10. Olá Jefferson. Adicionei um novo IP no servidor e o inclui no WHM. Toquei o IP do domínio e o cpanel fez o resto. Estou pingando e já esta aparecendo o novo IP. Mas o site aparece esta mensagem: No whatsmydns.net já aparece o novo IP. Exite algo mais que devo fazer ? Somente aguardar mais o DNS mesmo ? Valeu
  11. Obrigado @Maik Vou considerar isto. Dentro do cpanel o usuário pode criam uma chave de acesso, isso dá acesso total também ? Obrigado @redenflu Vou fazer isto sem dar acesso SSH. Me recomenda usar o mod_wsgi ? Ví que algumas hospedagens tem o gerenciador de aplicações pytho dentro do cpanel mas não sei se é usando o mod_wsgi ou outro mod.
  12. Show de bola gente.. E vocês usam mod_wsgi ?
  13. Olá pessoal. 2 clientes pediram pra usar python na hospedagem cpanel. Alguém esta usando ? Vale a pena ter na hospedagem ?= Valeu.
  14. Boa tarde. Obrigado pelo ajuda até aqui @Jefferson Tentei o estacionário como você disse mas não deu certo pois o domínio já existe. É uma conta dentro do cpanel. Tanto o domínio do cms quanto a conta do cliente estão do mesmo servidor. Se eu remover a conta cpanel e criar o estacionário funciona bem, mas ai o cliente fica sem o cpanel. Tentei também editar o /var/cpanel/userdata/USER/dominio.com.br e depois rodar um rebuildhttpdconf. Ontem deu certo, mas como você disse antes, o cpanel atualiza e descamba tudo. Acho que a unica solução é tirar o CMS deste servidor e colocar em outro, com outro IP e ai voltar apontar via cname mesmo. Se tiver alguma outra dica pra me direcionar eu fico grato. Grande abraço.
×
×
  • Criar Novo...