Clicky

Jump to content
Portal do Host
  • Sign Up

Sign in to follow this  
pginterativa

Erro apresentado no cron

Recommended Posts

Olá pessoal tudo bem,

segue abaixo uma mensgem que estou recebendo toda vez que meu cron executa o script do whmcs

<br />

<b>Warning</b>: realpath() [<a href='function.realpath'>function.realpath</a>]: SAFE MODE Restriction in effect. The script whose uid is 524 is not allowed to access /usr/lib/php/extensions/no-debug-non-zts-20090626 owned by uid 0 in <b>/home/pgintera/public_html/admin/cron.php</b> on line <b>34</b><br /> Site error: the file <b>/home/pgintera/public_html/admin/cron.php</b> requires the ionCube PHP Loader ioncube_loader_lin_5.3.so to be installed by the site administrator.

já está tudo instalado configurado, atualizado, mas sempre mostra a mensagem acima.

Share this post


Link to post
Share on other sites

Você ativou o ionCube no Tweak Settings do whm?


WebChamp - Hospedagem de Sites SSD, Revenda de Hospedagem SSD, Revenda de VPS, Servidores Virtuais  (OpenVZ / VMware / KVM). Novos planos VPS no Brasil.

Dicas Linux - Seu portal com dicas e tutoriais Linux.

Share this post


Link to post
Share on other sites

Tenta recompilar o seu apache com o ionCube Loader.


WebChamp - Hospedagem de Sites SSD, Revenda de Hospedagem SSD, Revenda de VPS, Servidores Virtuais  (OpenVZ / VMware / KVM). Novos planos VPS no Brasil.

Dicas Linux - Seu portal com dicas e tutoriais Linux.

Share this post


Link to post
Share on other sites

Posso estar errado, mas o erro não é de "not found", e sim erro de permissão, ou seja, o arquivo está na extensions..

Novamente, vê se o SELinux está ativado.

Share this post


Link to post
Share on other sites

Pra verificar se o SELinux tá ativado digite "nano /etc/selinux/config" no SSH. Se estiver SELINUX=disabled é porque está desativado. Acredito que pra ativar tem que estar assim: SELINUX=permissive


Recomendo: MobaXterm

Share this post


Link to post
Share on other sites
Pra verificar se o SELinux tá ativado digite "nano /etc/selinux/config" no SSH. Se estiver SELINUX=disabled é porque está desativado. Acredito que pra ativar tem que estar assim: SELINUX=permissive

É diferente :P.

vi /etc/sysconfig/selinux

mude "enforcing" ou "permissive" para "disabled".

Ou se estiver com preguiça: cat /etc/sysconfig/selinux | grep SELINUX=

Se o resultado for algum dos que eu disse ali, dê um vi e mude para disabled. Em seguida dê um "reboot".

Edited by Rodrigo Baldasso

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×
×
  • Create New...