Clicky

Jump to content
  • Sign Up
Sign in to follow this  
Guest Malcriado

Problema de charset nos tickets convertidos por email [Resolvido!]

Recommended Posts

Guest Malcriado

Salve!

Estamos com um problema que me parece ser também o problema de outros.

Configuramos nosso WHMCS para converter os emails recebidos em tickets, através de PIPE (email foward). Porém estes tickets criados a partir de emails recebidos estão apresentando problemas de charset (acentos e cedilha).

Quando respondemos este ticket, os problemas de charset \"na mensagem que escrevemos\" não acontece.

O problema também não acontece quando o ticket é aberto diretamente no WHMCS. Ele acontece apenas na conversão de email para ticket.

Alguém já teve esse problema? Como resolveu?

Já abri um ticket no suporte do WHMCS mas ninguém respondeu. Acho que não estão muito dispostos a resolver problemas de caracteres latinos.

PS: Utilizamos o WHMCS versão 4.2.1 com utf-8.

Share this post


Link to post
Share on other sites
Guest Malcriado

Salve!

Estamos com um problema que me parece ser também o problema de outros.

Configuramos nosso WHMCS para converter os emails recebidos em tickets, através de PIPE (email foward). Porém estes tickets criados a partir de emails recebidos estão apresentando problemas de charset (acentos e cedilha).

Quando respondemos este ticket, os problemas de charset \\\"na mensagem que escrevemos\\\" não acontece.

O problema também não acontece quando o ticket é aberto diretamente no WHMCS. Ele acontece apenas na conversão de email para ticket.

Alguém já teve esse problema? Como resolveu?

Já abri um ticket no suporte do WHMCS mas ninguém respondeu. Acho que não estão muito dispostos a resolver problemas de caracteres latinos.

PS: Utilizamos o WHMCS versão 4.2.1 com utf-8.

Share this post


Link to post
Share on other sites
Guest Malcriado

Muita gente usa os Foruns de forma errada.

Busca a solução para um problema, e quando consegue, some sem colocar a resolução no tópico que ele próprio abriu para pedir ajuda. Ou seja, ele pede uma ajuda que ele próprio não está disposto a oferecer.

Não vou agir como esses vermes, claro. Portanto segue a solução que acabei de encontrar.

-----

Nós utilizávamos a codificação utf-8. O que fiz foi alterar para iso-8859-1. Pronto. Problema resolvido.

Poré quando vc fizer isso, seu painel de cliente vai ficar desconfigurado devido ao arquivo de tradução ser em utf-8. Para resolver, basta upar a tradução em iso-8859-1.

Ainda sim, os produtos que vc cadastrou tb vão apresentar erros, assim como a sua assinatura nos emails e provavelmente em outros lugares que ainda não detectei (isso acontece devido a mudança de charset do WHMCS). Para resolver basta reescreve-los.

Ainda existe um outro local em que os dados vão ficar desconfigurados: os dados inseridos pelos seus clientes. Eles terão que ajustar a cada vez que logarem. Nada que um bom email explicativo não resolva.

Bom, concluo que o nosso erro tenha sido iniciar o processo em utf-8 ao invés de utilizar iso-8859-1 desde o começo. Na próxima já sei.

É isso aí. Boa sorte a todos.

Share this post


Link to post
Share on other sites

Malcriado,

No meu caso aqui acho que nem vou ter este problema.

Como vendo hospedagem Plesk em cima de server Windows, o Plesk não cria a conta do cliente caso tenha qualquer caracter acentuado.

Então meus clientes já se cadastram sem acentuação.

Agora será que não se consegue uma solução para importar as mensagens em UTF-8?

Abraços.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.




×
×
  • Create New...