Jump to content

Suhosin x PHP 5.4


Recommended Posts

pessoal, após executar o EasyApache o cPanel atualizou o PHP para a versão 5.4, só que isso gerou erros no Suhosin que não é compatível com essa versão do PHP. o que eu posso usar para ter a mesma segurança que o Suhosin dava no PHP? o mod_ruid2 pode ser usado para substituir o Suhosin? ou volto para o PHP 5.3?

Link to comment
Share on other sites

Amigo o Suhosin já tem para php 5.4 porem falta o cPanel atualizar, ja pedi esse recurso porem tem poucos votos ainda.

 

33 votos preciso de sua ajuda e de outros amigos do fórum para eles implantar

 

http://features.cpanel.net/responses/update-suhosin-to-version-0935-for-php-54-55-compatibility

 

Acredito que com 400 votos já passamos os primeiros colocados e eles olham para esse pedido.

Link to comment
Share on other sites

 

Eu nunca me atentei a isso.

 

No 5.3, eu executo esse comando

 

/scripts/phpextensionmgr install PHPSuHosin
 
No 5.4, funciona também?
 
 

 

 

Não vai funcionar pois o SuHosin não possui nenhuma versão oficial para o 5.4, então o cPanel não irá conseguir.

Mas se já está disponível no mercado uma source para o PHP 5.4, então é só compilar ela. Depois de compilar, irá gerar um arquivo .so. Após isso é só movê-lo para a pasta extensions do seu PHP e ativar no php.ini.

Link to comment
Share on other sites

o comando "/scripts/phpextensionmgr install PHPSuHosin" não funciona com o PHP 5.4 pois o Suhosin não suportava ele, agora parece que já suporta mas o pessoal do cPanel não incluiu ele (segundo o link indicado pelo amigo acima neste thread). Não sei se seria uma boa instalar ele manualmente no cPanel já que este controla tudo e poderia dar conflito em alguma coisa. no momento recompilei novamente o EasyApache com o PHP 5.3 assim "resolvo".

 

mas a grande dúvida: se precisar usar o PHP 5.4 no servidor, qual seria o substituto para o Suhosin? o Mod_Ruid2 serviria ou ele é para outra coisa?

Link to comment
Share on other sites

o comando "/scripts/phpextensionmgr install PHPSuHosin" não funciona com o PHP 5.4 pois o Suhosin não suportava ele, agora parece que já suporta mas o pessoal do cPanel não incluiu ele (segundo o link indicado pelo amigo acima neste thread). Não sei se seria uma boa instalar ele manualmente no cPanel já que este controla tudo e poderia dar conflito em alguma coisa. no momento recompilei novamente o EasyApache com o PHP 5.3 assim "resolvo".

 

mas a grande dúvida: se precisar usar o PHP 5.4 no servidor, qual seria o substituto para o Suhosin? o Mod_Ruid2 serviria ou ele é para outra coisa?

 

Não tem perigo nenhum. Você só vai ter que colocar a mão na massa e fazer o que o cPanel faz pra você toda vez que recompila o Apache: compilar um módulo da fonte e depois colocar o nome do módulo nas extensões.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

Do you agree with our terms?