Jump to content

[Ajuda] Mod_Rewrite E Joomla


dackson

Recommended Posts

Bom dia pessoal,

Adquiri recentemente um Smart Serve na IWeb, com um pouco de trabalho e muita pesquisa, fiz todas as configurações necessárias para meus sites, após realizar a migração de um site de teste, percebi que as URL's amigáveis não estão funcionando, sei que esse problema pode ocorrer com o mod_rewrite do apache ou no arquivo .htaccess, pesquisei bastante, inclusive aqui no fórum, mais não encontrei uma solução para o meu problema, alguém já passou por isso? Poderiam me ajudar?

Detalhes:

SO: Centos 6

CPanel/WHM: 11.34.1

Com o CPanel, o mod_rewrite já vem compilado junto com o apache, verifiquei isso com o comando:

httpd -l | grep mod_rewrite
Retorno
mod_rewrite.c[/code]




No arquivo /etc/httpd/conf/httpd.conf



[code] ... RewriteEngine on ... <Directory "/"> Options All AllowOverride All </Directory> ... [/code]
Utilizo o Joomla 2.5 que dá suporte a URL amigáveis, quando desabilito a opção de "utilizar URL's amigáveis com o mod_rewrite", o site funciona normalmente. .htaccess (do Joomla)
[code] ## Can be commented out if causes errors, see notes above. Options +FollowSymLinks ## Mod_rewrite in use. RewriteEngine On[/code]

Agradeço a ajuda de todos!

Link to comment
Share on other sites

Tente comentar a opção Options +FollowSymLinks

Se não sabe, comentar significa por um # em frente à uma linha (ou // e /* */ em outros casos).

Edição: em minha instalação do Joomla na existe essa linha acima. Se a dica não servir, dê uma olha no erro log do Apache; ele tem detalhes da causa do erro.

Não há bem nem mal que dure para sempre. Um dia tudo acaba.

Link to comment
Share on other sites

Olá Jaime, já fiz esse teste e continua com o mesmo problema, acabei de testar com o Joomla 3 e o problema persiste.

Obs.: O erro retornado é o 404 (Página não encontrada).

Acho que seja alguma configuração no Apache, mais não encontro qual!

Obrigado pela ajuda Jaime.

Link to comment
Share on other sites

O .htaccess que estou utilizando é o padrão do Joomla:


#

# @package  Joomla

# @copyright Copyright (C) 2005 - 2012 Open Source Matters. All rights reserved.

# @license  GNU General Public License version 2 or later; see LICENSE.txt

##

##

# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE!

#

# The line just below this section: 'Options +FollowSymLinks' may cause problems

# with some server configurations.  It is required for use of mod_rewrite, but may already

# be set by your server administrator in a way that dissallows changing it in

# your .htaccess file.  If using it causes your server to error out, comment it out (add # to

# beginning of line), reload your site in your browser and test your sef url's.  If they work,

# it has been set by your server administrator and you do not need it set here.

##

## Can be commented out if causes errors, see notes above.

Options +FollowSymLinks

## Mod_rewrite in use.

RewriteEngine On

## Begin - Rewrite rules to block out some common exploits.

# If you experience problems on your site block out the operations listed below

# This attempts to block the most common type of exploit `attempts` to Joomla!

#

# Block out any script trying to base64_encode data within the URL.

RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR]

# Block out any script that includes a <script> tag in URL.

RewriteCond %{QUERY_STRING} (<|%3C)([^s]*s)+cript.*(>|%3E) [NC,OR]

# Block out any script trying to set a PHP GLOBALS variable via URL.

RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]

# Block out any script trying to modify a _REQUEST variable via URL.

RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})

# Return 403 Forbidden header and show the content of the root homepage

RewriteRule .* index.php [F]

#

## End - Rewrite rules to block out some common exploits.

## Begin - Custom redirects

#

# If you need to redirect some pages, or set a canonical non-www to

# www redirect (or vice versa), place that code here. Ensure those

# redirects use the correct RewriteRule syntax and the [R=301,L] flags.

#

## End - Custom redirects

##

# Uncomment following line if your webserver's URL

# is not directly related to physical file paths.

# Update Your Joomla! Directory (just / for root).

##

# RewriteBase /

## Begin - Joomla! core SEF Section.

#

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

#

# If the requested path and file is not /index.php and the request

# has not already been internally rewritten to the index.php script

RewriteCond %{REQUEST_URI} !^/index\.php

# and the request is for something within the component folder,

# or for the site root, or for an extensionless URL, or the

# requested URL ends with one of the listed extensions

RewriteCond %{REQUEST_URI} /component/|(/[^.]*|\.(php|html?|feed|pdf|vcf|raw))$ [NC]

# and the requested path and file doesn't directly match a physical file

RewriteCond %{REQUEST_FILENAME} !-f

# and the requested path and file doesn't directly match a physical folder

RewriteCond %{REQUEST_FILENAME} !-d

# internally rewrite the request to the index.php script

RewriteRule .* index.php [L]

#

## End - Joomla! core SEF Section.

Link to comment
Share on other sites

Aparentemente está ok.

Só descomente a linha


# RewriteBase /

e teste novamente.

Se por um acaso seu Joomla não estiver instalado na raiz de seu site (ex: www.seusite.com.br/ ) mas sim dentro de uma pasta (ex: www.seusite.com.br/nomedapasta/), então também corrija ali o RewriteBase / para RewriteBase /nomedapasta/

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

Do you agree with our terms?