Clicky

Ir para conteúdo

Eduardo Rissao

Ajuda com Squid

Posts Recomendados

Olá,

 

Não sei se aqui é a área correta para isso,mas vamos lá:

Estou com uma vps no Brasil, para instalar o squid, afim de bloquear o acesso a alguns sites nos computadores da empresa de meu pai, porem não consigo fazer o servidor funcionar corretamente.

Eu instalo o squid, e não mexo nas configurações dele, deixando no padrão, que é o recomendado por eles (fiz isso apenas para testar se a conexão estava funcionando.), mas quando eu configuro o navegador para usar o proxy, TODOS os sites ficam indisponíveis, mesmo eu não mexendo na configuração do squid e bloqueando nenhum site.

Sistema operacional usado: CentOS 6 x86_64

Alguém, por favor, me ajude?!

Lembrando que não é um servidor em localhost, então eu creio que devo mudar algum IP na configuração, mas eu não sei qual..

 

Atenciosamente,

Eduardo Rissão

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Consegui fazer ele rodar de forma transparente, porem, por esse meio, não posso bloquear sites https.

Para isso, vou ter que configurar ele de forma autenticada, o que eu vou ter que pesquisar tudo novamente.


Se alguém puder me ajuda nessa parte..

Compartilhar este post


Link para o post
Compartilhar em outros sites

Consegui fazer ele rodar de forma transparente, porem, por esse meio, não posso bloquear sites https.

Para isso, vou ter que configurar ele de forma autenticada, o que eu vou ter que pesquisar tudo novamente.

Se alguém puder me ajuda nessa parte..

O porque nao usa um servidor interno para o squid? Pode ser ateh um pentium 4 pra isso!

A respeito do proxy transparente pata bloquear https, da sim. Tem um tutorial no viva o Linux

Compartilhar este post


Link para o post
Compartilhar em outros sites

O porque nao usa um servidor interno para o squid? Pode ser ateh um pentium 4 pra isso!

A respeito do proxy transparente pata bloquear https, da sim. Tem um tutorial no viva o Linux

 Pois é, dizem que da, mas eu já tentei e ele não ta bloqueando nem site sem https, por isso to achando estranho..

Compartilhar este post


Link para o post
Compartilhar em outros sites

Veja esses links, mas da sim cara com squid e iptables.

 

Na empresa que trampo é assim, alguns sites em https ele bloqueia de forma diferente, tipo rejeita a conexão, já no http ele bloqueia exibindo a página de bloqueio personalizada.

 

 

http://www.vivaolinux.com.br/topico/Squid-Iptables/Squid-333-Debian-7-HTTPS-TRANSPARENT
http://www.vivaolinux.com.br/artigo/Squid-+-Iptables-Combinacao-Infalivel?pagina=4
https://www.google.com.br/search?hl=&q=squid+proxy+transparente+https&sourceid=navclient-ff&rlz=1B7GGHP_pt-BRBR449BR449&ie=UTF-8&aq=2&oq=squid+proxy+tra&gws_rd=ssl

  • Gostei! 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Participe da conversa

Você pode postar agora e se cadastrar mais tarde. Se você tem uma conta, faça o login para postar com sua conta.

Visitante
Responder

×   Você colou conteúdo com formatação.   Remover formatação

  Apenas 75 emojis são permitidos.

×   Seu link foi automaticamente incorporado.   Mostrar como link

×   Seu conteúdo anterior foi restaurado.   Limpar o editor

×   Não é possível colar imagens diretamente. Carregar ou inserir imagens do URL.


  • Quem Está Navegando   0 membros estão online

    Nenhum usuário registrado visualizando esta página.



×
×
  • Criar Novo...