Clicky

Jump to content
Portal do Host
  • Sign Up

Eduardo Rissao

Silver
  • Content Count

    167
  • Joined

  • Last visited

Personal Info

  • Name
    Eduardo Rissão

Contact info

  • Skype
    eduardo.rissao

Recent Profile Visitors

1,281 profile views
  1. Foi pago para uma empresa fazer eles. Ai começou a dar problema quando transferiu o site para a WebLink.
  2. Bem, fiz uma coisa no notepad++ que foi muita burrisse minha não ter feito isso antes. Na hora de salvar, eu converti ele (no próprio notepad++) para UTF-8. Fiz isso em todas as páginas, o que resolveu os problemas com acentos (se possivel, vejam se acham algum erro de acentuação em alguma página do site http://grmoveisplanejados.com.br/) Porém, no código, ainda permanece o charset como iso-8859-1, vejam: http://prntscr.com/6njhgd Será que tem algum problema? Ps: Para arrumar o problema do banco de dados, eu coloquei o código nas páginas que puxava os dados do db: header('Content-Type: text/html; charset=utf-8'); mysql_query("SET NAMES 'utf8'"); mysql_query('SET character_set_connection=utf8'); mysql_query('SET character_set_client=utf8'); mysql_query('SET character_set_results=utf8'); E depois converti tudo para o UTF-8, porem com o detalhe do charset no código ainda estar iso-8859-1 Atenciosamente, Eduardo Rissão
  3. Esse código ai não acontece nada, mesmo colocando depois da conexão com o banco de dados. Agora se coloca o código que me passaram: header('Content-Type: text/html; charset=utf-8'); mysql_query("SET NAMES 'utf8'"); mysql_query('SET character_set_connection=utf8'); mysql_query('SET character_set_client=utf8'); mysql_query('SET character_set_results=utf8'); Da um problema diferente, tipo, ele arruma o problema com o banco de dados, mas a página em si fica bugada. Veja a print: ( http://prntscr.com/6mjbjp )
  4. Acho bem dificil isso acontecer. Veja bem: Você vai numa loja famosa de roupas (Hering, Polo Play, sei lá o que) para comprar uma camiseta e é recepcionado com um péssimo atendimento. Com isso, você irá dizer que as lojas de roupas mais simples da sua cidade também é assim (ou pior)?
  5. Não, nem todos. Na página inicial, somente o que está com problema mesmo. Isso e as fotos, na galeria. Segue o código da index: <? session_start(); require_once "icontrol/_lib/icontrol.php"; require_once "icontrol/_lib/icontrol.pontualweb.php"; require_once "icontrol/_lib/conndb.php"; require_once "icontrol/_lib/functions.php"; ?> <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> <html xmlns="http://www.w3.org/1999/xhtml"> <head> <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" /> <meta name="keywords" content="moveis, marcenaria, cozinhas, armarios, planejados"> <meta name="description" content="A GR Móveis Planejados é atualmente uma das principais fabricantes de móveis planejados do interior paulista. Com equipamentos de última geração e tecnologia de ponta, a GR utiliza materiais que atendem aos mais exigentes padrões de qualidade do mercado, prezando por um acabamento impecável!"> <title>GR Móveis Planejados</title> <link href="estrutura.css" rel="stylesheet" type="text/css" /> <link rel="shortcut icon" href="/favicon.ico" type="image/x-icon" /> </head> <body> <div class="topo"><img src="imagens/logo.jpg" width="984" height="199" /></div> <div class="menu" align="center"> <? include("menu.php"); ?> </div> <div class="banner1"> <? include('banner.php'); ?> <br /> <? $sqlHome = "select * from imovel where imoInterna = 'S' order by imoCodigo desc limit 2"; $qryHome = mysql_query($sqlHome); ?> <div style="width:954px; margin:auto;"> <ul style="list-style:none; padding:0px; margin:0;"> <? while ($itens = mysql_fetch_assoc($qryHome)) { ?> <li style="display:inline-block; background-image:url(imagens/sombraHome.png); width:475px; height:277px; position:relative;"> <div style="height:25px; padding:10px; text-align:left; font:16px verdana; color:#FFF;"><a href="internas.php?cod=<?= $itens['imoCodigo']; ?>" style="text-decoration:none; font:16px verdana; color:#FFF;"><?= $itens['imoNome']; ?></a></div> <ul style="list-style:none; padding:0px 10px; margin:0;"> <? $sql = "select * from fotos where imoCodigo = {$itens['imoCodigo']} limit 1"; $qry = mysql_query($sql); while($apreFotoP = mysql_fetch_assoc($qry)) { $i++; if (vrfExtensao('imagem', 'web/imagens/produtos/site/miniaturas/', $apreFotoP['imoCodigo'] . '_' . $apreFotoP['fotCodigo']) == true) { $miniatura = $img; list($w, $h) = getimagesize($miniatura); $image_file = $miniatura; $targetfile = "maskara/maskara" . $apreFotoP['imoCodigo'].$apreFotoP['fotCodigo'] .".jpg"; $photo = imagecreatefromjpeg($image_file); $fotoW = 165; $fotoH = 165; $photoFrame = imagecreatetruecolor($fotoW,$fotoH); $dest_x = ($w - $fotoW) / 2; $dest_y = ($h - $fotoH) / 2; imagecopy($photoFrame, $photo, 0, 0, $dest_x, $dest_y, $fotoW, $fotoH); imagejpeg($photoFrame, $targetfile); ?> <li style="display:inline-block; width:170px;"><a href="internas.php?cod=<?= $itens['imoCodigo']; ?>"><img src='<?= $targetfile; ?>' border="0"/></a></li> <? unset($targetfile); } } ?> <li style="display:inline-block; width:280px; font:12px verdana; color:#FFF; vertical-align:top; text-align:left;"><a href="internas.php?cod=<?= $itens['imoCodigo']; ?>" style="text-decoration:none; font:12px verdana; color:#FFF;"><?= nl2br($itens['imoPre']); ?></a></li> </ul> </li> <? } ?> </ul> </div> </div> <div class="rodape"> <? include("rodape.php"); ?> <?php include_once("analyticstracking.php") ?> </div> </body> </html> Como o problema aparenta estar somente na tabela onde está esse texto, eu posso deleta-la e importa-la novamente (somente essa tabela)? Pois quando eu tempo importa sem deleta-la, aparece isso: http://prntscr.com/6mjgbm Atenciosamente, Eduardo Rissão
  6. Sim, agora arrumou a parte que estava com defeito, mas bugou as outras, veja: http://prntscr.com/6mjbjp Atenciosamente, Eduardo Rissão
  7. Mas o próprio banco de dados está enviando o charset Veja, fiz algumas mudanças e deixei o site todo em charset iso-8859-1 e o banco de dados em latin1_swedish_ci. O rodapé, por exemplo, está normal (mesmo não sendo pego do banco de dados). Já o http://prntscr.com/6meg8qestá. O que será que é isso...?
  8. Olá, Depois de transferir meu site para a nova hospedagem, começou a me aparecer problemas na acentuação em alguns lugares do site. Estava configurado da seguinte forma: No código php (junto com o html) do site, o charset estava iso-8859-1, e no banco de dados do site estava no uf8_unicode_ci, porem em cada tabela estava o latin1_sweddish_ci Teoricamente, era para estar tudo correto, mas não estava. Então mudei o charset no código para utf-8, e arrumou uma parte. Porem na descrição da aba deu erro no acento, e tive que colocar aqueles códigos html para acentos. Entretanto, quando eu coloco o link dele no facebook, fica bugado, veja: http://prntscr.com/6mdyxv O que eu faço? Atenciosamente, Eduardo Rissão
  9. Funcionou!!!! Muito obrigado!!! Ps: Tive que desabilitar a auto resposta pelo php (vou fazer pelo painel da host), pois dava erro.
  10. É que o formulário em si fica em outro php, um que só monta a página mesmo. Ai é o código que envia o e-mail. Pode dar um exemplo, fazendo o get do nome e colocando no código para mim? O resto eu faço... Então, acho que nenhum dos dois. O estranho é que antes isso funcionava.. (Parou depois que transferiu o site)
  11. Olá, Estou com muita dificuldade em algo que me parece simples, que envolve envio de e-mails por meio de um formulário de contato. Bem, vamos lá. Tenho um formulário de contato no meu site, porem sem funcionar. Link: http://grmoveisplane....br/contato.php O código para envio do e-mail dele é esse: <? $assu = "Contato pelo Site"; $header = "From: {$email}\n"; $header .= "Organization: GR Moveis\n"; $header .= "MIME-Version: 1.0\n"; $header .= "Content-Type: text/html; charset=iso-8859-1\n"; $header .= "Content-Transfer-Encoding: 8bit\n"; $mens = "<html><head><title>Entre em contato</title> </head> <body bgcolor=#ffffff text=#000000 topmargin=0 leftmargin=0> <table width=100% align=center> <tr> <td width=30%>Nome</td> <td>$nome</td> </tr> <tr> <td width=30%>E-mail</td> <td>$email</td> </tr> <tr> <td width=30%>Assunto</td> <td>$mensagem</td> </tr> </table> </body>"; require_once('mail/phpmailer/class.phpmailer.php'); $time = time(); $mail = new PHPMailer(); //$body = file_get_contents('contents.html'); //$body = eregi_replace("[\]",'',$body); $body = $mens; $mail->IsSMTP(); // telling the class to use SMTP $mail->SMTPDebug = 0; // enables SMTP debug information (for testing) // 1 = errors and messages // 2 = messages only $mail->SMTPAuth = true; // enable SMTP authentication $mail->SMTPSecure = "tls"; $mail->Host = "mx2.weblink.com.br"; // sets the SMTP server $mail->Port = 2525; // set the SMTP port for the GMAIL server $mail->Username = "teste@grmoveisplanejados.com.br"; // SMTP account username $mail->Password = "SENHADOEMAIL"; // SMTP account password $mail->SetFrom($email, $nome); $mail->AddReplyTo($email, $nome); $mail->Subject = $assu; $mail->AltBody = "Para ver a mensagem, use um leitor de e-mail compativel com HTML."; // optional, comment out and test $mail->MsgHTML($body); $address = "teste@grmoveisplanejados.com.br"; $mail->AddAddress($address, "Contato"); //$mail->AddAttachment("images/phpmailer.gif"); // attachment //$mail->AddAttachment("images/phpmailer_mini.gif"); // attachment if(!$mail->Send()) { echo "A mensagem nao pode ser enviada. Mensagem de erro: " . $mail->ErrorInfo; } else { echo "E-mail enviado com sucesso!"; } ?> O problema dele está na hora de receber o e-mail. Acontece assim: Eu digito todas as informações no formulário de contato: http://prntscr.com/6lzme0 Clico em Enviar. Aparece que foi enviado com sucesso: http://prntscr.com/6lzmv6 Até ai beleza. Entro no e-mail de teste que eu criei e coloquei para receber os e-mail do formulário. O e-mail é recebido: http://prntscr.com/6lzngk Porem, ele não envia informação NENHUMA do formulário de contato, veja: http://prntscr.com/6lznoz Alguem tem ideia do que eu posso fazer para fazer essa coisa funcionar? Atenciosamente, Eduardo Rissão
  12. Se estivermos se tratando de marketing, sem dúvidas, eles são os melhores nisso (Principalmente UOLHOST). Mas se estivermos se tratando de qualidade de serviço já suja. A hostGator e a GoDaddy ainda se salvam, pois, apesar de ter muitas reclamações (que é normal em grandes empresas), conseguem atender bem a maioria dos clientes. Já a UOLHOST, ta no sal. Digo isso pois já vi um amigo usar e foi a pior coisa. Sites que demoram para atualizar o código, entre outras coisas. Um dia, fui pedir uma hospedagem de site lá, mas quando pesquisei, não achei uma pessoa falando bem do serviço deles. (Isso a uns 3 ou 4 meses atrás, não sei se já mudou). Creio que está longe de a UOLHOST falir outra empresa no mercado.
  13. Parece que ele só permite enviar X e-mails no gratuito. Estou errado?
×
×
  • Create New...