Clicky

Ir para conteúdo

abobre

Provavel erro ao atualizar o centos 6

Posts Recomendados

Bom dia, tenho dois dedicados com o centos 6 instalado e agora quando tento atualizar o centos,aparece a seguinte mensagem, e não atualiza, nesses servidores eu utilizo o WHM também.

root@srv [~]# yum update
Loaded plugins: fastestmirror
Setting up Update Process
Loading mirror speeds from cached hostfile
 * base: mirror-fr2.bbln.org
 * epel: www.mirrorservice.org
 * extras: mirror-fr2.bbln.org
 * rpmforge: www.mirrorservice.org
 * updates: mirror-fr2.bbln.org
Resolving Dependencies
--> Running transaction check
---> Package bind.x86_64 32:9.8.2-0.23.rc1.el6_5.1 will be updated
--> Processing Dependency: bind = 32:9.8.2-0.23.rc1.el6_5.1 for package: 32:bind-chroot-9.8.2-0.23.rc1.el6_5.1.x86_64
---> Package bind.x86_64 32:9.8.2-0.30.rc1.el6_6.1 will be an update
---> Package bind-devel.x86_64 32:9.8.2-0.23.rc1.el6_5.1 will be updated
---> Package bind-devel.x86_64 32:9.8.2-0.30.rc1.el6_6.1 will be an update
---> Package bind-libs.x86_64 32:9.8.2-0.23.rc1.el6_5.1 will be updated
---> Package bind-libs.x86_64 32:9.8.2-0.30.rc1.el6_6.1 will be an update
---> Package bind-utils.x86_64 32:9.8.2-0.23.rc1.el6_5.1 will be updated
---> Package bind-utils.x86_64 32:9.8.2-0.30.rc1.el6_6.1 will be an update
---> Package curl.x86_64 0:7.19.7-40.el6_6.3 will be updated
---> Package curl.x86_64 0:7.19.7-40.el6_6.4 will be an update
---> Package glibc.x86_64 0:2.12-1.149.el6_6.4 will be updated
---> Package glibc.x86_64 0:2.12-1.149.el6_6.5 will be an update
---> Package glibc-common.x86_64 0:2.12-1.149.el6_6.4 will be updated
---> Package glibc-common.x86_64 0:2.12-1.149.el6_6.5 will be an update
---> Package glibc-devel.x86_64 0:2.12-1.149.el6_6.4 will be updated
---> Package glibc-devel.x86_64 0:2.12-1.149.el6_6.5 will be an update
---> Package glibc-headers.x86_64 0:2.12-1.149.el6_6.4 will be updated
---> Package glibc-headers.x86_64 0:2.12-1.149.el6_6.5 will be an update
---> Package glibc-static.x86_64 0:2.12-1.149.el6_6.4 will be updated
---> Package glibc-static.x86_64 0:2.12-1.149.el6_6.5 will be an update
---> Package kernel-headers.x86_64 0:2.6.32-504.3.3.el6 will be updated
---> Package kernel-headers.x86_64 0:2.6.32-504.8.1.el6 will be an update
---> Package libcurl.x86_64 0:7.19.7-40.el6_6.3 will be updated
---> Package libcurl.x86_64 0:7.19.7-40.el6_6.4 will be an update
---> Package libssh2.x86_64 0:1.4.2-1.el6 will be updated
---> Package libssh2.x86_64 0:1.4.2-1.el6_6.1 will be an update
---> Package nss-softokn.x86_64 0:3.14.3-19.el6_6 will be updated
---> Package nss-softokn.x86_64 0:3.14.3-22.el6_6 will be an update
---> Package nss-softokn-freebl.x86_64 0:3.14.3-19.el6_6 will be updated
---> Package nss-softokn-freebl.x86_64 0:3.14.3-22.el6_6 will be an update
---> Package tcsh.x86_64 0:6.17-24.el6 will be updated
---> Package tcsh.x86_64 0:6.17-25.el6_6 will be an update
--> Finished Dependency Resolution
Error: Package: 32:bind-chroot-9.8.2-0.23.rc1.el6_5.1.x86_64 (@updates)
           Requires: bind = 32:9.8.2-0.23.rc1.el6_5.1
           Removing: 32:bind-9.8.2-0.23.rc1.el6_5.1.x86_64 (@updates)
               bind = 32:9.8.2-0.23.rc1.el6_5.1
           Updated By: 32:bind-9.8.2-0.30.rc1.el6_6.1.x86_64 (updates)
               bind = 32:9.8.2-0.30.rc1.el6_6.1
           Available: 32:bind-9.8.2-0.30.rc1.el6.x86_64 (base)
               bind = 32:9.8.2-0.30.rc1.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
root@srv [~]#

Compartilhar este post


Link para o post
Compartilhar em outros sites

Analisando algumas informações referente o erro e também no google, acredito que tenha encontrado a causa do problema, conforme mensagem que recebi no servidor.

Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:

         1. You have an upgrade for bind-libs which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of bind-libs of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude bind-libs.otherarch ... this should give you an error
            message showing the root cause of the problem.

         2. You have multiple architectures of bind-libs installed, but
            yum can only see an upgrade for one of those arcitectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.

         3. You have duplicate versions of bind-libs installed already.
            You can use "yum check" to get yum show these errors.

       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).

       Protected multilib versions: 32:bind-libs-9.8.2-0.30.rc1.el6_6.1.x86_64 !                                                              = 32:bind-libs-9.8.2-0.30.rc1.el6.i686

root@srv [~]# yum list --showduplicates 32:bind-libs-9.8.2-0.30.rc1.el6_6.1.*
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror-fr1.bbln.org
 * extras: mirror-fr1.bbln.org
 * updates: mirror-fr1.bbln.org
Available Packages
bind-libs.i686                                                 32:9.8.2-0.30.rc1.el6_6.1                                               updates
bind-libs.x86_64                                               32:9.8.2-0.30.rc1.el6_6.1                                               updates
root@srv [~]#

Eu tenho instalado nos servidores o Centos 6 de 64bits, eu posso remover tranquilamente o bind-libs.i686 32:9.8.2-0.30.rc1.el6_6.1 do meu servidor, pois acredito que é ele que está causando o problema ?

 

 Grato

Compartilhar este post


Link para o post
Compartilhar em outros sites

Participe da conversa

Você pode postar agora e se cadastrar mais tarde. Se você tem uma conta, faça o login para postar com sua conta.

Visitante
Responder

×   Você colou conteúdo com formatação.   Remover formatação

  Apenas 75 emojis são permitidos.

×   Seu link foi automaticamente incorporado.   Mostrar como link

×   Seu conteúdo anterior foi restaurado.   Limpar o editor

×   Não é possível colar imagens diretamente. Carregar ou inserir imagens do URL.


  • Quem Está Navegando   0 membros estão online

    Nenhum usuário registrado visualizando esta página.



×
×
  • Criar Novo...