Jump to content

smtp banner com mais de um IP postfix no centos


RonanC

Recommended Posts

Boa noite pessoal, estou realizando alguns testes em um novo servidor para oferecer um serviço aos clientes existentes

 

Porém estou com dificuldade para configurar o smtp banner correto para cada IP de envio no postfix / centos

 

Alguém já conseguiu fazer isso ? tenho 5 ips neste servidor.

 

pretendo aplicar o mesmo nos servidores com whm, pretendo rotacionar pelo menos 2 ip's porém apanho na hora de acertar o banner.

 

Já consegui rotacionar os ips no envio, assinar com dkim, spf etc, tudo ok, apenas o smtp banner que sempre aparece o mesmo.

 

Se alguém já fez isso e puder compartilhar o conhecimento, agradeço.

 

Dispenso comentários idiotas por favor.

Link to comment
Share on other sites

Ronan,

 

Configure seu master.cf para responder aos IP's conforme desejado:

 

IP.IP.IP.IP:smtp inet n - - - - smtpd -o myhostname=mail.dominio.com...
IP.IP.IP.IP:smtp inet n - - - - smtpd -o myhostname=mail.dominio.com...

 

Não esqueça de considerar a variável no main.cf:

 

smtpd_banner = $myhostname 

 

[]s

Link to comment
Share on other sites

Ronan,

 

Configure seu master.cf para responder aos IP's conforme desejado:

 

IP.IP.IP.IP:smtp inet n - - - - smtpd -o myhostname=mail.dominio.com...

IP.IP.IP.IP:smtp inet n - - - - smtpd -o myhostname=mail.dominio.com...

 

Não esqueça de considerar a variável no main.cf:

 

smtpd_banner = $myhostname 

 

[]s

 

Obrigado pela dica cara, acho que apaguei uma linha a mais no server, vou re instalar tudo se der certo farei um tutorial completo aqui pro portaldohost.

 

Here we go.

Link to comment
Share on other sites

IP:smtp inet n  - - - -  smtpd -o myhostname=server1.dominio.net
IP:smtp inet n  - - - -  smtpd -o myhostname=server2.dominio.net
IP:smtp inet n  - - - -  smtpd -o myhostname=server3.dominio.net
IP:smtp inet n  - - - -  smtpd -o myhostname=server4.dominio.net
 
isso coloquei em /etc/zpanel/configs/postfix/master.cf
 
também adicionei as linhas para assinar cmo DKIM os e-mails, e está funcionando, agora só falta acertar o smtp banner.
 
Depois de adicinoar os ips como indicou, uando reiniciei o postfix deu o seguinte erro no log
 
Jun  6 10:07:41 server1 postfix/postfix-script[1708]: starting the Postfix mail system
Jun  6 10:07:41 server1 postfix/master[1709]: fatal: bind XX.XX.XX.XX port 25: Address already in use
 
Estou usando o postfix instalado junto com o zpanel pra facilitar o gerenciamento das contas etc.
 
Tenho que apagar alguma linha que o zpanel criou pra evitar esse conflito ?
 
Obrigado !!!
Link to comment
Share on other sites

Segue zpanel main.cf

# postfix config file

# uncomment for debugging if needed

soft_bounce=yes

# postfix main

mail_owner = postfix

setgid_group = postdrop

delay_warning_time = 4

# postfix paths

html_directory = no

command_directory = /usr/sbin

daemon_directory = /usr/libexec/postfix

queue_directory = /var/spool/postfix

sendmail_path = /usr/sbin/sendmail.postfix

newaliases_path = /usr/bin/newaliases.postfix

mailq_path = /usr/bin/mailq.postfix

manpage_directory = /usr/share/man

sample_directory = /usr/share/doc/postfix-2.2.2/samples

readme_directory = /usr/share/doc/postfix-2.2.2/README_FILES

# network settings

inet_interfaces = all

mydomain = dominio.com

myhostname = server1.dominio.com

mynetworks = all

mydestination = localhost.$mydomain, localhost

relay_domains = proxy:mysql:/etc/zpanel/configs/postfix/mysql-relay_domains_maps.cf

smtpd_banner = $myhostname

# mail delivery

recipient_delimiter = +

# mappings

alias_maps = hash:/etc/aliases

alias_database = hash:/etc/aliases

transport_maps = hash:/etc/postfix/transport

#local_recipient_maps =

# virtual setup

virtual_alias_maps = proxy:mysql:/etc/zpanel/configs/postfix/mysql-virtual_alias_maps.cf,

regexp:/etc/zpanel/configs/postfix/virtual_regexp

virtual_mailbox_base = /var/zpanel/vmail

virtual_mailbox_domains = proxy:mysql:/etc/zpanel/configs/postfix/mysql-virtual_domains_maps.cf

virtual_mailbox_maps = proxy:mysql:/etc/zpanel/configs/postfix/mysql-virtual_mailbox_maps.cf

virtual_mailbox_limit_maps = proxy:mysql:/etc/zpanel/configs/postfix/mysql-virtual_mailbox_limit_maps.cf

virtual_minimum_uid = 101

virtual_uid_maps = static:101

virtual_gid_maps = static:12

virtual_transport = dovecot

dovecot_destination_recipient_limit = 1

# debugging

debug_peer_level = 2

debugger_command =

PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin

xxgdb $daemon_directory/$process_name $process_id & sleep 5

# authentication

smtpd_sasl_auth_enable = yes

smtpd_sasl_security_options = noanonymous

smtpd_sasl_local_domain = $myhostname

broken_sasl_auth_clients = yes

smtpd_sasl_type = dovecot

smtpd_sasl_path = private/auth

# tls config

smtp_use_tls = yes

smtpd_use_tls = yes

#smtp_tls_note_starttls_offer = yes

#smtpd_tls_loglevel = 1

#smtpd_tls_received_header = yes

#smtpd_tls_session_cache_timeout = 3600s

#tls_random_source = dev:/dev/urandom

#smtp_tls_session_cache_database = btree:$data_directory/smtp_tls_session_cache

# Change mail.example.com.* to your host name

#smtpd_tls_key_file = /etc/pki/tls/private/mail.example.com.key

#smtpd_tls_cert_file = /etc/pki/tls/certs/mail.example.com.crt

# smtpd_tls_CAfile = /etc/pki/tls/root.crt

# rules restrictions

smtpd_client_restrictions =

smtpd_helo_restrictions =

smtpd_sender_restrictions =

smtpd_recipient_restrictions = permit_sasl_authenticated,

permit_mynetworks,

reject_unauth_destination,

reject_non_fqdn_sender,

reject_non_fqdn_recipient,

reject_unknown_recipient_domain

# uncomment for realtime black list checks

,reject_rbl_client zen.spamhaus.org

,reject_rbl_client bl.spamcop.net

,reject_rbl_client dnsbl.sorbs.net

smtpd_helo_required = yes

unknown_local_recipient_reject_code = 550

disable_vrfy_command = yes

smtpd_data_restrictions = reject_unauth_pipelining

smtpd_milters = inet:127.0.0.1:8891

non_smtpd_milters = $smtpd_milters

milter_default_action = accept

milter_protocol = 2

Segue master.cf, penso que o conflito esteja aqui

#

# Postfix master process configuration file. For details on the format

# of the file, see the Postfix master(5) manual page.

#

# ***** Unused items removed *****

# ==========================================================================

# service type private unpriv chroot wakeup maxproc command + args

# (yes) (yes) (yes) (never) (100)

# ==========================================================================

smtp inet n - n - - smtpd

# -o content_filter=smtp-amavis:127.0.0.1:10024

# -o receive_override_options=no_address_mappings

pickup fifo n - n 60 1 pickup

-o content_filter=

-o receive_override_options=no_header_body_checks

cleanup unix n - n - 0 cleanup

qmgr fifo n - n 300 1 qmgr

#qmgr fifo n - n 300 1 oqmgr

tlsmgr unix - - n 1000? 1 tlsmgr

rewrite unix - - n - - trivial-rewrite

bounce unix - - n - 0 bounce

defer unix - - n - 0 bounce

trace unix - - n - 0 bounce

verify unix - - n - 1 verify

flush unix n - n 1000? 0 flush

proxymap unix - - n - - proxymap

smtp unix - - n - - smtp

# When relaying mail as backup MX, disable fallback_relay to avoid MX loops

relay unix - - n - - smtp

-o fallback_relay=

# -o smtp_helo_timeout=5 -o smtp_connect_timeout=5

showq unix n - n - - showq

error unix - - n - - error

discard unix - - n - - discard

local unix - n n - - local

virtual unix - n n - - virtual

lmtp unix - - n - - lmtp

anvil unix - - n - 1 anvil

scache unix - - n - 1 scache

#

# ====================================================================

# Interfaces to non-Postfix software. Be sure to examine the manual

# pages of the non-Postfix software to find out what options it wants.

# ====================================================================

maildrop unix - n n - - pipe

flags=DRhu user=vmail argv=/usr/local/bin/maildrop -d ${recipient}

uucp unix - n n - - pipe

flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)

ifmail unix - n n - - pipe

flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)

bsmtp unix - n n - - pipe

flags=Fq. user=foo argv=/usr/local/sbin/bsmtp -f $sender $nexthop $recipient

#

# spam/virus section

#

smtp-amavis unix - - y - 2 smtp

-o smtp_data_done_timeout=1200

-o disable_dns_lookups=yes

-o smtp_send_xforward_command=yes

127.0.0.1:10025 inet n - y - - smtpd

-o content_filter=

-o smtpd_helo_restrictions=

-o smtpd_sender_restrictions=

-o smtpd_recipient_restrictions=permit_mynetworks,reject

-o mynetworks=127.0.0.0/8

-o smtpd_error_sleep_time=0

-o smtpd_soft_error_limit=1001

-o smtpd_hard_error_limit=1000

-o receive_override_options=no_header_body_checks

-o smtpd_bind_address=127.0.0.1

-o smtpd_helo_required=no

-o smtpd_client_restrictions=

-o smtpd_restriction_classes=

-o disable_vrfy_command=no

-o strict_rfc821_envelopes=yes

#

# Dovecot LDA

dovecot unix - n n - - pipe

flags=DRhu user=vmail:mail argv=/usr/libexec/dovecot/deliver -d ${recipient}

#

# Vacation mail

vacation unix - n n - - pipe

flags=Rq user=vacation argv=/var/spool/vacation/vacation.pl -f ${sender} -- ${recipient}

XX.XX.XX.XX:smtp inet n - - - - smtpd -o myhostname=server1.dominio.com

XX.XX.XX.XX:smtp inet n - - - - smtpd -o myhostname=server2.dominio.com

XX.XX.XX.XX:smtp inet n - - - - smtpd -o myhostname=server3.dominio.com

XX.XX.XX.XX:smtp inet n - - - - smtpd -o myhostname=server4.dominio.com

Edited by RonanC
Link to comment
Share on other sites

Pessoal boa tarde, consegui fazer o smtp banner responder corretamente quando um servidor conecta no ip ou host correspondente, porém na hora de enviar ele sempre aparece como server1.dominio.com como faço para alterar de acordo, para aparecer server2.domino.com e por ai vai... ???

 

Received: from server1.dominio.com ([XX.XX.XX.XX]) by BAY004-MC1F9.hotmail.com with Microsoft SMTPSVC(7.5.7601.22678);
     Sat, 7 Jun 2014 10:41:44 -0700

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

Do you agree with our terms?