Search
Generic filters
Exact matches only

[Ajuda] Saldo MoiP no WHMCS

Fórum Fórum administração design-desenvolvimento-e-commerce [Ajuda] Saldo MoiP no WHMCS

  • Este tópico está vazio.

[Ajuda] Saldo MoiP no WHMCS

  • Medim Host
    Membro

    Oi pessoal. Eu tenho instalado no meu WHMCS a ferramento do Edvan que permite que eu tenha visualizações do meu saldo no MoIP – so que percebo que agora tem dado um erro muito estranho. Aparece uma mensagem dizendo que Não possuo nenhuma transação recorrente. Pouco mais cedo esta normal. Veja abaixo o link da imagem de como esta aparecendo aqui:

    http://awesomescreenshot.com/024ndar93

    Isso é normal?

    Jean Santos
    Membro

    Amigo,

    Se o módulo for do edvan, entre em contato com ele, tenho alguns módulos com ele e quando dá problema vou em busca do Edvan, mesmo sabendo que vou receber a resposta depois de umas 3 horas, raramente respondem posterior abertura do bilhete.. Mas quando respondem pelo menos resolvem : P

    edvan
    Membro

    Dá uma lida em http://www.whmcs.blog.br/principal/atualizacao-script-saldo-moip/ lá vai ter a resposta para seu problema!

    Medim Host
    Membro
    Dá uma lida em http://www.whmcs.blog.br/principal/atualizacao-script-saldo-moip/ lá vai ter a resposta para seu problema!

    Mais neste caso, só não ficará visível se for = a R$ 0,00, correto? – mais o meu não está zero. Tenho saldo a receber, tenho saldo disponível para saque. A não que esteja errado pelo o que entendi

    edvan
    Membro

    Dá uma lida nos comentários… o script não está rodando, isso é bloqueio!

    Medim Host
    Membro
    Dá uma lida nos comentários… o script não está rodando, isso é bloqueio!

    Não consegui. Segui as mensagens, fiz as alterações e mesmo assim nao deu.

    edvan
    Membro

    Certamente você habilitou o “open_basedir” e com isso o script não irá funcionar!

    Medim Host
    Membro

    existe algum outro meio que eu possa desabilita-lo? Estava lendo com mais atenção os comentários no Blog WHMCS, e fiz tudo que eu pude entender, so que mesmo assim nao deu certo.

    Anônimo
    Convidado
    existe algum outro meio que eu possa desabilita-lo? Estava lendo com mais atenção os comentários no Blog WHMCS, e fiz tudo que eu pude entender, so que mesmo assim nao deu certo.

    Sim, no próprio WHM.

    Medim Host
    Membro
    Sim, no próprio WHM.

    E quais os “contras” dessa opção ser desabilitada?

    Medim Host
    Membro

    O “open_basedir” pode trabalhar desabilitado sem que há problemas? Realmente foi isso que aconteceu, ele foi habilitado e depois disso perdi o contato com o saldo MoIP.

    henrique
    Membro

    Aqui também não funciona nem o da Angélica (MoIP + Pagseguro) e nem o do Edvan.

    Fiz o que esta nos tutoriais e não consegui até agora…………..

    Tenho saldo disponível para saque nas duas contas.

    Medim Host
    Membro

    Aqui funcionava até ontem mais cedo. So que ai o open_basedir foi habilitado, devido a tentativas de ataques.. dai em diante não funciona mais.. – Segui o passo a passo dos comentários, mesmo assim, fiz tudo que estava lá e sinceramente não funcionou. Parece que um Carlos Sidnei que estava com a mesma dificuldade la nos comentários tambem continua.. pelo menos nao vi ele respondendo dizendo que tinha conseguido..

    edvan
    Membro
    Aqui funcionava até ontem mais cedo. So que ai o open_basedir foi habilitado, devido a tentativas de ataques.. dai em diante não funciona mais.. – Segui o passo a passo dos comentários, mesmo assim, fiz tudo que estava lá e sinceramente não funcionou. Parece que um Carlos Sidnei que estava com a mesma dificuldade la nos comentários tambem continua.. pelo menos nao vi ele respondendo dizendo que tinha conseguido..

    Você não ativou o open_basedir pois leu em um post que “aumentava a segurança”?

    Faz assim no arquivo após a linha 26 do arquivo MoIPStatus.php insira:

    ini_set(“error_reporting”,E_ALL);

    Posta o resultado aqui pra nós!

    Depois tenta refazer os testes abaixo:

    No arquivo MoIPStatus.php linha 32 altera para

    if (ini_get(‘open_basedir’) == ” && ini_get(‘safe_mode’ == ‘Off’)) curl_setopt($ch, CURLOPT_FOLLOWLOCATION, 1);

    Se mesmo assim não funcionar coloca na linha 28:

    ini_set(‘open_basedir’,’0′);

    e na linha 32

    curl_setopt($ch, CURLOPT_FOLLOWLOCATION ,1);

    Faz assim no arquivo após a linha 26 do arquivo MoIPStatus.php insira:

    ini_set(“error_reporting”,E_ALL);

    Aproveitei e fiz o teste aqui

    Veja o erro:

    Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set in /pasta do meu whmcs/MoIPStatus.php on line 33

    Notice: Undefined offset: 1 in /pasta do meu whmcs/saldos-extrato.php on line 69

    Notice: Undefined offset: 2 in /pasta do meu whmcs/saldos-extrato.php on line 70

    Notice: Undefined offset: 3 in /pasta do meu whmcs/saldos-extrato.php on line 71

    Notice: Undefined offset: 4 in /pasta do meu whmcs/saldos-extrato.php on line 72

    edvan
    Membro

    A linha abaixo deveria resolver pois alguns já utilizaram e deu certo!

    if (ini_get(‘open_basedir’) == ” && ini_get(‘safe_mode’ == ‘Off’)) curl_setopt($ch, CURLOPT_FOLLOWLOCATION, 1);

    Certamente o ini_get não está conseguindo ser inicializado via código.

    Tenta iniciar ele via .htacess ou php.ini apenas para essa pasta.

    Medim Host
    Membro

    Eu fiz o teste aqui e o teste deu igual ao do @chuva – Não ha necessidade de postar, pois está exatamente igual.

    if (ini_get(‘open_basedir’) == ” && ini_get(‘safe_mode’ == ‘Off’)) curl_setopt($ch, CURLOPT_FOLLOWLOCATION, 1);

    Ainda assim, colocando essa linha 32, não funciona..

    Você não ativou o open_basedir pois leu em um post que “aumentava a segurança”?

    Sim, eu li isso em outros foruns, inclusive no seu blog tem um comentário que diz isso

    Olá Edvan, ontem eu alterei a segurança do servidor, adicionei uma linha manualmente na configuração do php de proteção “open_basedir”… / … Eu preferi fazer essa modificação de segurança, porque sem ela, qualquer cliente poderia enviar um arquivo malicioso p/ servidor e ter acesso a todas as contas

    edvan
    Membro

    Então tenta lê os artigos e tentar adaptar para sua necessidade:

    http://www.edmondscommerce.co.uk/curl/php-curl-curlopt_followlocation-and-open_basedir-or-safe-mode/

    http://www.francesco-castaldo.com/2009/10/warning-curl_setopt-function-curl-setopt-curlopt_followlocation-cannot-be-activated-when-in-safe_mode-or-an-open_basedir-is-set/

    Ou entra em contato com seu suporte ( datacenter ) e verifica a possibilidade de liberar a função apenas para o script via php.ini ou .htaccess.

    Infelizmente estou com outras prioridades e não tenho como adaptar o script para essa restrição.

    edvan
    Membro
    Eu fiz o teste aqui e o teste deu igual ao do @chuva – Não ha necessidade de postar, pois está exatamente igual.

    Ainda assim, colocando essa linha 32, não funciona..

    Sim, eu li isso em outros foruns, inclusive no seu blog tem um comentário que diz isso

    Tem uma luz no fim do túnel… tem um comentário aguardando moderação!

    Tem uma luz no fim do túnel… tem um comentário aguardando moderação!

    Vou olhar depois la em seu blog Edvan…tentei acessar pelo tablet, mas nao carregou os comentarios la do disque.

Visualizando 20 posts - 1 até 20 (de 28 do total)

O tópico ‘[Ajuda] Saldo MoiP no WHMCS’ está fechado para novas respostas.

    Members
  • Active
  • New
  • Online
  • Groups
  • Active
  • Newest
Dark mode