Jump to content

Não consigo gerar um certificado do Let's Encrypt no virtualizor


Sammy
 Share

Recommended Posts

34 minutos atrás, Sammy disse:

Resumindo tudo, eu anteriormente tinha colocado um certificado de outra autoridade e recentemente ele expirou, e quando tento instalar um novo, pelo proprio painel do virtualizor, diz o que aparece no print abaixo, alguém sabe resolver?

 

Capturar.PNG

Pela mensagem, o domínio não aponta para o servidor, veja se o proxy do cloudflare não está ativo ou coisa do tipo.

Link to comment
Share on other sites

4 horas atrás, LucianoZ disse:

Posta o log.

image.png.d5d23a02fba35e0103f272f64027b77c.png

4 horas atrás, Marks disse:

Pela mensagem, o domínio não aponta para o servidor, veja se o proxy do cloudflare não está ativo ou coisa do tipo.

Já fiz isso e não deu certo, até tentei ativar o acesso web do IP para o dominio buscar o DNS, e ainda sim, o erro persiste.

2 horas atrás, AngelCosta disse:

Desabilita as nuvens do cloudflare temporariamente para poder gerar o certificado inicial. Depois disto, poderá reativá-las.

Se o domínio é novo, esperas propagar.

O dominio está ativo há algum tempo e funcionando normalmente, no caso, estou tentando usar um subdominio no virtualizor, mas sem sucesso de conseguir usar o proprio gerador do painel.

Link to comment
Share on other sites

Em 12/01/2022 em 15:34, AngelCosta disse:

Se chegarem a uma solução, lembrem de deixar aqui para ajudar os próximos.

Inicialmente o problema foi a falta de DNS configurado no meu servidor, esse primeiro fator foi resolvido adicionando nas seguintes partes

etc/resolv.conf
etc/hosts

nameserver 8.8.8.8 (resolv.conf)
nameserver 8.8.4.4 (resolv.conf)

1.1.1.1. virtualizor virtualizor.seudominio.com.br (hosts)

todo processo foi usando nano pelo SSH

nano /etc/resolv.conf e o mesmo para hosts

 

depois o @Vittor novamenete deu ping no google e retornou o resultado.

outro impasse que meu servidor tinha para ser possivel gerar um certificado, era que a licença não tinha atualizado a data de renovação, constava como expirava, bastou clicar em atualizar licença e pronto.

o terceiro e ultimo empecilho foi simplesmente o fato da opção Staging estar habilitada, nas tentativas mal sucedidas de ativar o certificado, o certificado era o de teste e não o de produção, então o browser retornava error.

Obrigado a todos que se dispuseram a me ajudar, e a solução do meu problema foi graças ao @Vittor

 

Edited by Sammy
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...

te

te